about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-03-13 18:00:52 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-03-14 18:44:42 -0400
commitf79f80dbf267036a96f8eae281c8501482756d03 (patch)
treed2e37a9947ee5b952282025a5f5f5c4bf2090a7f /pkgs/applications
parent2d1d83d836e09e50469302101955ea6c58dcd206 (diff)
downloadnixlib-f79f80dbf267036a96f8eae281c8501482756d03.tar
nixlib-f79f80dbf267036a96f8eae281c8501482756d03.tar.gz
nixlib-f79f80dbf267036a96f8eae281c8501482756d03.tar.bz2
nixlib-f79f80dbf267036a96f8eae281c8501482756d03.tar.lz
nixlib-f79f80dbf267036a96f8eae281c8501482756d03.tar.xz
nixlib-f79f80dbf267036a96f8eae281c8501482756d03.tar.zst
nixlib-f79f80dbf267036a96f8eae281c8501482756d03.zip
treewide: get rid of platforms.allBut
Negative reasoning like `allBut` is a bad idea with an open world of
platforms. Concretely, if we add a new, quite different sort of
platform, existing packages with `allBut` will claim they work on it
even though they probably won't.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/ahoviewer/default.nix4
-rw-r--r--pkgs/applications/window-managers/i3/lock-color.nix2
2 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/applications/graphics/ahoviewer/default.nix b/pkgs/applications/graphics/ahoviewer/default.nix
index 2d42a479999b..b7647803b3d3 100644
--- a/pkgs/applications/graphics/ahoviewer/default.nix
+++ b/pkgs/applications/graphics/ahoviewer/default.nix
@@ -37,7 +37,9 @@ stdenv.mkDerivation rec {
     description = "A GTK2 image viewer, manga reader, and booru browser";
     maintainers = with maintainers; [ skrzyp xzfc ];
     license = licenses.mit;
-    platforms = platforms.allBut [ "darwin" "cygwin" ];
+    # Unintentionally not working on Darwin:
+    # https://github.com/ahodesuka/ahoviewer/issues/62
+    platforms = platforms.linux;
   };
 }
 
diff --git a/pkgs/applications/window-managers/i3/lock-color.nix b/pkgs/applications/window-managers/i3/lock-color.nix
index ec1673f5040d..edaa88bde23d 100644
--- a/pkgs/applications/window-managers/i3/lock-color.nix
+++ b/pkgs/applications/window-managers/i3/lock-color.nix
@@ -34,6 +34,6 @@ stdenv.mkDerivation rec {
 
     # Needs the SSE2 instruction set. See upstream issue
     # https://github.com/chrjguill/i3lock-color/issues/44
-    platforms = platforms.i686 ++ platforms.x86_64;
+    platforms = platforms.x86;
   };
 }