about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorArseniy Seroka <ars.seroka@gmail.com>2016-04-27 00:04:14 +0300
committerArseniy Seroka <ars.seroka@gmail.com>2016-04-27 11:38:09 +0300
commitf6d7cefa7ba6429ec2a324ac3ae1fcefb45bdf0b (patch)
tree283a2327faf7d4d563eeccda3952de376a29de89 /pkgs/applications
parent9765e5835f8e4daf5a8c50515688814e64501124 (diff)
downloadnixlib-f6d7cefa7ba6429ec2a324ac3ae1fcefb45bdf0b.tar
nixlib-f6d7cefa7ba6429ec2a324ac3ae1fcefb45bdf0b.tar.gz
nixlib-f6d7cefa7ba6429ec2a324ac3ae1fcefb45bdf0b.tar.bz2
nixlib-f6d7cefa7ba6429ec2a324ac3ae1fcefb45bdf0b.tar.lz
nixlib-f6d7cefa7ba6429ec2a324ac3ae1fcefb45bdf0b.tar.xz
nixlib-f6d7cefa7ba6429ec2a324ac3ae1fcefb45bdf0b.tar.zst
nixlib-f6d7cefa7ba6429ec2a324ac3ae1fcefb45bdf0b.zip
esteidfirefoxplugin: init at 3.12.1.1142
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/firefox/wrapper.nix2
-rw-r--r--pkgs/applications/networking/browsers/mozilla-plugins/esteidfirefoxplugin/default.nix45
2 files changed, 47 insertions, 0 deletions
diff --git a/pkgs/applications/networking/browsers/firefox/wrapper.nix b/pkgs/applications/networking/browsers/firefox/wrapper.nix
index 5fb887bda220..1904d720dbd3 100644
--- a/pkgs/applications/networking/browsers/firefox/wrapper.nix
+++ b/pkgs/applications/networking/browsers/firefox/wrapper.nix
@@ -6,6 +6,7 @@
 , supportsJDK, jrePlugin, icedtea_web
 , trezor-bridge, bluejeans, djview4, adobe-reader
 , google_talk_plugin, fribid, gnome3/*.gnome_shell*/
+, esteidfirefoxplugin
 }:
 
 ## configurability of the wrapper itself
@@ -42,6 +43,7 @@ let
       ++ lib.optional (cfg.enableTrezor or false) trezor-bridge
       ++ lib.optional (cfg.enableBluejeans or false) bluejeans
       ++ lib.optional (cfg.enableAdobeReader or false) adobe-reader
+      ++ lib.optional (cfg.enableEsteid or false) esteidfirefoxplugin
      );
   libs = [ gst_all.gstreamer gst_all.gst-plugins-base ]
          ++ lib.optionals (cfg.enableQuakeLive or false)
diff --git a/pkgs/applications/networking/browsers/mozilla-plugins/esteidfirefoxplugin/default.nix b/pkgs/applications/networking/browsers/mozilla-plugins/esteidfirefoxplugin/default.nix
new file mode 100644
index 000000000000..039d8bbe4060
--- /dev/null
+++ b/pkgs/applications/networking/browsers/mozilla-plugins/esteidfirefoxplugin/default.nix
@@ -0,0 +1,45 @@
+{ stdenv, fetchurl, gtk2, openssl, pcsclite, pkgconfig, opensc }:
+
+stdenv.mkDerivation rec {
+  version = "3.12.1.1142";
+  name = "esteidfirefoxplugin-${version}";
+
+  src = fetchurl {
+    url = "https://installer.id.ee/media/ubuntu/pool/main/e/esteidfirefoxplugin/esteidfirefoxplugin_3.12.1.1142.orig.tar.xz";
+    sha256 = "0y7759x1xr00p5r3c5wpllcqqnnxh2zi74cmy4m9m690z3ywn0fx";
+  };
+
+  unpackPhase = ''
+    mkdir src
+    tar xf $src -C src
+    cd src
+  '';
+
+  buildInputs = [ gtk2 openssl pcsclite pkgconfig opensc ];
+
+  buildPhase = ''
+    sed -i "s|opensc-pkcs11.so|${opensc}/lib/pkcs11/opensc-pkcs11.so|" Makefile 
+    make plugin
+  '';
+
+  installPhase = ''
+    plugins=$out/lib/mozilla/plugins
+    mkdir -p $plugins
+    cp -a npesteid-firefox-plugin.so $plugins/
+    rp=$(patchelf --print-rpath $plugins/npesteid-firefox-plugin.so)
+    patchelf --set-rpath "$rp:${opensc}/lib:${opensc}/lib/pkcs11" $plugins/npesteid-firefox-plugin.so
+  '';
+
+  passthru.mozillaPlugin = "/lib/mozilla/plugins";
+
+  dontStrip = true;
+  dontPatchELF = true;
+
+  meta = with stdenv.lib; {
+    description = "Firefox ID card signing plugin";
+    homepage = "http://www.id.ee/";
+    license = licenses.lgpl2;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.jagajaga ];
+  };
+}