about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2020-01-31 00:38:47 +0100
committerGitHub <noreply@github.com>2020-01-31 00:38:47 +0100
commitf65f6338fa7f7d81913a5ab623ebc06e2b698511 (patch)
tree4366b1d801c66304f935d3976ea59ed1b5a4488d /pkgs/applications
parent6ea79d2707e099fc5e35b22b7713a95e80def99d (diff)
parent00a8de028e93ffc3a2b4bab0c90da3a9d1c62669 (diff)
downloadnixlib-f65f6338fa7f7d81913a5ab623ebc06e2b698511.tar
nixlib-f65f6338fa7f7d81913a5ab623ebc06e2b698511.tar.gz
nixlib-f65f6338fa7f7d81913a5ab623ebc06e2b698511.tar.bz2
nixlib-f65f6338fa7f7d81913a5ab623ebc06e2b698511.tar.lz
nixlib-f65f6338fa7f7d81913a5ab623ebc06e2b698511.tar.xz
nixlib-f65f6338fa7f7d81913a5ab623ebc06e2b698511.tar.zst
nixlib-f65f6338fa7f7d81913a5ab623ebc06e2b698511.zip
Merge pull request #77796 from 101100/fix-quodlibet
quodlibet: fix tests
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/quodlibet/default.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/pkgs/applications/audio/quodlibet/default.nix b/pkgs/applications/audio/quodlibet/default.nix
index 573dca518e3a..597cf68f4d09 100644
--- a/pkgs/applications/audio/quodlibet/default.nix
+++ b/pkgs/applications/audio/quodlibet/default.nix
@@ -18,7 +18,7 @@ python3.pkgs.buildPythonApplication rec {
 
   nativeBuildInputs = [ wrapGAppsHook gettext ];
 
-  checkInputs = with python3.pkgs; [ pytest pytest_xdist pyflakes pycodestyle polib xvfb_run dbus.daemon glibcLocales ];
+  checkInputs = [ gdk-pixbuf ] ++ (with python3.pkgs; [ pytest pytest_xdist polib xvfb_run dbus.daemon glibcLocales ]);
 
   buildInputs = [ gnome3.adwaita-icon-theme libsoup glib glib-networking gtk3 webkitgtk gdk-pixbuf keybinder3 gtksourceview libmodplug libappindicator-gtk3 kakasi gobject-introspection ]
     ++ (if xineBackend then [ xineLib ] else with gst_all_1;
@@ -33,13 +33,23 @@ python3.pkgs.buildPythonApplication rec {
 
   LC_ALL = "en_US.UTF-8";
 
+  pytestFlags = stdenv.lib.optionals (xineBackend || !withGstPlugins) [
+    "--ignore=tests/plugin/test_replaygain.py"
+  ] ++ [
+    # upstream does actually not enforce source code linting
+    "--ignore=tests/quality"
+    # build failure on Arch Linux
+    # https://github.com/NixOS/nixpkgs/pull/77796#issuecomment-575841355
+    "--ignore=tests/test_operon.py"
+  ];
+
   checkPhase = ''
     runHook preCheck
-    env XDG_DATA_DIRS="$out/share:${gtk3}/share/gsettings-schemas/${gtk3.name}:$XDG_DATA_DIRS" \
+    env XDG_DATA_DIRS="$out/share:${gtk3}/share/gsettings-schemas/${gtk3.name}:$XDG_ICON_DIRS:$XDG_DATA_DIRS" \
       HOME=$(mktemp -d) \
       xvfb-run -s '-screen 0 800x600x24' dbus-run-session \
         --config-file=${dbus.daemon}/share/dbus-1/session.conf \
-        py.test${stdenv.lib.optionalString (xineBackend || !withGstPlugins) " --ignore=tests/plugin/test_replaygain.py"}
+        py.test $pytestFlags
     runHook postCheck
   '';
 
@@ -65,6 +75,5 @@ python3.pkgs.buildPythonApplication rec {
 
     maintainers = with maintainers; [ coroa sauyon ];
     homepage = https://quodlibet.readthedocs.io/en/latest/;
-    broken = true;
   };
 }