about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAttila Sztupak <attila.sztupak@gmail.com>2014-09-26 15:33:17 +0100
committerAttila Sztupak <attila.sztupak@gmail.com>2014-09-26 15:33:17 +0100
commitf1be508a09f3d8a05c0326bb9ecbe25cdb40d04e (patch)
tree3ca0b2d5354bd40664231f65ea706795f3945986 /pkgs/applications
parent1cd727180eeb60e1c4f6ead96be614431624830f (diff)
downloadnixlib-f1be508a09f3d8a05c0326bb9ecbe25cdb40d04e.tar
nixlib-f1be508a09f3d8a05c0326bb9ecbe25cdb40d04e.tar.gz
nixlib-f1be508a09f3d8a05c0326bb9ecbe25cdb40d04e.tar.bz2
nixlib-f1be508a09f3d8a05c0326bb9ecbe25cdb40d04e.tar.lz
nixlib-f1be508a09f3d8a05c0326bb9ecbe25cdb40d04e.tar.xz
nixlib-f1be508a09f3d8a05c0326bb9ecbe25cdb40d04e.tar.zst
nixlib-f1be508a09f3d8a05c0326bb9ecbe25cdb40d04e.zip
crashplan: [new-package] an online/offline backup solution
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/backup/crashplan/CrashPlanEngine.patch37
-rw-r--r--pkgs/applications/backup/crashplan/default.nix77
2 files changed, 114 insertions, 0 deletions
diff --git a/pkgs/applications/backup/crashplan/CrashPlanEngine.patch b/pkgs/applications/backup/crashplan/CrashPlanEngine.patch
new file mode 100644
index 000000000000..de2afe2da684
--- /dev/null
+++ b/pkgs/applications/backup/crashplan/CrashPlanEngine.patch
@@ -0,0 +1,37 @@
+--- ./scripts/CrashPlanEngine	2014-02-19 23:17:19.000000000 +0000
++++ ./scripts/CrashPlanEngine.1	2014-07-24 17:36:37.330333581 +0100
+@@ -11,7 +11,7 @@
+ 	
+ 	cd $TARGETDIR
+ 		
+-	nice -n 19 $JAVACOMMON $SRV_JAVA_OPTS -classpath $FULL_CP com.backup42.service.CPService > $TARGETDIR/log/engine_output.log 2> $TARGETDIR/log/engine_error.log & 
++	nice -n 19 $JAVACOMMON $SRV_JAVA_OPTS -classpath $FULL_CP com.backup42.service.CPService > $VARDIR/log/engine_output.log 2> $VARDIR/log/engine_error.log & 
+ 	
+ 	if [[ $! -gt 0 ]]; then
+ 		echo $! > $PIDFILE
+@@ -26,7 +26,7 @@
+ 
+ 	echo "Using Ubuntu 9.04 startup"
+ 	
+-	start-stop-daemon -v --pidfile $PIDFILE --make-pidfile --background --chdir $TARGETDIR --start --nicelevel 19 --exec $JAVACOMMON -- $SRV_JAVA_OPTS -classpath $FULL_CP com.backup42.service.CPService > $TARGETDIR/log/engine_output.log 2> $TARGETDIR/log/engine_error.log
++	start-stop-daemon -v --pidfile $PIDFILE --make-pidfile --background --chdir $TARGETDIR --start --nicelevel 19 --exec $JAVACOMMON -- $SRV_JAVA_OPTS -classpath $FULL_CP com.backup42.service.CPService > $VARDIR/log/engine_output.log 2> $VARDIR/log/engine_error.log
+ 	
+ 	# This test isn't as useful as one might like; start-stop-daemon can't accurately report the state of child processes when --background is used.
+ 	# We use this mainly to report the specific error value returned by start-stop-daemon if something goes wrong, but be aware that a return value
+@@ -91,7 +91,6 @@
+ DESC="CrashPlan Engine"
+ NAME=CrashPlanEngine
+ DAEMON=$TARGETDIR/lib/com.backup42.desktop.jar
+-PIDFILE="$TARGETDIR/${NAME}.pid"
+ 
+ if [[ -f $TARGETDIR/install.vars ]]; then
+ 	. $TARGETDIR/install.vars
+@@ -100,6 +99,8 @@
+ 	exit 1
+ fi
+ 
++PIDFILE="$VARDIR/${NAME}.pid"
++
+ if [[ ! -f $DAEMON ]]; then
+ 	echo "Could not find JAR file $DAEMON"
+ 	exit 0
diff --git a/pkgs/applications/backup/crashplan/default.nix b/pkgs/applications/backup/crashplan/default.nix
new file mode 100644
index 000000000000..7988042fe4f6
--- /dev/null
+++ b/pkgs/applications/backup/crashplan/default.nix
@@ -0,0 +1,77 @@
+{ stdenv, fetchurl, makeWrapper, jre, cpio, gawk, gnugrep, gnused, procps, swt, gtk2, glib, libXtst }:
+
+let version = "3.6.3";
+
+in stdenv.mkDerivation rec {
+  name = "crashplan-${version}";
+
+  crashPlanArchive = fetchurl {
+    url = "http://download.crashplan.com/installs/linux/install/CrashPlan/CrashPlan_${version}_Linux.tgz";
+    sha256 = "0v01fzc62bxr6lpamnxg1nb7vh4a8ky6mahbq76kmjxfqv7q0mb0";
+  };
+
+  srcs = [ crashPlanArchive ];
+
+  meta = {
+    description = "An online/offline backup solution";
+    homepage = "http://www.crashplan.org";
+    license = stdenv.lib.licenses.unfree;
+  };
+
+  buildInputs = [ makeWrapper cpio ];
+
+  vardir = "/var/lib/crashplan";
+
+  manifestdir = "${vardir}/manifest";
+
+  patches = [ ./CrashPlanEngine.patch ];
+
+  installPhase = ''
+    mkdir $out
+    zcat -v CrashPlan_${version}.cpi | (cd $out; cpio -i -d -v --no-preserve-owner)
+
+    # sed -i "s|<manifestPath>manifest</manifestPath>|<manifestPath>${manifestdir}</manifestPath>|g" $out/conf/default.service.xml
+
+    # Fix for encoding troubles (CrashPlan ticket 178827)
+    # Make sure the daemon is running using the same localization as
+    # the (installing) user
+    echo "" >> run.conf
+    echo "export LC_ALL=en_US.UTF-8" >> run.conf
+
+    install -d -m 755 unpacked $out
+
+    install -D -m 644 EULA.txt $out/EULA.txt
+    install -D -m 644 run.conf $out/bin/run.conf
+    install -D -m 755 scripts/CrashPlanDesktop $out/bin/CrashPlanDesktop
+    install -D -m 755 scripts/CrashPlanEngine $out/bin/CrashPlanEngine
+
+    rm -r $out/log
+    ln -s $vardir/log $out/log
+    ln -s $vardir/cache $out/cache
+    ln -s $vardir/backupArchives $out/backupArchives
+    ln -s $vardir/conf/service.model $out/conf/service.model
+    ln -s $vardir/conf/my.service.xml $out/conf/my.service.xml
+
+    echo "JAVACOMMON=${jre}/bin/java" > $out/install.vars
+    echo "APP_BASENAME=CrashPlan" >> $out/install.vars
+    echo "TARGETDIR=$out" >> $out/install.vars
+    echo "BINSDIR=$out/bin" >> $out/install.vars
+    echo "MANIFESTDIR=${manifestdir}" >> $out/install.vars
+    echo "VARDIR=${vardir}" >> $out/install.vars
+    echo "INITDIR=" >> $out/install.vars
+    echo "RUNLVLDIR=" >> $out/install.vars
+    echo "INSTALLDATE=" >> $out/install.vars
+  '';
+
+  postFixup = ''
+    for f in $out/bin/CrashPlanDesktop $out/bin/CrashPlanEngine; do
+      echo "substitutions in $f"
+      substituteInPlace $f --replace /bin/ps  ${procps}/bin/ps
+      substituteInPlace $f --replace awk      ${gawk}/bin/awk
+      substituteInPlace $f --replace sed      ${gnused}/bin/sed
+      substituteInPlace $f --replace grep     ${gnugrep}/bin/grep
+    done
+
+    wrapProgram $out/bin/CrashPlanDesktop --prefix LD_LIBRARY_PATH ":" "${gtk2}/lib:${glib}/lib:${libXtst}/lib"
+  '';
+}