about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorYureka <yuka@yuka.dev>2021-09-03 12:03:25 +0200
committerYureka <yuka@yuka.dev>2021-09-03 13:23:45 +0200
commitf007b794c758000a275b00dd0695d2fb155195f0 (patch)
tree4e3919c40c91ec170078c95b9a245c2c04419cbd /pkgs/applications
parent6ede6d2740c0625531b58d69d5a80a06821c6635 (diff)
downloadnixlib-f007b794c758000a275b00dd0695d2fb155195f0.tar
nixlib-f007b794c758000a275b00dd0695d2fb155195f0.tar.gz
nixlib-f007b794c758000a275b00dd0695d2fb155195f0.tar.bz2
nixlib-f007b794c758000a275b00dd0695d2fb155195f0.tar.lz
nixlib-f007b794c758000a275b00dd0695d2fb155195f0.tar.xz
nixlib-f007b794c758000a275b00dd0695d2fb155195f0.tar.zst
nixlib-f007b794c758000a275b00dd0695d2fb155195f0.zip
gitlab: add back grpc patch
They downgraded grpc in the fix release
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/gitlab/default.nix6
-rw-r--r--pkgs/applications/version-management/gitlab/fix-grpc-ar.patch10
-rw-r--r--pkgs/applications/version-management/gitlab/gitaly/default.nix10
3 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/applications/version-management/gitlab/default.nix b/pkgs/applications/version-management/gitlab/default.nix
index c8480fcc0736..26d8cb1732fd 100644
--- a/pkgs/applications/version-management/gitlab/default.nix
+++ b/pkgs/applications/version-management/gitlab/default.nix
@@ -22,6 +22,12 @@ let
     gemset =
       let x = import (gemdir + "/gemset.nix");
       in x // {
+        # grpc expects the AR environment variable to contain `ar rpc`. See the
+        # discussion in nixpkgs #63056.
+        grpc = x.grpc // {
+          patches = [ ./fix-grpc-ar.patch ];
+          dontBuild = false;
+        };
         # the openssl needs the openssl include files
         openssl = x.openssl // {
           buildInputs = [ openssl ];
diff --git a/pkgs/applications/version-management/gitlab/fix-grpc-ar.patch b/pkgs/applications/version-management/gitlab/fix-grpc-ar.patch
new file mode 100644
index 000000000000..9b95e668e045
--- /dev/null
+++ b/pkgs/applications/version-management/gitlab/fix-grpc-ar.patch
@@ -0,0 +1,10 @@
+--- a/src/ruby/ext/grpc/extconf.rb
++++ b/src/ruby/ext/grpc/extconf.rb
+@@ -27,6 +27,7 @@ ENV['MACOSX_DEPLOYMENT_TARGET'] = '10.7'
+ if ENV['AR'].nil? || ENV['AR'].size == 0
+     ENV['AR'] = RbConfig::CONFIG['AR'] + ' rcs'
+ end
++ENV['AR'] = ENV['AR'] + ' rcs'
+ if ENV['CC'].nil? || ENV['CC'].size == 0
+     ENV['CC'] = RbConfig::CONFIG['CC']
+ end
diff --git a/pkgs/applications/version-management/gitlab/gitaly/default.nix b/pkgs/applications/version-management/gitlab/gitaly/default.nix
index 7a80d8de4c05..07a9a297a034 100644
--- a/pkgs/applications/version-management/gitlab/gitaly/default.nix
+++ b/pkgs/applications/version-management/gitlab/gitaly/default.nix
@@ -9,6 +9,16 @@ let
     inherit ruby;
     copyGemFiles = true;
     gemdir = ./.;
+    gemset =
+      let x = import (gemdir + "/gemset.nix");
+      in x // {
+        # grpc expects the AR environment variable to contain `ar rpc`. See the
+        # discussion in nixpkgs #63056.
+        grpc = x.grpc // {
+          patches = [ ../fix-grpc-ar.patch ];
+          dontBuild = false;
+        };
+      };
   };
   version = "14.2.3";
   gitaly_package = "gitlab.com/gitlab-org/gitaly/v${lib.versions.major version}";