about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTomo <68489118+Tomodachi94@users.noreply.github.com>2024-02-01 14:35:04 -0800
committerTomo <68489118+Tomodachi94@users.noreply.github.com>2024-03-22 11:12:44 -0700
commitee181285b1ed88c52d08fbecd36b913987526fd8 (patch)
treea18474ba262bc9580db1e561254b25c1e60d76e9 /pkgs/applications
parenta819aea202336a32c658db4ce46300cdfb4399fb (diff)
downloadnixlib-ee181285b1ed88c52d08fbecd36b913987526fd8.tar
nixlib-ee181285b1ed88c52d08fbecd36b913987526fd8.tar.gz
nixlib-ee181285b1ed88c52d08fbecd36b913987526fd8.tar.bz2
nixlib-ee181285b1ed88c52d08fbecd36b913987526fd8.tar.lz
nixlib-ee181285b1ed88c52d08fbecd36b913987526fd8.tar.xz
nixlib-ee181285b1ed88c52d08fbecd36b913987526fd8.tar.zst
nixlib-ee181285b1ed88c52d08fbecd36b913987526fd8.zip
vscode-extensions.jackmacwindows.craftos-pc: init at 1.2.2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/vscode/extensions/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/pkgs/applications/editors/vscode/extensions/default.nix b/pkgs/applications/editors/vscode/extensions/default.nix
index 11db90fa4050..5ff4a7338a1c 100644
--- a/pkgs/applications/editors/vscode/extensions/default.nix
+++ b/pkgs/applications/editors/vscode/extensions/default.nix
@@ -18,6 +18,7 @@
 , clojure-lsp
 , alejandra
 , millet
+, craftos-pc
 , shfmt
 , typst-lsp
 , typst-preview
@@ -1991,6 +1992,39 @@ let
         };
       };
 
+      jackmacwindows.craftos-pc = buildVscodeMarketplaceExtension {
+        mktplcRef = {
+          name = "craftos-pc";
+          publisher = "jackmacwindows";
+          version = "1.2.2";
+          sha256 = "sha256-A+MNroXv0t9Mw/gr0Fyov3cXyF/GGzwRLKrIxQ2tKCE=";
+        };
+        nativeBuildInputs = [ jq moreutils ];
+        postInstall = ''
+          cd "$out/$installPrefix"
+
+          jq -e '
+            .contributes.configuration.properties."craftos-pc.executablePath.linux".default =
+              "${lib.meta.getExe craftos-pc}" |
+            .contributes.configuration.properties."craftos-pc.executablePath.mac".default =
+              "${lib.meta.getExe craftos-pc}" |
+            .contributes.configuration.properties."craftos-pc.executablePath.windows".default =
+              "${lib.meta.getExe craftos-pc}"
+          ' \
+          < package.json \
+          | sponge package.json
+        '';
+        meta = {
+          changelog = "https://marketplace.visualstudio.com/items/jackmacwindows.craftos-pc/changelog";
+          description = "A Visual Studio Code extension for opening a CraftOS-PC window";
+          downloadPage = "https://marketplace.visualstudio.com/items?itemName=jackmacwindows.craftos-pc";
+          homepage = "https://www.craftos-pc.cc/docs/extension";
+          license = lib.licenses.mit;
+          maintainers = with lib.maintainers; [ tomodachi94 ];
+          platforms = craftos-pc.meta.platforms;
+        };
+      };
+
       james-yu.latex-workshop = buildVscodeMarketplaceExtension {
         mktplcRef = {
           name = "latex-workshop";