about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorDaniel Schaefer <git@danielschaefer.me>2019-05-28 13:37:14 +0200
committerRenaud <c0bw3b@users.noreply.github.com>2019-05-28 13:37:13 +0200
commiteccb90a2d997d65dc514253b441e515d8e0241c3 (patch)
treeefc5f624b82871db026e0585fd3d06d42fb20d75 /pkgs/applications
parent53b08beea6eebf82a488cb1c12d59cfbfbc5c5f2 (diff)
downloadnixlib-eccb90a2d997d65dc514253b441e515d8e0241c3.tar
nixlib-eccb90a2d997d65dc514253b441e515d8e0241c3.tar.gz
nixlib-eccb90a2d997d65dc514253b441e515d8e0241c3.tar.bz2
nixlib-eccb90a2d997d65dc514253b441e515d8e0241c3.tar.lz
nixlib-eccb90a2d997d65dc514253b441e515d8e0241c3.tar.xz
nixlib-eccb90a2d997d65dc514253b441e515d8e0241c3.tar.zst
nixlib-eccb90a2d997d65dc514253b441e515d8e0241c3.zip
compton: 0.1_beta2.5 -> 6.2 (#61681)
* compton-git: 5.1-rc2 -> 6.2

vsync is now a boolean option, see:
https://github.com/yshui/compton/pull/130

menu-opacity is deprecated and there's a warning that says:
Please use the wintype option `opacity` of `popup_menu` and
`dropdown_menu` instead.

* nixos/compton: Keep vSync option backwards compatible

The new upstream option tries to make the best choice for the user.
Therefore the behaviour should stay the same with this backwards
compatibility patch.

* compton-git: Remove DRM option

It's deprecated and shouldn't be used.
https://github.com/yshui/compton/pull/130/files#r285505456

* compton-git: Remove new_backends option

Was removed in "Let old/new backends co-exist"
b0c5db9f5aa500dc3568cc6fe68493df98794d4d

* compton: 0.1_beta2.5 -> 6.2

Drop the legacy, unmaintained version and use the fork for real.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/window-managers/compton/default.nix157
1 files changed, 57 insertions, 100 deletions
diff --git a/pkgs/applications/window-managers/compton/default.nix b/pkgs/applications/window-managers/compton/default.nix
index 2c388c941e6c..60607ea89d15 100644
--- a/pkgs/applications/window-managers/compton/default.nix
+++ b/pkgs/applications/window-managers/compton/default.nix
@@ -3,110 +3,67 @@
 , xorgproto, libxcb ,xcbutilrenderutil, xcbutilimage, pixman, libev
 , dbus, libconfig, libdrm, libGL, pcre, libX11, libXcomposite, libXdamage
 , libXinerama, libXrandr, libXrender, libXext, xwininfo, libxdg_basedir }:
+stdenv.mkDerivation rec {
+  pname = "compton";
+  version = "6.2";
 
-let
-  common = source: stdenv.mkDerivation (source // rec {
-    name = "${source.pname}-${source.version}";
+  COMPTON_VERSION = "v${version}";
 
-    nativeBuildInputs = (source.nativeBuildInputs or []) ++ [
-      pkgconfig
-      asciidoc
-      docbook_xml_dtd_45
-      docbook_xsl
-      makeWrapper
-    ];
-
-    installFlags = [ "PREFIX=$(out)" ];
-
-    postInstall = ''
-      wrapProgram $out/bin/compton-trans \
-        --prefix PATH : ${lib.makeBinPath [ xwininfo ]}
-    '';
-
-    meta = with lib; {
-      description = "A fork of XCompMgr, a sample compositing manager for X servers";
-      longDescription = ''
-        A fork of XCompMgr, which is a sample compositing manager for X
-        servers supporting the XFIXES, DAMAGE, RENDER, and COMPOSITE
-        extensions. It enables basic eye-candy effects. This fork adds
-        additional features, such as additional effects, and a fork at a
-        well-defined and proper place.
-      '';
-      license = licenses.mit;
-      maintainers = with maintainers; [ ertes enzime twey ];
-      platforms = platforms.linux;
-    };
-  });
-
-  stableSource = rec {
-    pname = "compton";
-    version = "0.1_beta2.5";
-
-    COMPTON_VERSION = version;
-
-    buildInputs = [
-      dbus libX11 libXcomposite libXdamage libXrender libXrandr libXext
-      libXinerama libdrm pcre libxml2 libxslt libconfig libGL
-    ];
-
-    src = fetchFromGitHub {
-      owner = "chjj";
-      repo = "compton";
-      rev = "b7f43ee67a1d2d08239a2eb67b7f50fe51a592a8";
-      sha256 = "1p7ayzvm3c63q42na5frznq3rlr1lby2pdgbvzm1zl07wagqss18";
-    };
-
-    meta = {
-      homepage = https://github.com/chjj/compton/;
-    };
+  src = fetchFromGitHub {
+    owner  = "yshui";
+    repo   = "compton";
+    rev    = COMPTON_VERSION;
+    sha256 = "03fi9q8zw2qrwpkmy1bnavgfh91ci9in5fdi17g4s5s0n2l7yil7";
   };
 
-  gitSource = rec {
-    pname = "compton-git";
-    version = "5.1-rc2";
-
-    COMPTON_VERSION = "v${version}";
-
-    nativeBuildInputs = [ meson ninja ];
-
-    src = fetchFromGitHub {
-      owner  = "yshui";
-      repo   = "compton";
-      rev    = COMPTON_VERSION;
-      sha256 = "1qpy76kkhz8gfby842ry7lanvxkjxh4ckclkcjk4xi2wsmbhyp08";
-    };
-
-    buildInputs = [
-      dbus libX11 libXext
-      xorgproto
-      libXinerama libdrm pcre libxml2 libxslt libconfig libGL
-      # Removed:
-      # libXcomposite libXdamage libXrender libXrandr
-
-      # New:
-      libxcb xcbutilrenderutil xcbutilimage
-      pixman libev
-      libxdg_basedir
-    ];
-
-    preBuild = ''
-      git() { echo "v${version}"; }
-      export -f git
+  nativeBuildInputs = [
+    meson ninja
+    pkgconfig
+    asciidoc
+    docbook_xml_dtd_45
+    docbook_xsl
+    makeWrapper
+  ];
+
+  buildInputs = [
+    dbus libX11 libXext
+    xorgproto
+    libXinerama libdrm pcre libxml2 libxslt libconfig libGL
+    libxcb xcbutilrenderutil xcbutilimage
+    pixman libev
+    libxdg_basedir
+  ];
+
+  NIX_CFLAGS_COMPILE = [ "-fno-strict-aliasing" ];
+
+  mesonFlags = [
+    "-Dbuild_docs=true"
+  ];
+
+  preBuild = ''
+    git() { echo "v${version}"; }
+    export -f git
+  '';
+
+  installFlags = [ "PREFIX=$(out)" ];
+
+  postInstall = ''
+    wrapProgram $out/bin/compton-trans \
+      --prefix PATH : ${lib.makeBinPath [ xwininfo ]}
+  '';
+
+  meta = with lib; {
+    description = "A fork of XCompMgr, a sample compositing manager for X servers";
+    longDescription = ''
+      A fork of XCompMgr, which is a sample compositing manager for X
+      servers supporting the XFIXES, DAMAGE, RENDER, and COMPOSITE
+      extensions. It enables basic eye-candy effects. This fork adds
+      additional features, such as additional effects, and a fork at a
+      well-defined and proper place.
     '';
-
-    NIX_CFLAGS_COMPILE = [ "-fno-strict-aliasing" ];
-
-    mesonFlags = [
-      "-Dvsync_drm=true"
-      "-Dnew_backends=true"
-      "-Dbuild_docs=true"
-    ];
-
-    meta = {
-      homepage = https://github.com/yshui/compton/;
-    };
+    license = licenses.mit;
+    homepage = "https://github.com/yshui/compton";
+    maintainers = with maintainers; [ ertes enzime twey ];
+    platforms = platforms.linux;
   };
-in {
-  compton = common stableSource;
-  compton-git = common gitSource;
 }