about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2015-09-15 06:53:50 +0200
committerDomen Kožar <domen@dev.si>2015-09-15 06:53:50 +0200
commiteb29d8e44ba580747063542590cf80eb5ba79373 (patch)
tree79bf64678e0039847162efa35f6608a1db939ca0 /pkgs/applications
parentf3519eb040874d4271957aab987c65076ada6e14 (diff)
parenteb7404d97a7e46df1f598a74982ca06e08033a45 (diff)
downloadnixlib-eb29d8e44ba580747063542590cf80eb5ba79373.tar
nixlib-eb29d8e44ba580747063542590cf80eb5ba79373.tar.gz
nixlib-eb29d8e44ba580747063542590cf80eb5ba79373.tar.bz2
nixlib-eb29d8e44ba580747063542590cf80eb5ba79373.tar.lz
nixlib-eb29d8e44ba580747063542590cf80eb5ba79373.tar.xz
nixlib-eb29d8e44ba580747063542590cf80eb5ba79373.tar.zst
nixlib-eb29d8e44ba580747063542590cf80eb5ba79373.zip
Merge pull request #9869 from Mathnerd314/import-fix
all-packages: Use callPackage where possible
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/vim/configurable.nix5
-rw-r--r--pkgs/applications/editors/vim/qvim.nix5
-rw-r--r--pkgs/applications/graphics/xaos/default.nix2
-rw-r--r--pkgs/applications/misc/gphoto2/gphotofs.nix2
-rw-r--r--pkgs/applications/misc/grass/default.nix15
-rw-r--r--pkgs/applications/networking/instant-messengers/carrier/2.5.0.nix20
-rw-r--r--pkgs/applications/science/geometry/drgeo/default.nix4
-rw-r--r--pkgs/applications/science/math/content/default.nix16
-rw-r--r--pkgs/applications/version-management/git-and-tools/default.nix2
-rw-r--r--pkgs/applications/version-management/monotone-viz/mtn-head.nix4
-rw-r--r--pkgs/applications/version-management/tailor/default.nix6
-rw-r--r--pkgs/applications/version-management/viewmtn/0.10.nix3
12 files changed, 50 insertions, 34 deletions
diff --git a/pkgs/applications/editors/vim/configurable.nix b/pkgs/applications/editors/vim/configurable.nix
index cd7db6bb82e3..fd4f13ab6500 100644
--- a/pkgs/applications/editors/vim/configurable.nix
+++ b/pkgs/applications/editors/vim/configurable.nix
@@ -1,6 +1,9 @@
 # TODO tidy up eg The patchelf code is patching gvim even if you don't build it..
 # but I have gvim with python support now :) - Marc
-args@{pkgs, source ? "default", ...}: with args;
+args@{pkgs, source ? "default", fetchurl, fetchhg, stdenv, ncurses, pkgconfig, gettext
+, composableDerivation, lib, config, glib, gtk, python, perl, tcl, ruby
+, libX11, libXext, libSM, libXpm, libXt, libXaw, libXau, libXmu
+, libICE, ... }: with args;
 
 
 let inherit (args.composableDerivation) composableDerivation edf;
diff --git a/pkgs/applications/editors/vim/qvim.nix b/pkgs/applications/editors/vim/qvim.nix
index 482e59833b35..0e0b6fc8e50d 100644
--- a/pkgs/applications/editors/vim/qvim.nix
+++ b/pkgs/applications/editors/vim/qvim.nix
@@ -1,4 +1,7 @@
-args@{...}: with args;
+args@{ fetchgit, stdenv, ncurses, pkgconfig, gettext
+, composableDerivation, lib, config, python, perl, tcl, ruby, qt4
+, libX11, libXext, libSM, libXpm, libXt, libXaw, libXau, libXmu
+, libICE, ... }: with args;
 
 let tag = "20140827";
     sha256 = "02adf2212872db3c5d133642d2c12fbfc28b506e4c0c42552e3d079756f63f65";
diff --git a/pkgs/applications/graphics/xaos/default.nix b/pkgs/applications/graphics/xaos/default.nix
index cacefc9bcc12..7e01d3847d56 100644
--- a/pkgs/applications/graphics/xaos/default.nix
+++ b/pkgs/applications/graphics/xaos/default.nix
@@ -1,4 +1,4 @@
-a :
+a @ { libXt, libX11, libXext, xextproto, xproto, gsl, aalib, zlib, intltool, gettext, perl, ... }:
 let
   fetchurl = a.fetchurl;
 
diff --git a/pkgs/applications/misc/gphoto2/gphotofs.nix b/pkgs/applications/misc/gphoto2/gphotofs.nix
index 32c95ec147bd..1e6d924b63a5 100644
--- a/pkgs/applications/misc/gphoto2/gphotofs.nix
+++ b/pkgs/applications/misc/gphoto2/gphotofs.nix
@@ -1,4 +1,4 @@
-a :
+a @ { libgphoto2, fuse, pkgconfig, glib, libtool, ... } :
 let
   fetchurl = a.fetchurl;
   s = import ./src-info-for-gphotofs.nix;
diff --git a/pkgs/applications/misc/grass/default.nix b/pkgs/applications/misc/grass/default.nix
index 823b6cdf5387..5ff14458840b 100644
--- a/pkgs/applications/misc/grass/default.nix
+++ b/pkgs/applications/misc/grass/default.nix
@@ -1,4 +1,11 @@
-{ config, ... }@a:
+{ config, libXmu, libXext, libXp, libX11, libXt, libSM, libICE, libXpm
+   , libXaw, libXrender
+  , composableDerivation, stdenv, fetchurl
+   , lib, flex, bison, cairo, fontconfig
+   , gdal, zlib, ncurses, gdbm, proj, pkgconfig, swig
+   , blas, liblapack, libjpeg, libpng, mysql, unixODBC, mesa, postgresql, python
+   , readline, sqlite, tcl, tk, libtiff, freetype, makeWrapper, wxGTK, ffmpeg, fftw
+   , wxPython, motif, opendwg }@a:
 
 # You can set gui by exporting GRASS_GUI=..
 # see http://grass.itc.it/gdp/html_grass64/g.gui.html
@@ -28,7 +35,7 @@ a.composableDerivation.composableDerivation {} (fix: {
   name = "grass-6.4.0RC6";
 
   buildInputs = [
-    # gentoos package depends on gmath ? 
+    # gentoos package depends on gmath ?
     a.pkgconfig
     a.flex a.bison a.libXmu a.libXext a.libXp a.libX11 a.libXt a.libSM a.libICE
     a.libXpm a.libXaw a.flex a.bison a.gdbm
@@ -72,7 +79,7 @@ a.composableDerivation.composableDerivation {} (fix: {
       configureFlags = [ "--with-python=${a.python}/bin/python-config" ];
       buildInputs = [a.python a.swig];
     };
-    
+
   }
   // edf { name = "_64bit"; feat = "64bit"; }
   // wwfp a.ncurses { name = "curses"; }
@@ -119,7 +126,7 @@ a.composableDerivation.composableDerivation {} (fix: {
   // wwfp a.unixODBC { name = "odbc"; }
   // wwfp a.fftw { name = "fftw"; }
   // wwf {
-    name = "blas"; 
+    name = "blas";
     enable.configureFlags = [ "--with-blas-libs=${a.blas}/lib" ];
   }
   // wwf {
diff --git a/pkgs/applications/networking/instant-messengers/carrier/2.5.0.nix b/pkgs/applications/networking/instant-messengers/carrier/2.5.0.nix
index 909d6404193c..7368a8842147 100644
--- a/pkgs/applications/networking/instant-messengers/carrier/2.5.0.nix
+++ b/pkgs/applications/networking/instant-messengers/carrier/2.5.0.nix
@@ -1,11 +1,15 @@
-args : with args; 
+args @ { fetchurl, stdenv, pkgconfig, perl, perlXMLParser, libxml2, openssl, nss
+, gtkspell, aspell, gettext, ncurses, avahi, dbus, dbus_glib, python
+, libtool, automake, autoconf, gstreamer
+, gtk, glib
+, libXScrnSaver, scrnsaverproto, libX11, xproto, kbproto, ... }: with args;
 /*
   arguments: all buildInputs
-  optional: purple2Source: purple-2 source - place to copy libpurple from 
+  optional: purple2Source: purple-2 source - place to copy libpurple from
     (to use a fresher pidgin build)
 */
-let 
-  externalPurple2 = (lib.attrByPath ["purple2Source"] null args) != null; 
+let
+  externalPurple2 = (lib.attrByPath ["purple2Source"] null args) != null;
 in
 rec {
   src = fetchurl {
@@ -16,9 +20,9 @@ rec {
   buildInputs = [gtkspell aspell
     gstreamer startupnotification
     libxml2 openssl nss
-    libXScrnSaver ncurses scrnsaverproto 
+    libXScrnSaver ncurses scrnsaverproto
     libX11 xproto kbproto GConf avahi
-    dbus dbus_glib glib python 
+    dbus dbus_glib glib python
     autoconf libtool automake];
 
   propagatedBuildInputs = [
@@ -38,11 +42,11 @@ rec {
   phaseNames = ["doConfigure" "preBuild" "doMakeInstall"]
     ++ (lib.optional externalPurple2 "postInstall")
   ;
-      
+
   name = "carrier-2.5.0";
   meta = {
     description = "PidginIM GUI fork with user-friendly development model";
-    homepage = http://funpidgin.sf.net; 
+    homepage = http://funpidgin.sf.net;
   };
 } // (if externalPurple2 then {
   postInstall = fullDepEntry (''
diff --git a/pkgs/applications/science/geometry/drgeo/default.nix b/pkgs/applications/science/geometry/drgeo/default.nix
index c18a6ed7426c..63b757945d29 100644
--- a/pkgs/applications/science/geometry/drgeo/default.nix
+++ b/pkgs/applications/science/geometry/drgeo/default.nix
@@ -1,4 +1,4 @@
-args : with args; 
+args @ { libxml2, perl, intltool, libtool, pkgconfig, gtk, ... } : with args;
 let version = lib.attrByPath ["version"] "1.1.0" args; in
 rec {
   src = fetchurl {
@@ -17,7 +17,7 @@ rec {
   doPreBuild = fullDepEntry (''
     cp drgeo.desktop.in drgeo.desktop
   '') ["minInit" "doUnpack"];
-      
+
   name = "drgeo-" + version;
   meta = {
     description = "Interactive geometry program";
diff --git a/pkgs/applications/science/math/content/default.nix b/pkgs/applications/science/math/content/default.nix
index 177efd667a39..57fdb525719b 100644
--- a/pkgs/applications/science/math/content/default.nix
+++ b/pkgs/applications/science/math/content/default.nix
@@ -1,10 +1,10 @@
-a :  
-let 
+a @ { mesa, lesstif, libX11, libXaw, xproto, libXt, libSM, libICE, libXmu, libXext, libXcursor, ... } :
+let
   fetchurl = a.fetchurl;
 
-  version = "1.5"; 
+  version = "1.5";
   buildInputs = with a; [
-    mesa lesstif libX11 libXaw xproto libXt libSM libICE 
+    mesa lesstif libX11 libXaw xproto libXt libSM libICE
       libXmu libXext libXcursor
   ];
 in
@@ -28,9 +28,9 @@ rec {
   configureFlags = [];
 
   /* doConfigure should be removed if not needed */
-  phaseNames = ["unpackTarballs" 
+  phaseNames = ["unpackTarballs"
     "setPlatform" "extraVars"
-    "buildVibrant" "buildContent" 
+    "buildVibrant" "buildContent"
     "install"];
 
   unpackTarballs = a.fullDepEntry (''
@@ -42,10 +42,10 @@ rec {
     sed -e s/SGI=/SGI=no/ -i content/makefile_v
   '') ["minInit"];
 
-  platformTLAContent = if a.stdenv.isLinux then "LIN" else 
+  platformTLAContent = if a.stdenv.isLinux then "LIN" else
     throw "Three-letter code for the platform is not known";
 
-  platformTLAVibrant = if a.stdenv.isLinux then "lnx" else 
+  platformTLAVibrant = if a.stdenv.isLinux then "lnx" else
     throw "Three-letter code for the platform is not known";
 
   setPlatform = a.fullDepEntry (''
diff --git a/pkgs/applications/version-management/git-and-tools/default.nix b/pkgs/applications/version-management/git-and-tools/default.nix
index 85219e48449e..adf8027bf27d 100644
--- a/pkgs/applications/version-management/git-and-tools/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/default.nix
@@ -1,7 +1,7 @@
 /* moving all git tools into one attribute set because git is unlikely to be
  * referenced by other packages and you can get a fast overview.
 */
-args: with args; with pkgs;
+args @ {pkgs}: with args; with pkgs;
 let
   inherit (pkgs) stdenv fetchgit fetchurl subversion;
 
diff --git a/pkgs/applications/version-management/monotone-viz/mtn-head.nix b/pkgs/applications/version-management/monotone-viz/mtn-head.nix
index b9a2daade5b5..eb75b45128e3 100644
--- a/pkgs/applications/version-management/monotone-viz/mtn-head.nix
+++ b/pkgs/applications/version-management/monotone-viz/mtn-head.nix
@@ -1,4 +1,4 @@
-args : with args; 
+args @ { graphviz, pkgconfig, autoconf, automake, libtool, glib, gtk, ... }: with args;
 rec {
   srcDrv = fetchmtn {
     name = "monotone-viz-mtn-checkout";
@@ -9,7 +9,7 @@ rec {
   };
   src = srcDrv + "/";
 
-  buildInputs = [ocaml lablgtk libgnomecanvas gtk graphviz glib 
+  buildInputs = [ocaml lablgtk libgnomecanvas gtk graphviz glib
     pkgconfig autoconf automake libtool];
   configureFlags = ["--with-lablgtk-dir=$(echo ${lablgtk}/lib/ocaml/*/site-lib/lablgtk2)"];
 
diff --git a/pkgs/applications/version-management/tailor/default.nix b/pkgs/applications/version-management/tailor/default.nix
index f8937f39e769..5164ed6a9b44 100644
--- a/pkgs/applications/version-management/tailor/default.nix
+++ b/pkgs/applications/version-management/tailor/default.nix
@@ -1,4 +1,4 @@
-args : with args; 
+args @ { makeWrapper, python, ... }: with args;
 let version = if args ? version then args.version else "0.9.35"; in
 rec {
   src = fetchurl {
@@ -14,10 +14,10 @@ rec {
 
   /* doConfigure should be specified separately */
   phaseNames = ["installPythonPackage" "wrapBinContentsPython"];
-      
+
   name = "tailor-" + version;
   meta = {
     description = "Version control tools integration tool";
   };
 }
- 
+
diff --git a/pkgs/applications/version-management/viewmtn/0.10.nix b/pkgs/applications/version-management/viewmtn/0.10.nix
index d5e7d1e7c83a..be8cc83c3008 100644
--- a/pkgs/applications/version-management/viewmtn/0.10.nix
+++ b/pkgs/applications/version-management/viewmtn/0.10.nix
@@ -1,5 +1,4 @@
-
-args : with args; 
+args @ { monotone, cheetahTemplate, highlight, ctags, makeWrapper, graphviz, which, python, ... }: with args;
 rec {
   src = fetchurl {
     url = http://viewmtn.1erlei.de/downloads/viewmtn-0.10.tgz;