about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorfigsoda <figsoda@pm.me>2022-09-09 19:55:02 -0400
committerGitHub <noreply@github.com>2022-09-09 19:55:02 -0400
commiteb1f0837a05b77e4e771ae9c687af47391df2981 (patch)
treed3ae1b93e2e04ea08d362744b44084ef4371fdec /pkgs/applications
parentbf054c6f270c0b66e27fc01b4e0dcd131336cdbf (diff)
parenta87d3f897b649058b7896f55062063df777e20ca (diff)
downloadnixlib-eb1f0837a05b77e4e771ae9c687af47391df2981.tar
nixlib-eb1f0837a05b77e4e771ae9c687af47391df2981.tar.gz
nixlib-eb1f0837a05b77e4e771ae9c687af47391df2981.tar.bz2
nixlib-eb1f0837a05b77e4e771ae9c687af47391df2981.tar.lz
nixlib-eb1f0837a05b77e4e771ae9c687af47391df2981.tar.xz
nixlib-eb1f0837a05b77e4e771ae9c687af47391df2981.tar.zst
nixlib-eb1f0837a05b77e4e771ae9c687af47391df2981.zip
Merge pull request #190560 from SuperSandro2000/qemu
qemu: make sure to not mix python versions
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/virtualization/qemu/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/applications/virtualization/qemu/default.nix b/pkgs/applications/virtualization/qemu/default.nix
index 3d8d87ec2274..8e7a683ed33e 100644
--- a/pkgs/applications/virtualization/qemu/default.nix
+++ b/pkgs/applications/virtualization/qemu/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchurl, fetchpatch, python3, python3Packages, zlib, pkg-config, glib, buildPackages
+{ lib, stdenv, fetchurl, fetchpatch, python3, zlib, pkg-config, glib, buildPackages
 , perl, pixman, vde2, alsa-lib, texinfo, flex
 , bison, lzo, snappy, libaio, libtasn1, gnutls, nettle, curl, ninja, meson, sigtool
 , makeWrapper, runtimeShell, removeReferencesTo
@@ -50,7 +50,7 @@ stdenv.mkDerivation rec {
 
   depsBuildBuild = [ buildPackages.stdenv.cc ];
 
-  nativeBuildInputs = [ makeWrapper removeReferencesTo pkg-config flex bison meson ninja perl python3 python3Packages.sphinx python3Packages.sphinx-rtd-theme ]
+  nativeBuildInputs = [ makeWrapper removeReferencesTo pkg-config flex bison meson ninja perl python3 python3.pkgs.sphinx python3.pkgs.sphinx-rtd-theme ]
     ++ lib.optionals gtkSupport [ wrapGAppsHook ]
     ++ lib.optionals stdenv.isDarwin [ sigtool ];