about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2020-02-02 21:56:43 -0500
committerGitHub <noreply@github.com>2020-02-02 21:56:43 -0500
commitea0b9a5acac0f4569424780e13e7a2407cf158cd (patch)
tree2db2d0f5a2671e3d87cf6ba34a7dbd03ba8ba9ee /pkgs/applications
parent4ca09829c0026d8955e9e2ff22d6632e3dfc4cab (diff)
parent378be0a5429ddcc85b3e818d8631d7ddeb302d8d (diff)
downloadnixlib-ea0b9a5acac0f4569424780e13e7a2407cf158cd.tar
nixlib-ea0b9a5acac0f4569424780e13e7a2407cf158cd.tar.gz
nixlib-ea0b9a5acac0f4569424780e13e7a2407cf158cd.tar.bz2
nixlib-ea0b9a5acac0f4569424780e13e7a2407cf158cd.tar.lz
nixlib-ea0b9a5acac0f4569424780e13e7a2407cf158cd.tar.xz
nixlib-ea0b9a5acac0f4569424780e13e7a2407cf158cd.tar.zst
nixlib-ea0b9a5acac0f4569424780e13e7a2407cf158cd.zip
Merge pull request #79138 from masaeedu/girt-tests
gitAndTools.git-interactive-rebase-tool: remove patch
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/git-and-tools/default.nix4
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-interactive-rebase-tool/01-terminaltests.patch169
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-interactive-rebase-tool/default.nix10
3 files changed, 8 insertions, 175 deletions
diff --git a/pkgs/applications/version-management/git-and-tools/default.nix b/pkgs/applications/version-management/git-and-tools/default.nix
index 3a68f7903822..3682717f314d 100644
--- a/pkgs/applications/version-management/git-and-tools/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/default.nix
@@ -103,7 +103,9 @@ let
 
   git-imerge = callPackage ./git-imerge { };
 
-  git-interactive-rebase-tool = callPackage ./git-interactive-rebase-tool {};
+  git-interactive-rebase-tool = callPackage ./git-interactive-rebase-tool {
+    inherit (darwin.apple_sdk.frameworks) Security;
+  };
 
   git-machete = python3Packages.callPackage ./git-machete { };
 
diff --git a/pkgs/applications/version-management/git-and-tools/git-interactive-rebase-tool/01-terminaltests.patch b/pkgs/applications/version-management/git-and-tools/git-interactive-rebase-tool/01-terminaltests.patch
deleted file mode 100644
index 1bbae6dc01a7..000000000000
--- a/pkgs/applications/version-management/git-and-tools/git-interactive-rebase-tool/01-terminaltests.patch
+++ /dev/null
@@ -1,169 +0,0 @@
---- a/src/display/utils.rs
-+++ b/src/display/utils.rs
-@@ -53,166 +53,3 @@
- 		_ => ColorMode::TwoTone,
- 	}
- }
--
--#[cfg(all(windows, test))]
--mod tests {
--	use crate::display::color_mode::ColorMode;
--	use crate::display::utils::detect_color_mode;
--
--	#[test]
--	fn detect_color_mode_windows() {
--		assert_eq!(detect_color_mode(2), ColorMode::ThreeBit);
--	}
--}
--
--#[cfg(all(unix, test))]
--mod tests {
--	use crate::display::color_mode::ColorMode;
--	use crate::display::utils::detect_color_mode;
--	use std::env::{remove_var, set_var};
--
--	fn clear_env() {
--		remove_var("COLORTERM");
--		remove_var("VTE_VERSION");
--		remove_var("TERM_PROGRAM");
--		remove_var("TERM");
--	}
--
--	#[test]
--	fn detect_color_mode_no_env_2_colors() {
--		clear_env();
--		assert_eq!(detect_color_mode(2), ColorMode::TwoTone);
--	}
--
--	#[test]
--	fn detect_color_mode_no_env_8_colors() {
--		clear_env();
--		assert_eq!(detect_color_mode(8), ColorMode::ThreeBit);
--	}
--
--	#[test]
--	fn detect_color_mode_no_env_less_8_colors() {
--		clear_env();
--		assert_eq!(detect_color_mode(7), ColorMode::TwoTone);
--	}
--
--	#[test]
--	fn detect_color_mode_no_env_16_colors() {
--		clear_env();
--		assert_eq!(detect_color_mode(16), ColorMode::FourBit);
--	}
--
--	#[test]
--	fn detect_color_mode_no_env_less_16_colors() {
--		clear_env();
--		assert_eq!(detect_color_mode(15), ColorMode::ThreeBit);
--	}
--
--	#[test]
--	fn detect_color_mode_no_env_256_colors() {
--		clear_env();
--		assert_eq!(detect_color_mode(256), ColorMode::EightBit);
--	}
--
--	#[test]
--	fn detect_color_mode_no_env_less_256_colors() {
--		clear_env();
--		assert_eq!(detect_color_mode(255), ColorMode::FourBit);
--	}
--
--	#[test]
--	fn detect_color_mode_no_env_more_256_colors() {
--		clear_env();
--		assert_eq!(detect_color_mode(257), ColorMode::EightBit);
--	}
--
--	#[test]
--	fn detect_color_mode_term_env_no_256() {
--		clear_env();
--		set_var("TERM", "XTERM");
--		assert_eq!(detect_color_mode(0), ColorMode::TwoTone);
--	}
--
--	#[test]
--	fn detect_color_mode_term_env_with_256() {
--		clear_env();
--		set_var("TERM", "XTERM-256");
--		assert_eq!(detect_color_mode(0), ColorMode::EightBit);
--	}
--
--	#[test]
--	fn detect_color_mode_term_program_env_apple_terminal() {
--		clear_env();
--		set_var("TERM_PROGRAM", "Apple_Terminal");
--		assert_eq!(detect_color_mode(0), ColorMode::EightBit);
--	}
--
--	#[test]
--	fn detect_color_mode_term_program_env_iterm() {
--		clear_env();
--		set_var("TERM_PROGRAM", "iTerm.app");
--		assert_eq!(detect_color_mode(0), ColorMode::EightBit);
--	}
--
--	#[test]
--	fn detect_color_mode_term_program_env_other() {
--		clear_env();
--		set_var("TERM_PROGRAM", "other");
--		assert_eq!(detect_color_mode(0), ColorMode::TwoTone);
--	}
--
--	#[test]
--	fn detect_color_mode_vte_version_0_36_00() {
--		clear_env();
--		set_var("VTE_VERSION", "3600");
--		assert_eq!(detect_color_mode(0), ColorMode::TrueColor);
--	}
--
--	#[test]
--	fn detect_color_mode_vte_version_greater_0_36_00() {
--		clear_env();
--		set_var("VTE_VERSION", "3601");
--		assert_eq!(detect_color_mode(0), ColorMode::TrueColor);
--	}
--
--	#[test]
--	fn detect_color_mode_vte_version_less_0_36_00() {
--		clear_env();
--		set_var("VTE_VERSION", "1");
--		assert_eq!(detect_color_mode(0), ColorMode::EightBit);
--	}
--
--	#[test]
--	fn detect_color_mode_vte_version_0() {
--		clear_env();
--		set_var("VTE_VERSION", "0");
--		assert_eq!(detect_color_mode(0), ColorMode::TwoTone);
--	}
--	#[test]
--	fn detect_color_mode_vte_version_invalid() {
--		clear_env();
--		set_var("VTE_VERSION", "invalid");
--		assert_eq!(detect_color_mode(0), ColorMode::TwoTone);
--	}
--
--	#[test]
--	fn detect_color_mode_colorterm_env_is_truecolor() {
--		clear_env();
--		set_var("COLORTERM", "truecolor");
--		assert_eq!(detect_color_mode(0), ColorMode::TrueColor);
--	}
--
--	#[test]
--	fn detect_color_mode_colorterm_env_is_24bit() {
--		clear_env();
--		set_var("COLORTERM", "24bit");
--		assert_eq!(detect_color_mode(0), ColorMode::TrueColor);
--	}
--
--	#[test]
--	fn detect_color_mode_colorterm_env_is_other() {
--		clear_env();
--		set_var("COLORTERM", "other");
--		assert_eq!(detect_color_mode(0), ColorMode::TwoTone);
--	}
--}
diff --git a/pkgs/applications/version-management/git-and-tools/git-interactive-rebase-tool/default.nix b/pkgs/applications/version-management/git-and-tools/git-interactive-rebase-tool/default.nix
index 81b4486d569f..7635a96eca5e 100644
--- a/pkgs/applications/version-management/git-and-tools/git-interactive-rebase-tool/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git-interactive-rebase-tool/default.nix
@@ -1,4 +1,4 @@
-{ lib, ncurses5, fetchFromGitHub, rustPlatform }:
+{ stdenv, ncurses5, fetchFromGitHub, rustPlatform, libiconv, Security }:
 
 rustPlatform.buildRustPackage rec {
   pname = "git-interactive-rebase-tool";
@@ -11,13 +11,13 @@ rustPlatform.buildRustPackage rec {
     sha256 = "10z3di2qypgsmg2z7xfs9nlrf9vng5i7l8dvqadv1l4lb9zz7i8q";
   };
 
-  patches = [ ./01-terminaltests.patch ];
-
   cargoSha256 = "002kr52vlpv1rhnxki29xflpmgk6bszrw0dsxcc34kyal0593ajk";
 
-  buildInputs = [ ncurses5 ];
+  buildInputs = [ ncurses5 ] ++ stdenv.lib.optionals stdenv.isDarwin [ libiconv Security ];
+
+  checkFlagsArray = [ "--test-threads=1" ];
 
-  meta = with lib; {
+  meta = with stdenv.lib; {
     homepage = "https://github.com/MitMaro/git-interactive-rebase-tool";
     description = "Native cross platform full feature terminal based sequence editor for git interactive rebase";
     changelog = "https://github.com/MitMaro/git-interactive-rebase-tool/releases/tag/${version}";