about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@users.noreply.github.com>2016-06-04 01:14:09 +0200
committerJoachim Fasting <joachifm@users.noreply.github.com>2016-06-04 01:14:09 +0200
commite65698db0ba04c1685666fc9d541dcf07901278b (patch)
treecfb956276f460eb137f1f79df0624fc46fe995e9 /pkgs/applications
parent9dc2ab3d169670988463c0f22b9a515b4ade255f (diff)
parent75f793bbb27c1d73858e419851a7b0b6728ac32d (diff)
downloadnixlib-e65698db0ba04c1685666fc9d541dcf07901278b.tar
nixlib-e65698db0ba04c1685666fc9d541dcf07901278b.tar.gz
nixlib-e65698db0ba04c1685666fc9d541dcf07901278b.tar.bz2
nixlib-e65698db0ba04c1685666fc9d541dcf07901278b.tar.lz
nixlib-e65698db0ba04c1685666fc9d541dcf07901278b.tar.xz
nixlib-e65698db0ba04c1685666fc9d541dcf07901278b.tar.zst
nixlib-e65698db0ba04c1685666fc9d541dcf07901278b.zip
Merge pull request #15939 from ChrisJefferson/fix-gap
gap : 4.4.12 -> 4.8.3
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/math/gap/default.nix34
1 files changed, 16 insertions, 18 deletions
diff --git a/pkgs/applications/science/math/gap/default.nix b/pkgs/applications/science/math/gap/default.nix
index dcd0734d85d9..3d9e06527c9d 100644
--- a/pkgs/applications/science/math/gap/default.nix
+++ b/pkgs/applications/science/math/gap/default.nix
@@ -1,36 +1,34 @@
-{ stdenv, fetchurl, pari ? null }:
+{ stdenv, fetchurl, m4, gmp }:
 
 let
   baseName = "gap";
-  version = "4r4p12";
+  version = "4r8p3";
 
-  pkgVer = "2012_01_12-10_47_UTC";
-  pkgSrc = fetchurl {
-    url = "ftp://ftp.gap-system.org/pub/gap/gap4/tar.bz2/packages-${pkgVer}.tar.bz2";
-    sha256 = "0z9ncy1m5gvv4llkclxd1vpcgpb0b81a2pfmnhzvw8x708frhmnb";
-  };
+  pkgVer = "2016_03_19-22_17";
 in
 
 stdenv.mkDerivation rec {
   name = "${baseName}-${version}";
 
   src = fetchurl {
-    url = "ftp://ftp.gap-system.org/pub/gap/gap4/tar.gz/${baseName}${version}.tar.gz";
-    sha256 = "0flap5lbkvpms3zznq1zwxyxyj0ax3fk7m24f3bvhvr37vyxnf40";
+    url = "ftp://ftp.gap-system.org/pub/gap/gap48/tar.gz/${baseName}${version}_${pkgVer}.tar.gz";
+    sha256 = "1rmb0lj43avv456sjwb7ia3y0wwk5shlqylpkdwnnqpjnvjbnzv6";
   };
 
-  buildInputs = [ pari ];
-
+  configureFlags = [ "--with-gmp=system" ];
+  buildInputs = [ m4 gmp ];
+  
+  postBuild = ''
+    pushd pkg
+    bash ../bin/BuildPackages.sh
+    popd
+  '';
+  
   installPhase = ''
     mkdir -p "$out/bin" "$out/share/gap/"
 
     cp -r . "$out/share/gap/build-dir"
 
-    tar xf "${pkgSrc}" -C "$out/share/gap/build-dir/pkg"
-
-    ${if pari != null then
-      ''sed -e '2iexport PATH=$PATH:${pari}/bin' -i "$out/share/gap/build-dir/bin/gap.sh" ''
-    else ""}
     sed -e "/GAP_DIR=/aGAP_DIR='$out/share/gap/build-dir/'" -i "$out/share/gap/build-dir/bin/gap.sh"
 
     ln -s "$out/share/gap/build-dir/bin/gap.sh" "$out/bin"
@@ -41,10 +39,10 @@ stdenv.mkDerivation rec {
     maintainers = with maintainers;
     [
       raskin
+      chrisjefferson
     ];
-    platforms = platforms.linux;
+    platforms = platforms.all;
     license = licenses.gpl2;
     homepage = http://gap-system.org/;
-    broken = true;
   };
 }