about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2021-01-01 03:32:49 +0100
committerGitHub <noreply@github.com>2021-01-01 03:32:49 +0100
commite5c488c1545799d066706ad257fa4cc200fcb083 (patch)
treea3b135820015cdded98ebe904358c408ca8fb2a8 /pkgs/applications
parenteef90463b3478020bdfcefa5c0d718d3380e635d (diff)
parent31f845840c2baf8aa56f602fae518b640a9bd220 (diff)
downloadnixlib-e5c488c1545799d066706ad257fa4cc200fcb083.tar
nixlib-e5c488c1545799d066706ad257fa4cc200fcb083.tar.gz
nixlib-e5c488c1545799d066706ad257fa4cc200fcb083.tar.bz2
nixlib-e5c488c1545799d066706ad257fa4cc200fcb083.tar.lz
nixlib-e5c488c1545799d066706ad257fa4cc200fcb083.tar.xz
nixlib-e5c488c1545799d066706ad257fa4cc200fcb083.tar.zst
nixlib-e5c488c1545799d066706ad257fa4cc200fcb083.zip
Merge pull request #106741 from cyplo/mindforger1.52
mindforger: 1.48.2 -> 1.52.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/mindforger/build.patch57
-rw-r--r--pkgs/applications/editors/mindforger/default.nix32
2 files changed, 20 insertions, 69 deletions
diff --git a/pkgs/applications/editors/mindforger/build.patch b/pkgs/applications/editors/mindforger/build.patch
index e2745cbce2d0..e9b9244f8dbd 100644
--- a/pkgs/applications/editors/mindforger/build.patch
+++ b/pkgs/applications/editors/mindforger/build.patch
@@ -1,17 +1,8 @@
 diff --git a/app/app.pro b/app/app.pro
-index 4d47065..a39a320 100644
+index 29f9d9e..15fd2ff 100644
 --- a/app/app.pro
 +++ b/app/app.pro
-@@ -18,6 +18,8 @@
- TARGET = mindforger
- TEMPLATE = app
- 
-+include(../config.pri)
-+
- QT += widgets
- 
- mfner {
-@@ -297,7 +299,7 @@ RESOURCES += \
+@@ -370,7 +370,7 @@ RESOURCES += \
  # See http://doc.qt.io/qt-5/qmake-advanced-usage.html
  
  binfile.files += mindforger
@@ -20,51 +11,11 @@ index 4d47065..a39a320 100644
  INSTALLS += binfile
  
  # ########################################
-diff --git a/config.pri b/config.pri
-new file mode 100644
-index 0000000..ce05df1
---- /dev/null
-+++ b/config.pri
-@@ -0,0 +1,3 @@
-+isEmpty(PREFIX) {
-+ PREFIX = /usr
-+}
-diff --git a/deps/discount/discount.pro b/deps/discount/discount.pro
-index a8dfe35..ec16468 100644
---- a/deps/discount/discount.pro
-+++ b/deps/discount/discount.pro
-@@ -5,6 +5,8 @@
- # Webpage: http://www.pell.portland.or.us/~orc/Code/discount/
- #
- 
-+include(../../config.pri)
-+
- QT       -= core gui
- 
- TARGET = discount
-@@ -46,7 +48,7 @@ unix:!symbian {
-     maemo5 {
-         target.path = /opt/usr/lib
-     } else {
--        target.path = /usr/lib
-+        target.path = $$PREFIX/lib
-     }
-     INSTALLS += target
- }
 diff --git a/mindforger.pro b/mindforger.pro
-index ae627f2..0953856 100644
+index bd4f21d..6bb2dbc 100644
 --- a/mindforger.pro
 +++ b/mindforger.pro
-@@ -32,6 +32,8 @@ TEMPLATE = subdirs
- 
- SUBDIRS = deps lib app
- 
-+include(config.pri)
-+
- # build dependencies
- lib.depends = deps
- app.depends = lib
-@@ -44,20 +46,20 @@ app.depends = lib
+@@ -43,20 +43,20 @@ app.depends = lib
  #IMPORTANT: binfile MUST be specified in app/app.pro (project next to/that builds binary)
  
  docfiles.files += doc/*
diff --git a/pkgs/applications/editors/mindforger/default.nix b/pkgs/applications/editors/mindforger/default.nix
index 82aa38c14499..f7e244342257 100644
--- a/pkgs/applications/editors/mindforger/default.nix
+++ b/pkgs/applications/editors/mindforger/default.nix
@@ -1,35 +1,34 @@
-{ mkDerivation, stdenv, fetchurl, qmake, qtbase, qtwebkit }:
+{ mkDerivation
+, cmark-gfm
+, fetchurl
+, qmake
+, qtbase
+, qtwebkit
+, stdenv
+, wrapGAppsHook
+}:
 
 mkDerivation rec {
   pname = "mindforger";
-  version = "1.48.2";
+  version = "1.52.0";
 
   src = fetchurl {
-    url = "https://github.com/dvorka/mindforger/releases/download/1.48.0/mindforger_${version}.tgz";
-    sha256 = "1wlrl8hpjcpnq098l3n2d1gbhbjylaj4z366zvssqvmafr72iyw4";
+    url = "https://github.com/dvorka/mindforger/releases/download/${version}/mindforger_${version}.tgz";
+    sha256 = "1pghsw8kwvjhg3jpmjs0n892h2l0pm0cs6ymi8b23fwk0kfj67rd";
   };
 
-  nativeBuildInputs = [ qmake ] ;
-  buildInputs = [ qtbase qtwebkit ] ;
+  nativeBuildInputs = [ qmake wrapGAppsHook ] ;
+  buildInputs = [ qtbase qtwebkit cmark-gfm ] ;
 
   doCheck = true;
 
-  enableParallelBuilding = true ;
-
   patches = [ ./build.patch ] ;
 
   postPatch = ''
-    substituteInPlace deps/discount/version.c.in --subst-var-by TABSTOP 4
+    substituteInPlace lib/src/install/installer.cpp --replace /usr "$out"
     substituteInPlace app/resources/gnome-shell/mindforger.desktop --replace /usr "$out"
   '';
 
-  preConfigure = ''
-    export AC_PATH="$PATH"
-    pushd deps/discount
-    ./configure.sh
-    popd
-  '';
-
   qmakeFlags = [ "-r mindforger.pro" "CONFIG+=mfnoccache" ] ;
 
   meta = with stdenv.lib; {
@@ -41,5 +40,6 @@ mkDerivation rec {
     homepage = "https://www.mindforger.com";
     license = licenses.gpl2Plus;
     platforms = platforms.all;
+    maintainers = with maintainers; [ cyplo ];
   };
 }