about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorPavol Rusnak <pavol@rusnak.io>2020-04-19 14:49:07 +0200
committerPavol Rusnak <pavol@rusnak.io>2020-04-19 14:49:07 +0200
commite353fe89dbe0edbe30b9b3691e3d5734dfb42640 (patch)
tree69db903766c39b84e34a779340cae3451da9de9e /pkgs/applications
parentd4d6d26588de50957d8723b219007b0b35f346d5 (diff)
downloadnixlib-e353fe89dbe0edbe30b9b3691e3d5734dfb42640.tar
nixlib-e353fe89dbe0edbe30b9b3691e3d5734dfb42640.tar.gz
nixlib-e353fe89dbe0edbe30b9b3691e3d5734dfb42640.tar.bz2
nixlib-e353fe89dbe0edbe30b9b3691e3d5734dfb42640.tar.lz
nixlib-e353fe89dbe0edbe30b9b3691e3d5734dfb42640.tar.xz
nixlib-e353fe89dbe0edbe30b9b3691e3d5734dfb42640.tar.zst
nixlib-e353fe89dbe0edbe30b9b3691e3d5734dfb42640.zip
keepassxc: 2.5.2 -> 2.5.4
+ disabled testcli flaky test
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/keepassx/community.nix20
-rw-r--r--pkgs/applications/misc/keepassx/darwin.patch4
2 files changed, 18 insertions, 6 deletions
diff --git a/pkgs/applications/misc/keepassx/community.nix b/pkgs/applications/misc/keepassx/community.nix
index 0ed1cd27be05..27ffa7d17a3b 100644
--- a/pkgs/applications/misc/keepassx/community.nix
+++ b/pkgs/applications/misc/keepassx/community.nix
@@ -1,4 +1,10 @@
-{ stdenv, fetchFromGitHub, cmake, makeWrapper, qttools, darwin
+{ stdenv
+, fetchFromGitHub
+, fetchpatch
+, cmake
+, makeWrapper
+, qttools
+, darwin
 
 , curl
 , glibcLocales
@@ -33,13 +39,13 @@ with stdenv.lib;
 
 stdenv.mkDerivation rec {
   pname = "keepassxc";
-  version = "2.5.2";
+  version = "2.5.4";
 
   src = fetchFromGitHub {
     owner = "keepassxreboot";
     repo = "keepassxc";
     rev = version;
-    sha256 = "0z5bd17qaq7zpv96gw6qwv6rb4xx7xjq86ss6wm5zskcrraf7r7n";
+    sha256 = "1xih9q1pxszalc0l29fmjxwn1vrrrrbnhc8gmi8brw5sclhbs6bh";
   };
 
   NIX_CFLAGS_COMPILE = stdenv.lib.optionalString stdenv.cc.isClang [
@@ -57,6 +63,11 @@ stdenv.mkDerivation rec {
 
   patches = [
     ./darwin.patch
+    # use wl-copy on Wayland - can be dropped with the next version update
+    (fetchpatch {
+      url = "https://github.com/keepassxreboot/keepassxc/commit/6128e5d58294f26411160f44da91087ebe7f4b07.patch";
+      sha256 = "16q0h7kijqjdbskmk4ar6p3g8vcxr0bq1zrlq2bk16pk10nv4bh1";
+    })
   ];
 
   cmakeFlags = [
@@ -79,7 +90,8 @@ stdenv.mkDerivation rec {
     export LC_ALL="en_US.UTF-8"
     export QT_QPA_PLATFORM=offscreen
     export QT_PLUGIN_PATH="${qtbase.bin}/${qtbase.qtPluginPrefix}"
-    make test ARGS+="-E testgui --output-on-failure"
+    # testcli and testgui are flaky - skip them both
+    make test ARGS+="-E 'testcli|testgui' --output-on-failure"
   '';
 
   nativeBuildInputs = [ cmake wrapQtAppsHook qttools ];
diff --git a/pkgs/applications/misc/keepassx/darwin.patch b/pkgs/applications/misc/keepassx/darwin.patch
index 6232d1118a7b..95ca5d4587fe 100644
--- a/pkgs/applications/misc/keepassx/darwin.patch
+++ b/pkgs/applications/misc/keepassx/darwin.patch
@@ -6,10 +6,10 @@ index 74b1a7ff..0a713a32 100644
      set(PLUGIN_INSTALL_DIR ".")
      set(DATA_INSTALL_DIR "share")
  elseif(APPLE AND WITH_APP_BUNDLE)
-+	set(CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/Applications")
++    set(CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/Applications")
+     set(BUNDLE_INSTALL_DIR "${PROGNAME}.app/Contents")
      set(CMAKE_INSTALL_MANDIR "${PROGNAME}.app/Contents/Resources/man")
      set(CLI_INSTALL_DIR "${PROGNAME}.app/Contents/MacOS")
-     set(PROXY_INSTALL_DIR "${PROGNAME}.app/Contents/MacOS")
 @@ -369,12 +370,6 @@ set(CMAKE_AUTORCC ON)
  
  if(APPLE)