about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorSamuel Gräfenstein <s@muel.gr>2022-02-25 20:34:56 +0100
committerPeter Hoeg <peter@hoeg.com>2022-02-28 18:48:45 +0800
commitde4352babbbba55e6617a10d9c42a77ec710c31c (patch)
treeb7cca1146d8d0c629a0a9d08b4de3869578dbfce /pkgs/applications
parentab7314cb320d9cb7db0688d0f84b3c6b705a3094 (diff)
downloadnixlib-de4352babbbba55e6617a10d9c42a77ec710c31c.tar
nixlib-de4352babbbba55e6617a10d9c42a77ec710c31c.tar.gz
nixlib-de4352babbbba55e6617a10d9c42a77ec710c31c.tar.bz2
nixlib-de4352babbbba55e6617a10d9c42a77ec710c31c.tar.lz
nixlib-de4352babbbba55e6617a10d9c42a77ec710c31c.tar.xz
nixlib-de4352babbbba55e6617a10d9c42a77ec710c31c.tar.zst
nixlib-de4352babbbba55e6617a10d9c42a77ec710c31c.zip
{lib,}ktorrent: move to pkgs/application/kde
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/kde/default.nix2
-rw-r--r--pkgs/applications/kde/ktorrent.nix22
-rw-r--r--pkgs/applications/kde/libktorrent.nix22
-rw-r--r--pkgs/applications/networking/p2p/ktorrent/default.nix32
4 files changed, 46 insertions, 32 deletions
diff --git a/pkgs/applications/kde/default.nix b/pkgs/applications/kde/default.nix
index 27b702e370e4..4d39d25222c8 100644
--- a/pkgs/applications/kde/default.nix
+++ b/pkgs/applications/kde/default.nix
@@ -186,6 +186,7 @@ let
       kteatime = callPackage ./kteatime.nix {};
       ktimer = callPackage ./ktimer.nix {};
       ktnef = callPackage ./ktnef.nix {};
+      ktorrent = callPackage ./ktorrent.nix {};
       ktouch = callPackage ./ktouch.nix {};
       kturtle = callPackage ./kturtle.nix {};
       kwalletmanager = callPackage ./kwalletmanager.nix {};
@@ -203,6 +204,7 @@ let
       libkomparediff2 = callPackage ./libkomparediff2.nix {};
       libksane = callPackage ./libksane.nix {};
       libksieve = callPackage ./libksieve.nix {};
+      libktorrent = callPackage ./libktorrent.nix {};
       mailcommon = callPackage ./mailcommon.nix {};
       mailimporter = callPackage ./mailimporter.nix {};
       marble = callPackage ./marble.nix {};
diff --git a/pkgs/applications/kde/ktorrent.nix b/pkgs/applications/kde/ktorrent.nix
new file mode 100644
index 000000000000..f63865d30303
--- /dev/null
+++ b/pkgs/applications/kde/ktorrent.nix
@@ -0,0 +1,22 @@
+{
+  mkDerivation, lib,
+  extra-cmake-modules, kdoctools,
+  karchive, kcmutils, kcrash, kdnssd, ki18n, knotifications, knotifyconfig,
+  kplotting, kross, libgcrypt, libktorrent, taglib
+}:
+
+mkDerivation {
+  pname = "ktorrent";
+  meta = with lib; {
+    description = "KDE integrated BtTorrent client";
+    homepage    = "https://apps.kde.org/ktorrent/";
+    license     = licenses.gpl2Plus;
+    maintainers = with maintainers; [ eelco ];
+  };
+
+  nativeBuildInputs = [ extra-cmake-modules kdoctools ];
+  buildInputs = [
+    karchive kcmutils kcrash kdnssd ki18n knotifications knotifyconfig kplotting
+    kross libgcrypt libktorrent taglib
+  ];
+}
diff --git a/pkgs/applications/kde/libktorrent.nix b/pkgs/applications/kde/libktorrent.nix
new file mode 100644
index 000000000000..3b4ae5f72f7f
--- /dev/null
+++ b/pkgs/applications/kde/libktorrent.nix
@@ -0,0 +1,22 @@
+{
+  mkDerivation, lib,
+  extra-cmake-modules,
+  karchive, kcrash, ki18n, kio, libgcrypt, qca-qt5, solid,
+  boost, gmp
+}:
+
+mkDerivation {
+  pname = "libktorrent";
+  meta = with lib; {
+    description = "A BitTorrent library used by KTorrent";
+    homepage    = "https://apps.kde.org/ktorrent/";
+    maintainers = with maintainers; [ eelco ];
+  };
+
+  nativeBuildInputs = [ extra-cmake-modules ];
+  buildInputs = [ karchive kcrash ki18n kio libgcrypt qca-qt5 solid ];
+  propagatedBuildInputs = [ boost gmp ];
+  outputs = [ "out" "dev" ];
+
+  dontWrapQtApps = true;
+}
diff --git a/pkgs/applications/networking/p2p/ktorrent/default.nix b/pkgs/applications/networking/p2p/ktorrent/default.nix
deleted file mode 100644
index 94a4642b2de1..000000000000
--- a/pkgs/applications/networking/p2p/ktorrent/default.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ mkDerivation, lib, fetchurl, fetchpatch, cmake
-, extra-cmake-modules, qtbase, qtscript
-, karchive, kcrash, kdnssd, ki18n, kio, knotifications, knotifyconfig
-, kdoctools, kross, kcmutils, kwindowsystem
-, libktorrent, taglib, libgcrypt, kplotting
-}:
-
-mkDerivation rec {
-  pname = "ktorrent";
-  version = "${libktorrent.mainVersion}";
-
-  src = fetchurl {
-    url    = "mirror://kde/stable/ktorrent/${libktorrent.mainVersion}/${pname}-${version}.tar.xz";
-    sha256 = "0kwd0npxfg4mdh7f3xadd2zjlqalpb1jxk61505qpcgcssijf534";
-  };
-
-  nativeBuildInputs = [ cmake kdoctools extra-cmake-modules ];
-
-  buildInputs = [
-    qtbase qtscript
-    karchive kcrash kdnssd ki18n kio knotifications knotifyconfig kross kcmutils kwindowsystem
-    libktorrent taglib libgcrypt kplotting
-  ];
-
-  meta = with lib; {
-    description = "KDE integrated BtTorrent client";
-    homepage    = "https://www.kde.org/applications/internet/ktorrent/";
-    license = licenses.gpl2;
-    maintainers = with maintainers; [ eelco ];
-    platforms   = platforms.linux;
-  };
-}