about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTobias Happ <tobias.happ@gmx.de>2020-12-23 12:55:58 +0100
committerTobias Happ <tobias.happ@gmx.de>2020-12-24 12:57:54 +0100
commitde1d520b58f2d9d771e54492dfda8b8981c9500d (patch)
treeead3999db732180cca2d44cd2a62d202bd7af88d /pkgs/applications
parentf475529d44343da2310ca08fea93b735c5ea61a8 (diff)
downloadnixlib-de1d520b58f2d9d771e54492dfda8b8981c9500d.tar
nixlib-de1d520b58f2d9d771e54492dfda8b8981c9500d.tar.gz
nixlib-de1d520b58f2d9d771e54492dfda8b8981c9500d.tar.bz2
nixlib-de1d520b58f2d9d771e54492dfda8b8981c9500d.tar.lz
nixlib-de1d520b58f2d9d771e54492dfda8b8981c9500d.tar.xz
nixlib-de1d520b58f2d9d771e54492dfda8b8981c9500d.tar.zst
nixlib-de1d520b58f2d9d771e54492dfda8b8981c9500d.zip
audacity: switch to cmake to fix missing plug-ins
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/audacity/default.nix20
1 files changed, 5 insertions, 15 deletions
diff --git a/pkgs/applications/audio/audacity/default.nix b/pkgs/applications/audio/audacity/default.nix
index 20526c8c6c56..1a29ed8b9785 100644
--- a/pkgs/applications/audio/audacity/default.nix
+++ b/pkgs/applications/audio/audacity/default.nix
@@ -1,8 +1,8 @@
 { stdenv, fetchzip, wxGTK30, pkgconfig, file, gettext,
   libvorbis, libmad, libjack2, lv2, lilv, serd, sord, sratom, suil, alsaLib, libsndfile, soxr, flac, lame,
   expat, libid3tag, ffmpeg_3, soundtouch, /*, portaudio - given up fighting their portaudio.patch */
-  autoconf, automake, libtool
-  }:
+  cmake
+}:
 
 with stdenv.lib;
 
@@ -15,16 +15,8 @@ stdenv.mkDerivation rec {
     sha256 = "1xk0piv72d2xd3p7igr916fhcbrm76fhjr418k1rlqdzzg1hfljn";
   };
 
-  preConfigure = /* we prefer system-wide libs */ ''
-    autoreconf -vi # use system libraries
-
-    # we will get a (possibly harmless) warning during configure without this
-    substituteInPlace configure \
-      --replace /usr/bin/file ${file}/bin/file
-  '';
-
-  configureFlags = [
-    "--with-libsamplerate"
+  cmakeFlags = [
+    "-DCMAKE_BUILD_TYPE=Release"
   ];
 
   # audacity only looks for lame and ffmpeg at runtime, so we need to link them in manually
@@ -43,15 +35,13 @@ stdenv.mkDerivation rec {
     "-lswscale"
   ];
 
-  nativeBuildInputs = [ pkgconfig autoconf automake libtool ];
+  nativeBuildInputs = [ pkgconfig cmake ];
   buildInputs = [
     file gettext wxGTK30 expat alsaLib
     libsndfile soxr libid3tag libjack2 lv2 lilv serd sord sratom suil wxGTK30.gtk
     ffmpeg_3 libmad lame libvorbis flac soundtouch
   ]; #ToDo: detach sbsms
 
-  enableParallelBuilding = true;
-
   dontDisableStatic = true;
   doCheck = false; # Test fails