about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-07-19 18:17:46 -0400
committerworldofpeace <worldofpeace@protonmail.ch>2019-07-19 18:17:46 -0400
commitdc7c4d003c754581d86c609ae960a25ad3e43b92 (patch)
tree43244ef2d475016987d8709aa5f83e94966185ab /pkgs/applications
parent3531a229d1d9b67305bcf9f0441365f2e89cc361 (diff)
downloadnixlib-dc7c4d003c754581d86c609ae960a25ad3e43b92.tar
nixlib-dc7c4d003c754581d86c609ae960a25ad3e43b92.tar.gz
nixlib-dc7c4d003c754581d86c609ae960a25ad3e43b92.tar.bz2
nixlib-dc7c4d003c754581d86c609ae960a25ad3e43b92.tar.lz
nixlib-dc7c4d003c754581d86c609ae960a25ad3e43b92.tar.xz
nixlib-dc7c4d003c754581d86c609ae960a25ad3e43b92.tar.zst
nixlib-dc7c4d003c754581d86c609ae960a25ad3e43b92.zip
sublime-merge: add redirect for /bin/true
Without it rebasing/squashing features are broken.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/sublime-merge/common.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/applications/version-management/sublime-merge/common.nix b/pkgs/applications/version-management/sublime-merge/common.nix
index f69fdbefe184..c095aa49eafb 100644
--- a/pkgs/applications/version-management/sublime-merge/common.nix
+++ b/pkgs/applications/version-management/sublime-merge/common.nix
@@ -2,7 +2,7 @@
 
 { fetchurl, stdenv, xorg, glib, glibcLocales, gtk3, cairo, pango, libredirect, makeWrapper, wrapGAppsHook
 , pkexecPath ? "/run/wrappers/bin/pkexec"
-, writeScript, common-updater-scripts, curl, gnugrep
+, writeScript, common-updater-scripts, curl, gnugrep, coreutils
 }:
 
 let
@@ -18,7 +18,7 @@ let
   arch = "x64";
 
   libPath = stdenv.lib.makeLibraryPath [ xorg.libX11 glib gtk3 cairo pango ];
-  redirects = [ "/usr/bin/pkexec=${pkexecPath}" ];
+  redirects = [ "/usr/bin/pkexec=${pkexecPath}" "/bin/true=${coreutils}/bin/true" ];
 in let
   binaryPackage = stdenv.mkDerivation {
     pname = "${pname}-bin";