about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorLassulus <github@lassul.us>2019-10-02 20:39:45 +0200
committerGitHub <noreply@github.com>2019-10-02 20:39:45 +0200
commitdc00a981b2dc408616f5815e67c6f26c7e96fd16 (patch)
tree34cdeb1fd0cebaada50e0e70fce34a5daa5b7b13 /pkgs/applications
parent8cd5aa8a82367eeedbd0261f6d040a106e2a844a (diff)
parentffa991e7a0ee29bc69b940f91593ddf7abeef56d (diff)
downloadnixlib-dc00a981b2dc408616f5815e67c6f26c7e96fd16.tar
nixlib-dc00a981b2dc408616f5815e67c6f26c7e96fd16.tar.gz
nixlib-dc00a981b2dc408616f5815e67c6f26c7e96fd16.tar.bz2
nixlib-dc00a981b2dc408616f5815e67c6f26c7e96fd16.tar.lz
nixlib-dc00a981b2dc408616f5815e67c6f26c7e96fd16.tar.xz
nixlib-dc00a981b2dc408616f5815e67c6f26c7e96fd16.tar.zst
nixlib-dc00a981b2dc408616f5815e67c6f26c7e96fd16.zip
Merge pull request #70204 from 0x4A6F/master-qubes-core-vchan-xen
qubes-core-vchan-xen: init at 4.1.2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/qubes/qubes-core-vchan-xen/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/applications/qubes/qubes-core-vchan-xen/default.nix b/pkgs/applications/qubes/qubes-core-vchan-xen/default.nix
new file mode 100644
index 000000000000..e8241ede96cd
--- /dev/null
+++ b/pkgs/applications/qubes/qubes-core-vchan-xen/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchFromGitHub, xen_4_10 }:
+
+stdenv.mkDerivation rec {
+  pname = "qubes-core-vchan-xen";
+  version = "4.1.2";
+
+  src = fetchFromGitHub {
+    owner = "QubesOS";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "1wj4vv8nkzzig52r2nzkd4jy0cwznfkyddx379hfsdl4pzsp55mj";
+  };
+
+  buildInputs = [ xen_4_10 ];
+  buildPhase = ''
+    make all PREFIX=/
+  '';
+  installPhase = ''
+    make install DESTDIR=$out PREFIX=/
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Libraries required for the higher-level Qubes daemons and tools";
+    homepage = "https://qubes-os.org";
+    license = licenses.gpl2Plus;
+    maintainers = with maintainers; [ "0x4A6F" ];
+    platforms = platforms.linux;
+  };
+}
+