about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJonas Holst Damtoft <jonasdamtoft@gmail.com>2019-05-24 13:03:47 +0200
committerMatthieu Coudron <coudron@iij.ad.jp>2019-05-29 18:15:15 +0900
commitdbb27af6c6e28419e614cc8226787bff970d62c2 (patch)
treeb619c7d4c485c28dad2ae14adc1c04704b41f8be /pkgs/applications
parent97aba37876c4513102b0acef05f3438c0b896840 (diff)
downloadnixlib-dbb27af6c6e28419e614cc8226787bff970d62c2.tar
nixlib-dbb27af6c6e28419e614cc8226787bff970d62c2.tar.gz
nixlib-dbb27af6c6e28419e614cc8226787bff970d62c2.tar.bz2
nixlib-dbb27af6c6e28419e614cc8226787bff970d62c2.tar.lz
nixlib-dbb27af6c6e28419e614cc8226787bff970d62c2.tar.xz
nixlib-dbb27af6c6e28419e614cc8226787bff970d62c2.tar.zst
nixlib-dbb27af6c6e28419e614cc8226787bff970d62c2.zip
neovim: Allow passing extra makeWrapperArgs
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/neovim/wrapper.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/applications/editors/neovim/wrapper.nix b/pkgs/applications/editors/neovim/wrapper.nix
index 7d76bc1fd1a0..aa1e2a6b5bd7 100644
--- a/pkgs/applications/editors/neovim/wrapper.nix
+++ b/pkgs/applications/editors/neovim/wrapper.nix
@@ -12,7 +12,8 @@ neovim:
 
 let
   wrapper = {
-      withPython ? true,  extraPythonPackages ? (_: []) /* the function you would have passed to python.withPackages */
+      extraMakeWrapperArgs ? ""
+    , withPython ? true,  extraPythonPackages ? (_: []) /* the function you would have passed to python.withPackages */
     , withPython3 ? true,  extraPython3Packages ? (_: []) /* the function you would have passed to python.withPackages */
     , withNodeJs? false
     , withRuby ? true
@@ -113,7 +114,7 @@ let
         # https://github.com/neovim/neovim/issues/9413
         wrapProgram $out/bin/nvim \
           --set NVIM_SYSTEM_RPLUGIN_MANIFEST $out/rplugin.vim \
-          --add-flags "-u ${vimUtils.vimrcFile configure}"
+          --add-flags "-u ${vimUtils.vimrcFile configure}" ${extraMakeWrapperArgs}
       '';
 
     preferLocalBuild = true;