about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorNicolas B. Pierron <nicolas.b.pierron@gmail.com>2015-08-08 18:46:05 +0200
committerNicolas B. Pierron <nicolas.b.pierron@gmail.com>2015-08-08 18:46:05 +0200
commitda74a8dc350dbb10f7f87ed9d4fc63e8d7d12005 (patch)
tree12ac16ae1e5d5778ca42d4a6c2ac505ddebd46cd /pkgs/applications
parent076e90c67aeb2fe0f5866d7ce25730b6d3405d2b (diff)
parentf059656ef2e665d6a8ee41a6215ec2c7e969d390 (diff)
downloadnixlib-da74a8dc350dbb10f7f87ed9d4fc63e8d7d12005.tar
nixlib-da74a8dc350dbb10f7f87ed9d4fc63e8d7d12005.tar.gz
nixlib-da74a8dc350dbb10f7f87ed9d4fc63e8d7d12005.tar.bz2
nixlib-da74a8dc350dbb10f7f87ed9d4fc63e8d7d12005.tar.lz
nixlib-da74a8dc350dbb10f7f87ed9d4fc63e8d7d12005.tar.xz
nixlib-da74a8dc350dbb10f7f87ed9d4fc63e8d7d12005.tar.zst
nixlib-da74a8dc350dbb10f7f87ed9d4fc63e8d7d12005.zip
Merge pull request #9166 from taku0/thunderbird-38.1.0
thunderbird: 31.7.0 -> 38.1.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/mailreaders/thunderbird/default.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/pkgs/applications/networking/mailreaders/thunderbird/default.nix b/pkgs/applications/networking/mailreaders/thunderbird/default.nix
index f2a088164d20..5d6e0faad4a8 100644
--- a/pkgs/applications/networking/mailreaders/thunderbird/default.nix
+++ b/pkgs/applications/networking/mailreaders/thunderbird/default.nix
@@ -13,15 +13,17 @@
   enableOfficialBranding ? false
 }:
 
-let version = "31.7.0"; in
+let version = "38.1.0"; in
 let verName = "${version}"; in
 
 stdenv.mkDerivation rec {
   name = "thunderbird-${verName}";
 
   src = fetchurl {
-    url = "ftp://ftp.mozilla.org/pub/thunderbird/releases/${verName}/source/thunderbird-${verName}.source.tar.bz2";
-    sha1 = "90e18f8ecccdaf1ee39493223a7e3ad8b3b7bede";
+    url = "http://archive.mozilla.org/pub/thunderbird/releases/${verName}/source/thunderbird-${verName}.source.tar.bz2";
+
+    # https://archive.mozilla.org/pub/thunderbird/releases/${verName}/SHA1SUMS
+    sha1 = "7bb0c85e889e397e53dcbcbd36957dbd7c8c10bd";
   };
 
   buildInputs = # from firefox30Pkgs.xulrunner, but without gstreamer and libvpx
@@ -75,6 +77,10 @@ stdenv.mkDerivation rec {
     cd objdir
     echo '${stdenv.lib.concatMapStrings (s : "ac_add_options ${s}\n") configureFlags}' > .mozconfig
     echo 'ac_add_options --prefix="'"$out"'"' >> .mozconfig
+    # From version 38, we need to specify the source directory to build
+    # Thunderbird. Refer to mozilla/configure and search a line with
+    # "checking for application to build" and "# Support comm-central".
+    echo 'ac_add_options --with-external-source-dir="'`realpath ..`'"' >> .mozconfig
     echo 'mk_add_options MOZ_MAKE_FLAGS="-j'"$NIX_BUILD_CORES"'"' >> .mozconfig
     echo 'mk_add_options MOZ_OBJDIR="'`pwd`'"' >> .mozconfig