about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2008-06-17 14:19:59 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2008-06-17 14:19:59 +0000
commitd97069da1a884600688ceee314c8f9d876744a52 (patch)
tree92e2491cebd50976c2f59c8e05fd1a72fc26af8a /pkgs/applications
parent579099e9d00f3dc6b04ba0b0759a8b45a7b1b738 (diff)
downloadnixlib-d97069da1a884600688ceee314c8f9d876744a52.tar
nixlib-d97069da1a884600688ceee314c8f9d876744a52.tar.gz
nixlib-d97069da1a884600688ceee314c8f9d876744a52.tar.bz2
nixlib-d97069da1a884600688ceee314c8f9d876744a52.tar.lz
nixlib-d97069da1a884600688ceee314c8f9d876744a52.tar.xz
nixlib-d97069da1a884600688ceee314c8f9d876744a52.tar.zst
nixlib-d97069da1a884600688ceee314c8f9d876744a52.zip
* Quick start section.
* Updated some packages that are referenced in that section.

svn path=/nixpkgs/trunk/; revision=12139
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/hello/ex-2/default.nix20
-rw-r--r--pkgs/applications/networking/newsreaders/pan/default.nix12
2 files changed, 19 insertions, 13 deletions
diff --git a/pkgs/applications/misc/hello/ex-2/default.nix b/pkgs/applications/misc/hello/ex-2/default.nix
index b70103ceef5c..876e0dfb7c50 100644
--- a/pkgs/applications/misc/hello/ex-2/default.nix
+++ b/pkgs/applications/misc/hello/ex-2/default.nix
@@ -1,10 +1,20 @@
-{stdenv, fetchurl, perl}:
+{stdenv, fetchurl}:
 
 stdenv.mkDerivation {
-  name = "hello-2.1.1";
+  name = "hello-2.3";
+  
   src = fetchurl {
-    url = mirror://gnu/hello/hello-2.1.1.tar.gz;
-    md5 = "70c9ccf9fac07f762c24f2df2290784d";
+    url = mirror://gnu/hello/hello-2.3.tar.bz2;
+    sha256 = "0c7vijq8y68bpr7g6dh1gny0bff8qq81vnp4ch8pjzvg56wb3js1";
+  };
+  
+  meta = {
+    description = "A program that produces a familiar, friendly greeting";
+    longDescription = ''
+      GNU Hello is a program that prints "Hello, world!" when you run it.
+      It is fully customizable.
+    '';
+    homepage = http://www.gnu.org/software/hello/manual/;
+    license = "GPLv3+";
   };
-  buildInputs = [perl];
 }
diff --git a/pkgs/applications/networking/newsreaders/pan/default.nix b/pkgs/applications/networking/newsreaders/pan/default.nix
index a427e3550f8b..c91d64a2f4fe 100644
--- a/pkgs/applications/networking/newsreaders/pan/default.nix
+++ b/pkgs/applications/networking/newsreaders/pan/default.nix
@@ -3,8 +3,7 @@
 , perl, pcre, gmime, gettext
 }:
 
-assert spellChecking -> gtkspell != null /* !!! && gtk == gtkspell.gtk */;
-# !!! assert gtk.glib == gnet.glib;
+assert spellChecking -> gtkspell != null;
 
 stdenv.mkDerivation {
   name = "pan-0.132";
@@ -22,14 +21,11 @@ stdenv.mkDerivation {
     })
   ];
 
-  buildInputs = [
-    pkgconfig gtk perl pcre gmime gettext
-    (if spellChecking then gtkspell else null)
-  ];
-
-  inherit spellChecking stdenv;
+  buildInputs = [pkgconfig gtk perl pcre gmime gettext]
+    ++ stdenv.lib.optional spellChecking gtkspell;
 
   meta = {
     description = "A GTK+-based Usenet newsreader good at both text and binaries";
+    homepage = http://pan.rebelbase.com/;
   };
 }