about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2012-01-06 15:55:24 +0000
committerShea Levy <shea@shealevy.com>2012-01-06 15:55:24 +0000
commitd788929c64973df7ae8f680983c2cab26a4fc66c (patch)
tree643c7d6cf4e9ccd664df44b94a04414f5cc1051e /pkgs/applications
parentb884e56aa27c9fcaab0e551483f16cd71b1ad203 (diff)
downloadnixlib-d788929c64973df7ae8f680983c2cab26a4fc66c.tar
nixlib-d788929c64973df7ae8f680983c2cab26a4fc66c.tar.gz
nixlib-d788929c64973df7ae8f680983c2cab26a4fc66c.tar.bz2
nixlib-d788929c64973df7ae8f680983c2cab26a4fc66c.tar.lz
nixlib-d788929c64973df7ae8f680983c2cab26a4fc66c.tar.xz
nixlib-d788929c64973df7ae8f680983c2cab26a4fc66c.tar.zst
nixlib-d788929c64973df7ae8f680983c2cab26a4fc66c.zip
ledger3: Get building on darwin
svn path=/nixpkgs/trunk/; revision=31351
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/office/ledger/3.0.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/pkgs/applications/office/ledger/3.0.nix b/pkgs/applications/office/ledger/3.0.nix
index b95f2cc542a2..0df148ce3907 100644
--- a/pkgs/applications/office/ledger/3.0.nix
+++ b/pkgs/applications/office/ledger/3.0.nix
@@ -18,6 +18,10 @@ stdenv.mkDerivation {
     git texinfo
   ];
 
+  CPPFLAGS = "-I${gmp}/include -I${mpfr}/include";
+
+  LDFLAGS = "-L${gmp}/lib -L${mpfr}/lib";
+
   buildPhase = ''
     sed -i acprep \
       -e 's|search_prefixes = .*|search_prefixes = ["${boost}"]|'
@@ -25,7 +29,7 @@ stdenv.mkDerivation {
     python acprep update --no-pch --prefix=$out
   '';
 
-  doCheck = true;
+  doCheck = !stdenv.isDarwin;
 
   enableParallelBuilding = true;
 
@@ -41,7 +45,7 @@ stdenv.mkDerivation {
       their data, there really is no alternative.
     '';
 
-    platforms = stdenv.lib.platforms.linux;
+    platforms = stdenv.lib.platforms.all;
     maintainers = [ stdenv.lib.maintainers.simons ];
   };
 }