about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMichael Weiss <dev.primeos@gmail.com>2020-04-06 12:19:26 +0200
committerMichael Weiss <dev.primeos@gmail.com>2020-04-07 23:21:28 +0200
commitd782c440aedd13c9191434cf7fdfb442559fc4fc (patch)
treea6ff3d0fbcccde4146e4bce9a231660ad60357bc /pkgs/applications
parent0db2f2fdf6f51c46ba0f62a507276b7c1b1c590b (diff)
downloadnixlib-d782c440aedd13c9191434cf7fdfb442559fc4fc.tar
nixlib-d782c440aedd13c9191434cf7fdfb442559fc4fc.tar.gz
nixlib-d782c440aedd13c9191434cf7fdfb442559fc4fc.tar.bz2
nixlib-d782c440aedd13c9191434cf7fdfb442559fc4fc.tar.lz
nixlib-d782c440aedd13c9191434cf7fdfb442559fc4fc.tar.xz
nixlib-d782c440aedd13c9191434cf7fdfb442559fc4fc.tar.zst
nixlib-d782c440aedd13c9191434cf7fdfb442559fc4fc.zip
chromiumDev: Add the missing setuptools dependency
The build was failing with:
```
[1625/39505] ACTION //components/schema_org:generate_schema_org_code(//build/toolchain/linux:clang_x64)
FAILED: gen/components/schema_org/schema_org_entity_names.h gen/components/schema_org/schema_org_entity_names.cc gen/components/schema_org/schema_org_property_configurations.h gen/components/schema_org/schema_org_property_configurations.cc gen/components/schema_org/schema_org_property_names.h gen/components/schema_org/schema_org_property_names.cc
python ../../components/schema_org/generate_schema_org_code.py --schema-file ../../third_party/schema_org/schema.jsonld --output-dir gen/components/schema_org --templates templates/schema_org_entity_names.cc.tmpl templates/schema_org_entity_names.h.tmpl templates/schema_org_property_configurations.cc.tmpl templates/schema_org_property_configurations.h.tmpl templates/schema_org_property_names.cc.tmpl templates/schema_org_property_names.h.tmpl
Traceback (most recent call last):
  File "../../components/schema_org/generate_schema_org_code.py", line 22, in <module>
    env = Environment(loader=PackageLoader('generate_schema_org_code', ''))
  File "/build/chromium-83.0.4100.3/components/schema_org/../../third_party/jinja2/loaders.py", line 222, in __init__
    from pkg_resources import DefaultProvider, ResourceManager, \
ImportError: No module named pkg_resources
```
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/chromium/common.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/applications/networking/browsers/chromium/common.nix b/pkgs/applications/networking/browsers/chromium/common.nix
index 6f14b2f00e48..78d99e9945f3 100644
--- a/pkgs/applications/networking/browsers/chromium/common.nix
+++ b/pkgs/applications/networking/browsers/chromium/common.nix
@@ -117,7 +117,7 @@ let
       ninja which python2Packages.python perl pkgconfig
       python2Packages.ply python2Packages.jinja2 nodejs
       gnutar
-    ];
+    ] ++ optional (versionAtLeast version "83") python2Packages.setuptools;
 
     buildInputs = defaultDependencies ++ [
       nspr nss systemd