about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2020-03-23 03:41:26 +0000
committerOrivej Desh <orivej@gmx.fr>2020-03-23 04:27:51 +0000
commitd5b27c6c749d533d5d8699e57a50803d29ad6f68 (patch)
tree8e1c31fdb887d539f0ec8a0547c6a293890877a5 /pkgs/applications
parent3c23cf90509caf29240049c0439b373559bbdd26 (diff)
downloadnixlib-d5b27c6c749d533d5d8699e57a50803d29ad6f68.tar
nixlib-d5b27c6c749d533d5d8699e57a50803d29ad6f68.tar.gz
nixlib-d5b27c6c749d533d5d8699e57a50803d29ad6f68.tar.bz2
nixlib-d5b27c6c749d533d5d8699e57a50803d29ad6f68.tar.lz
nixlib-d5b27c6c749d533d5d8699e57a50803d29ad6f68.tar.xz
nixlib-d5b27c6c749d533d5d8699e57a50803d29ad6f68.tar.zst
nixlib-d5b27c6c749d533d5d8699e57a50803d29ad6f68.zip
muse: fix parallel building
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/muse/default.nix6
-rw-r--r--pkgs/applications/audio/muse/fix-parallel-building.patch78
2 files changed, 84 insertions, 0 deletions
diff --git a/pkgs/applications/audio/muse/default.nix b/pkgs/applications/audio/muse/default.nix
index bc0325356b29..87f86306b482 100644
--- a/pkgs/applications/audio/muse/default.nix
+++ b/pkgs/applications/audio/muse/default.nix
@@ -16,6 +16,12 @@ stdenv.mkDerivation rec {
 
   sourceRoot = "source/muse3";
 
+  prePatch = ''
+    chmod u+w $NIX_BUILD_TOP
+  '';
+
+  patches = [ ./fix-parallel-building.patch ];
+
   nativeBuildInputs = [ cmake pkgconfig qttools wrapQtAppsHook ];
 
   buildInputs = [
diff --git a/pkgs/applications/audio/muse/fix-parallel-building.patch b/pkgs/applications/audio/muse/fix-parallel-building.patch
new file mode 100644
index 000000000000..abeec5d54cc0
--- /dev/null
+++ b/pkgs/applications/audio/muse/fix-parallel-building.patch
@@ -0,0 +1,78 @@
+To confirm these dependencies, run in a fresh build tree:
+
+
+ninja muse/components/CMakeFiles/components.dir/confmport.o
+
+In file included from ../muse/components/confmport.cpp:48:
+../muse/mplugins/midifilterimpl.h:28:10: fatal error:
+ui_midifilter.h: No such file or directory
+
+
+ninja muse/waveedit/CMakeFiles/waveedit.dir/wavecanvas.o
+
+In file included from ../muse/waveedit/wavecanvas.cpp:72:
+../muse/components/copy_on_write.h:26:10: fatal error:
+ui_copy_on_write_base.h: No such file or directory
+
+
+ninja muse/instruments/CMakeFiles/instruments.dir/editinstrument.o
+
+In file included from ../muse/instruments/editinstrument.cpp:58:
+../muse/components/editevent.h:26:10: fatal error:
+ui_editnotedialogbase.h: No such file or directory
+
+
+ninja muse/liste/CMakeFiles/liste.dir/listedit.o
+
+In file included from ../muse/liste/listedit.cpp:37:
+../muse/components/editevent.h:26:10: fatal error:
+ui_editnotedialogbase.h: No such file or directory
+
+
+ninja muse/mixer/CMakeFiles/mixer.dir/rack.o
+
+In file included from ../muse/mixer/rack.cpp:49:
+../muse/components/plugindialog.h:4:10: fatal error:
+ui_plugindialogbase.h: No such file or directory
+
+
+--- a/muse/components/CMakeLists.txt
++++ b/muse/components/CMakeLists.txt
+@@ -343,4 +343,5 @@ set_target_properties( components
+ target_link_libraries ( components
+       ${QT_LIBRARIES}
++      mplugins
+       widgets
+       xml_module
+--- a/muse/waveedit/CMakeLists.txt
++++ b/muse/waveedit/CMakeLists.txt
+@@ -79,4 +79,5 @@ set_target_properties( waveedit
+ target_link_libraries( waveedit
+       ${QT_LIBRARIES}
++      components
+       widgets
+       )
+--- a/muse/instruments/CMakeLists.txt
++++ b/muse/instruments/CMakeLists.txt
+@@ -78,4 +78,5 @@ set_target_properties( instruments
+ target_link_libraries ( instruments
+       ${QT_LIBRARIES}
++      components
+       icons
+       widgets
+--- a/muse/liste/CMakeLists.txt
++++ b/muse/liste/CMakeLists.txt
+@@ -65,4 +65,5 @@ set_target_properties( liste
+ target_link_libraries ( liste
+       ${QT_LIBRARIES}
++      components
+       awl
+       widgets
+--- a/muse/mixer/CMakeLists.txt
++++ b/muse/mixer/CMakeLists.txt
+@@ -87,4 +87,5 @@ set_target_properties ( mixer
+ target_link_libraries ( mixer
+       ${QT_LIBRARIES}
++      components
+       widgets
+       )