about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorkoral <chahine.moreau@gmail.com>2020-02-16 14:40:48 +0100
committerJon <jonringer@users.noreply.github.com>2020-02-20 09:17:50 -0800
commitd57c05acd165ba8a428b13457c87d24175f58136 (patch)
tree2b8bc00faff2d2f0f1036aee0fd8e9e7a5188e0f /pkgs/applications
parent40376f17248a0217e796df599f4403211f91c725 (diff)
downloadnixlib-d57c05acd165ba8a428b13457c87d24175f58136.tar
nixlib-d57c05acd165ba8a428b13457c87d24175f58136.tar.gz
nixlib-d57c05acd165ba8a428b13457c87d24175f58136.tar.bz2
nixlib-d57c05acd165ba8a428b13457c87d24175f58136.tar.lz
nixlib-d57c05acd165ba8a428b13457c87d24175f58136.tar.xz
nixlib-d57c05acd165ba8a428b13457c87d24175f58136.tar.zst
nixlib-d57c05acd165ba8a428b13457c87d24175f58136.zip
mps-youtube: 0.2.8 -> unstable-2020-01-28
Also move derivation from python-packages to all-packages,
as this is a standalone application.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/mps-youtube/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/pkgs/applications/misc/mps-youtube/default.nix b/pkgs/applications/misc/mps-youtube/default.nix
new file mode 100644
index 000000000000..b1118cfc5977
--- /dev/null
+++ b/pkgs/applications/misc/mps-youtube/default.nix
@@ -0,0 +1,34 @@
+{ lib, python3Packages, fetchFromGitHub }:
+
+with python3Packages;
+
+buildPythonApplication rec {
+  pname = "mps-youtube";
+  version = "unstable-2020-01-28";
+
+  src = fetchFromGitHub {
+    owner = "mps-youtube";
+    repo = "mps-youtube";
+    rev = "b808697133ec2ad7654953232d1e841b20aa7cc3";
+    sha256 = "0lqprlpc0v092xqkjc0cc395ag45lijwgd34dpg2jy6i0f2szywv";
+  };
+
+  propagatedBuildInputs = [ pafy ];
+
+  # disabled due to error in loading unittest
+  # don't know how to make test from: <mps_youtube. ...>
+  doCheck = false;
+
+  # before check create a directory and redirect XDG_CONFIG_HOME to it
+  preCheck = ''
+    mkdir -p check-phase
+    export XDG_CONFIG_HOME=$(pwd)/check-phase
+  '';
+
+  meta = with lib; {
+    description = "Terminal based YouTube player and downloader";
+    homepage = "https://github.com/mps-youtube/mps-youtube";
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ koral odi ];
+  };
+}