about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorobadz <obadz-git@obadz.com>2018-05-12 13:16:03 +0100
committerobadz <obadz-git@obadz.com>2018-05-12 13:16:10 +0100
commitd4ec02fa7bb79ca1765a6220206b2f633cc080ef (patch)
tree3caa59b79a263162a3fccf2e5f11afb47e743f96 /pkgs/applications
parentb6708a4c9a7f7779e9288d33a09f1dcb2e701be7 (diff)
downloadnixlib-d4ec02fa7bb79ca1765a6220206b2f633cc080ef.tar
nixlib-d4ec02fa7bb79ca1765a6220206b2f633cc080ef.tar.gz
nixlib-d4ec02fa7bb79ca1765a6220206b2f633cc080ef.tar.bz2
nixlib-d4ec02fa7bb79ca1765a6220206b2f633cc080ef.tar.lz
nixlib-d4ec02fa7bb79ca1765a6220206b2f633cc080ef.tar.xz
nixlib-d4ec02fa7bb79ca1765a6220206b2f633cc080ef.tar.zst
nixlib-d4ec02fa7bb79ca1765a6220206b2f633cc080ef.zip
Revert "Fix pci_get_bus_and_slot removed in kernel 4.17"
This reverts commit d25607c79db9fca7f1c8696b792e376b42fb2ecb.

Reverted as part of #40313 based on commit author's comment:
https://github.com/NixOS/nixpkgs/pull/40313#issuecomment-388409185
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/virtualization/virtualbox/default.nix4
-rw-r--r--pkgs/applications/virtualization/virtualbox/kernpcidev.patch18
2 files changed, 3 insertions, 19 deletions
diff --git a/pkgs/applications/virtualization/virtualbox/default.nix b/pkgs/applications/virtualization/virtualbox/default.nix
index 4a4204f06c02..71c9c8fa6441 100644
--- a/pkgs/applications/virtualization/virtualbox/default.nix
+++ b/pkgs/applications/virtualization/virtualbox/default.nix
@@ -94,7 +94,9 @@ in stdenv.mkDerivation {
 
   patches =
      optional enableHardening ./hardened.patch
-  ++ [ ./qtx11extras.patch ./kernpcidev.patch ];
+  ++ [ ./qtx11extras.patch ];
+
+
 
   postPatch = ''
     sed -i -e 's|/sbin/ifconfig|${nettools}/bin/ifconfig|' \
diff --git a/pkgs/applications/virtualization/virtualbox/kernpcidev.patch b/pkgs/applications/virtualization/virtualbox/kernpcidev.patch
deleted file mode 100644
index 5192227d7d01..000000000000
--- a/pkgs/applications/virtualization/virtualbox/kernpcidev.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/src/VBox/HostDrivers/VBoxPci/linux/VBoxPci-linux.c b/src/VBox/HostDrivers/VBoxPci/linux/VBoxPci-linux.c
-index b8019f7..b7d2e39 100644
---- a/src/VBox/HostDrivers/VBoxPci/linux/VBoxPci-linux.c
-+++ b/src/VBox/HostDrivers/VBoxPci/linux/VBoxPci-linux.c
-@@ -73,8 +73,11 @@ MODULE_LICENSE("GPL");
- MODULE_VERSION(VBOX_VERSION_STRING);
- #endif
- 
--
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 20)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 17, 0)
-+# define PCI_DEV_GET(v,d,p)            pci_get_device(v,d,p)
-+# define PCI_DEV_PUT(x)                pci_dev_put(x)
-+# define PCI_DEV_GET_SLOT(bus, devfn)  pci_get_domain_bus_and_slot(0, bus, devfn)
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 20)
- # define PCI_DEV_GET(v,d,p)            pci_get_device(v,d,p)
- # define PCI_DEV_PUT(x)                pci_dev_put(x)
- # define PCI_DEV_GET_SLOT(bus, devfn)  pci_get_bus_and_slot(bus, devfn)