about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2021-03-25 11:58:47 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2021-03-25 11:58:47 +0100
commitd0830178383056757ec0eca1cddc27b48dd57dc5 (patch)
treeee755c760d5a6262db3a08a88dbc642fbb245c2a /pkgs/applications
parent5769fcd519a1ed5e5ecb1dfdbdeebddabddce6ad (diff)
downloadnixlib-d0830178383056757ec0eca1cddc27b48dd57dc5.tar
nixlib-d0830178383056757ec0eca1cddc27b48dd57dc5.tar.gz
nixlib-d0830178383056757ec0eca1cddc27b48dd57dc5.tar.bz2
nixlib-d0830178383056757ec0eca1cddc27b48dd57dc5.tar.lz
nixlib-d0830178383056757ec0eca1cddc27b48dd57dc5.tar.xz
nixlib-d0830178383056757ec0eca1cddc27b48dd57dc5.tar.zst
nixlib-d0830178383056757ec0eca1cddc27b48dd57dc5.zip
curaByDagoma: use python2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/curabydagoma/default.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/pkgs/applications/misc/curabydagoma/default.nix b/pkgs/applications/misc/curabydagoma/default.nix
index 821b88f9b20d..a8d041de1079 100644
--- a/pkgs/applications/misc/curabydagoma/default.nix
+++ b/pkgs/applications/misc/curabydagoma/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, runtimeShell, lib, fetchurl, python, pythonPackages, unzip }:
+{ stdenv, runtimeShell, lib, fetchurl, python2Packages, unzip }:
 
 # This package uses a precompiled "binary" distribution of CuraByDagoma,
 # distributed by the editor.
@@ -13,7 +13,9 @@
 # I guess people owning a 3D printer generally don't use i686.
 # If, however, someone needs it, we certainly can find a solution.
 
-stdenv.mkDerivation rec {
+let
+  pythonPackages = python2Packages;
+in stdenv.mkDerivation rec {
   pname = "curabydagoma";
   # Version is the date, UNIX format
   version = "1520506579";
@@ -26,7 +28,7 @@ stdenv.mkDerivation rec {
   };
   unpackCmd = "unzip $curSrc && tar zxf CuraByDagoma_amd64.tar.gz";
   nativeBuildInputs = [ unzip ];
-  buildInputs = [ python pythonPackages.pyopengl pythonPackages.wxPython pythonPackages.pyserial pythonPackages.numpy ];
+  buildInputs = [ pythonPackages.python pythonPackages.pyopengl pythonPackages.wxPython pythonPackages.pyserial pythonPackages.numpy ];
 
   # Compile all pyc files because the included pyc files may be older than the
   # py files. However, Python doesn't realize that because the packages
@@ -46,7 +48,7 @@ stdenv.mkDerivation rec {
     cat > $out/bin/curabydago <<EOF
     #!${runtimeShell}
     export PYTHONPATH=$PYTHONPATH
-    ${python.out}/bin/python $out/curabydago/cura.py
+    ${pythonPackages.python.interpreter} $out/curabydago/cura.py
     EOF
     chmod a+x $out/bin/curabydago