about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2021-04-03 02:38:06 +0200
committerGitHub <noreply@github.com>2021-04-03 02:38:06 +0200
commitcd2e10d7743e2120d1c7dcc0b141e3a2bcbc6d80 (patch)
treebe4301ec5eb62ca7acf64da8564c013136a49021 /pkgs/applications
parent11aadf2e08cae211639514de3226ce4ac20332bd (diff)
parentb052255e34daa19901a2f746d0cf11d1105565da (diff)
downloadnixlib-cd2e10d7743e2120d1c7dcc0b141e3a2bcbc6d80.tar
nixlib-cd2e10d7743e2120d1c7dcc0b141e3a2bcbc6d80.tar.gz
nixlib-cd2e10d7743e2120d1c7dcc0b141e3a2bcbc6d80.tar.bz2
nixlib-cd2e10d7743e2120d1c7dcc0b141e3a2bcbc6d80.tar.lz
nixlib-cd2e10d7743e2120d1c7dcc0b141e3a2bcbc6d80.tar.xz
nixlib-cd2e10d7743e2120d1c7dcc0b141e3a2bcbc6d80.tar.zst
nixlib-cd2e10d7743e2120d1c7dcc0b141e3a2bcbc6d80.zip
Merge pull request #108859 from hirenashah/oxefmsynth
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/oxefmsynth/default.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/pkgs/applications/audio/oxefmsynth/default.nix b/pkgs/applications/audio/oxefmsynth/default.nix
new file mode 100644
index 000000000000..427029f3c863
--- /dev/null
+++ b/pkgs/applications/audio/oxefmsynth/default.nix
@@ -0,0 +1,43 @@
+{ stdenv, lib, fetchFromGitHub, unzip, fetchzip, libX11 }:
+
+let
+
+  vst-sdk = stdenv.mkDerivation rec {
+    name = "vstsdk3610_11_06_2018_build_37";
+    src = fetchzip {
+      url = "https://web.archive.org/web/20181016150224if_/https://download.steinberg.net/sdk_downloads/${name}.zip";
+      sha256 = "0da16iwac590wphz2sm5afrfj42jrsnkr1bxcy93lj7a369ildkj";
+    };
+    installPhase = "cp -r . $out";
+  };
+
+in stdenv.mkDerivation rec {
+  pname = "oxefmsynth";
+  version = "1.3.5";
+
+  src = fetchFromGitHub {
+    owner = "oxesoft";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "1rk71ls33a38wx8i22plsi7d89cqqxrfxknq5i4f9igsw1ipm4gn";
+  };
+
+  NIX_CFLAGS_COMPILE = [ "-Wno-error=narrowing" ];
+
+  buildFlags = [ "VSTSDK_PATH=${vst-sdk}/VST2_SDK" ];
+
+  buildInputs = [ libX11 ];
+
+  installPhase = ''
+    mkdir -p $out/lib/lxvst
+    install -Dm644 oxevst64.so -t $out/lib/lxvst
+  '';
+
+  meta = with lib; {
+    homepage = "https://github.com/oxesoft/oxefmsynth";
+    description = "An open source VST 2.4 instrument plugin";
+    maintainers = [ maintainers.hirenashah ];
+    platforms = [ "x86_64-linux" ];
+    license = licenses.gpl3Only;
+  };
+}