about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorUrban Skudnik <urban.skudnik@gmail.com>2018-10-04 13:52:14 +0200
committerUrban Skudnik <urban.skudnik@gmail.com>2018-10-16 20:19:37 +0200
commitc90ad779a00bb21d8976756a147789a068a5556b (patch)
tree7305e91bdb7e409d75476b5b77eb1fd348bc7044 /pkgs/applications
parent6a995e986ac565bfd039051b6ef64adbf2858a46 (diff)
downloadnixlib-c90ad779a00bb21d8976756a147789a068a5556b.tar
nixlib-c90ad779a00bb21d8976756a147789a068a5556b.tar.gz
nixlib-c90ad779a00bb21d8976756a147789a068a5556b.tar.bz2
nixlib-c90ad779a00bb21d8976756a147789a068a5556b.tar.lz
nixlib-c90ad779a00bb21d8976756a147789a068a5556b.tar.xz
nixlib-c90ad779a00bb21d8976756a147789a068a5556b.tar.zst
nixlib-c90ad779a00bb21d8976756a147789a068a5556b.zip
brave: init at 0.25.2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/brave/default.nix108
1 files changed, 108 insertions, 0 deletions
diff --git a/pkgs/applications/networking/browsers/brave/default.nix b/pkgs/applications/networking/browsers/brave/default.nix
new file mode 100644
index 000000000000..d097e0b448ca
--- /dev/null
+++ b/pkgs/applications/networking/browsers/brave/default.nix
@@ -0,0 +1,108 @@
+{ stdenv, lib, fetchurl,
+  dpkg,
+  alsaLib,
+  at-spi2-atk,
+  atk,
+  cairo,
+  cups,
+  dbus,
+  expat,
+  fontconfig,
+  freetype,
+  gdk_pixbuf,
+  glib,
+  gnome2,
+  gtk3,
+  libuuid,
+  libX11,
+  libXcomposite,
+  libXcursor,
+  libXdamage,
+  libXext,
+  libXfixes,
+  libXi,
+  libXrandr,
+  libXrender,
+  libXScrnSaver,
+  libXtst,
+  nspr,
+  nss,
+  pango,
+  udev,
+  xorg,
+  zlib
+}:
+
+let rpath = lib.makeLibraryPath [
+    alsaLib
+    at-spi2-atk
+    atk
+    cairo
+    cups
+    dbus
+    expat
+    fontconfig
+    freetype
+    gdk_pixbuf
+    glib
+    gnome2.GConf
+    gtk3
+    libuuid
+    libX11
+    libXcomposite
+    libXcursor
+    libXdamage
+    libXext
+    libXfixes
+    libXi
+    libXrandr
+    libXrender
+    libXScrnSaver
+    libXtst
+    nspr
+    nss
+    pango
+    udev
+    xorg.libxcb
+    zlib
+];
+
+
+in stdenv.mkDerivation rec {
+    name = "brave";
+    version = "0.25.2";
+
+    src = fetchurl {
+        url = "https://github.com/brave/browser-laptop/releases/download/v${version}dev/brave_${version}_amd64.deb";
+        sha256 = "1r3rsa6szps7mvvpqyw0mg16zn36x451dxq4nmn2l5ds5cp1f017";
+    };
+
+    phases = [ "unpackPhase" "installPhase" ];
+
+    nativeBuildInputs = [ dpkg ];
+
+    unpackPhase = "dpkg-deb -x $src .";
+
+    installPhase = ''
+        mkdir -p $out
+
+        cp -R usr/* $out
+
+        patchelf \
+            --set-interpreter "$(cat $NIX_CC/nix-support/dynamic-linker)" \
+            --set-rpath "${rpath}" $out/bin/brave
+    '';
+
+    meta = with stdenv.lib; {
+        homepage = "https://brave.com/";
+        description = "Privacy-oriented browser for Desktop and Laptop computers";
+        longDescription = ''
+          Brave browser blocks the ads and trackers that slow you down,
+          chew up your bandwidth, and invade your privacy. Brave lets you
+          contribute to your favorite creators automatically.
+        '';
+        license = licenses.mpl20;
+        maintainers = [ maintainers.uskudnik ];
+        platforms = [ "x86_64-linux" ];
+    };
+}