about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAnderson Torres <torres.anderson.85@protonmail.com>2021-01-01 09:46:26 -0300
committerGitHub <noreply@github.com>2021-01-01 09:46:26 -0300
commitc868414fcf290e98b2a5e167388a3db1fe54d5e9 (patch)
treeeffa16b76b46f4f9ea92ffa4afaa897273f6fa47 /pkgs/applications
parent9fbcb14780cab86d7beb4b7798cb78fa078b5b45 (diff)
parentb4a9a5ad71e728c2254228cb75b79b96b4ec5aed (diff)
downloadnixlib-c868414fcf290e98b2a5e167388a3db1fe54d5e9.tar
nixlib-c868414fcf290e98b2a5e167388a3db1fe54d5e9.tar.gz
nixlib-c868414fcf290e98b2a5e167388a3db1fe54d5e9.tar.bz2
nixlib-c868414fcf290e98b2a5e167388a3db1fe54d5e9.tar.lz
nixlib-c868414fcf290e98b2a5e167388a3db1fe54d5e9.tar.xz
nixlib-c868414fcf290e98b2a5e167388a3db1fe54d5e9.tar.zst
nixlib-c868414fcf290e98b2a5e167388a3db1fe54d5e9.zip
Merge pull request #107831 from magnetophon/emulsion
emulsion: init at 7.2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/emulsion/default.nix85
1 files changed, 85 insertions, 0 deletions
diff --git a/pkgs/applications/graphics/emulsion/default.nix b/pkgs/applications/graphics/emulsion/default.nix
new file mode 100644
index 000000000000..ba7ebfcfdff6
--- /dev/null
+++ b/pkgs/applications/graphics/emulsion/default.nix
@@ -0,0 +1,85 @@
+{ stdenv
+, lib
+, fetchFromGitHub
+, rustPlatform
+, installShellFiles
+, makeWrapper
+, pkg-config
+, python3
+, libGL
+, libX11
+, libXcursor
+, libXi
+, libXrandr
+, libXxf86vm
+, libxcb
+, libxkbcommon
+, wayland
+, xdg_utils
+, AppKit
+, CoreGraphics
+, CoreServices
+, Foundation
+, OpenGL
+}:
+let
+  rpathLibs = [
+    libGL
+    libX11
+    libXcursor
+    libXi
+    libXrandr
+    libXxf86vm
+    libxcb
+  ] ++ lib.optionals stdenv.isLinux [
+    libxkbcommon
+    wayland
+  ];
+in
+rustPlatform.buildRustPackage rec {
+  pname = "emulsion";
+  version = "7.2";
+
+  src = fetchFromGitHub {
+    owner = "ArturKovacs";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "1king04p5j4gsvprrfppwaxa5jn4ga4nc0v63wl6fvq2ngwnkg4g";
+  };
+
+  cargoSha256 = "19vb2q5w3063l7349p1b8q40n97a4hxdvc7h7qsx1iiwp75knbd0";
+
+  nativeBuildInputs = [
+    installShellFiles
+    makeWrapper
+    pkg-config
+    python3
+  ];
+
+  buildInputs = rpathLibs ++ lib.optionals stdenv.isDarwin [
+    AppKit
+    CoreGraphics
+    CoreServices
+    Foundation
+    OpenGL
+  ];
+
+  installPhase = ''
+    runHook preInstall
+    install -D $releaseDir/emulsion $out/bin/emulsion
+  '' + lib.optionalString stdenv.isLinux ''
+      patchelf --set-rpath "${lib.makeLibraryPath rpathLibs}" $out/bin/emulsion
+  '' + ''
+    runHook postInstall
+  '';
+
+  dontPatchELF = true;
+
+  meta = with lib; {
+    description = "A fast and minimalistic image viewer";
+    homepage = "https://arturkovacs.github.io/emulsion-website/";
+    maintainers = [ maintainers.magnetophon ];
+    platforms = platforms.unix;
+    license = licenses.mit;
+  };
+}