about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorArseniy Seroka <jagajaga@users.noreply.github.com>2014-11-28 14:36:53 +0300
committerArseniy Seroka <jagajaga@users.noreply.github.com>2014-11-28 14:36:53 +0300
commitc1985405cceae6535077bfb55e995da994e43f2f (patch)
tree711894fe8da8d9a73f8d8b2ccd9a9bf852c5ea84 /pkgs/applications
parenta94da8c44c0e694450dbd6f30737cd254702251b (diff)
parent917bf6865a52648af8c871cc9c3ab71895f5f872 (diff)
downloadnixlib-c1985405cceae6535077bfb55e995da994e43f2f.tar
nixlib-c1985405cceae6535077bfb55e995da994e43f2f.tar.gz
nixlib-c1985405cceae6535077bfb55e995da994e43f2f.tar.bz2
nixlib-c1985405cceae6535077bfb55e995da994e43f2f.tar.lz
nixlib-c1985405cceae6535077bfb55e995da994e43f2f.tar.xz
nixlib-c1985405cceae6535077bfb55e995da994e43f2f.tar.zst
nixlib-c1985405cceae6535077bfb55e995da994e43f2f.zip
Merge pull request #5152 from manveru/neovim
add neovim
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/neovim/default.nix65
1 files changed, 65 insertions, 0 deletions
diff --git a/pkgs/applications/editors/neovim/default.nix b/pkgs/applications/editors/neovim/default.nix
new file mode 100644
index 000000000000..1c1c050b0000
--- /dev/null
+++ b/pkgs/applications/editors/neovim/default.nix
@@ -0,0 +1,65 @@
+{ stdenv, fetchgit, fetchurl, unzip, callPackage, ncurses, gettext, pkgconfig,
+cmake, pkgs, lpeg, lua, luajit, luaMessagePack, luabitop }:
+
+stdenv.mkDerivation rec {
+  name = "neovim-nightly";
+
+  version = "nightly";
+
+  src = fetchgit {
+    url = "https://github.com/neovim/neovim";
+    rev = "68fcd8b696dae33897303c9f8265629a31afbf17";
+    sha256 = "0hxkcy641jpn4qka44gfvhmb6q3dkjx6lvn9748lcl2gx2d36w4i";
+  };
+
+  libmsgpack = stdenv.mkDerivation rec {
+    version = "0.5.9";
+    name = "libmsgpack-${version}";
+
+    src = fetchgit {
+      rev = "ecf4b09acd29746829b6a02939db91dfdec635b4";
+      url = "https://github.com/msgpack/msgpack-c";
+      sha256 = "076ygqgxrc3vk2l20l8x2cgcv05py3am6mjjkknr418pf8yav2ww";
+    };
+
+    buildInputs = [ cmake ];
+
+    meta = with stdenv.lib; {
+      description = "MessagePack implementation for C and C++";
+      homepage = http://msgpack.org;
+      maintainers = [ maintainers.manveru ];
+      license = licenses.asl20;
+      platforms = platforms.all;
+    };
+  };
+
+  enableParallelBuilding = true;
+
+  buildInputs = [
+    ncurses
+    pkgconfig
+    cmake
+    pkgs.libuvVersions.v0_11_29
+    luajit
+    lua
+    lpeg
+    luaMessagePack
+    luabitop
+    libmsgpack
+  ];
+  nativeBuildInputs = [ gettext ];
+
+  LUA_CPATH="${lpeg}/lib/lua/${lua.luaversion}/?.so;${luabitop}/lib/lua/5.2/?.so";
+  LUA_PATH="${luaMessagePack}/share/lua/5.1/?.lua";
+  cmakeFlags = [
+    "-DUSE_BUNDLED_MSGPACK=ON"
+  ];
+
+  meta = with stdenv.lib; {
+    description = "Aggressive refactor of Vim";
+    homepage    = http://www.neovim.org;
+    maintainers = with maintainers; [ manveru ];
+    platforms   = platforms.unix;
+  };
+}
+