about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMarek Mahut <marek.mahut@gmail.com>2019-08-25 17:07:34 +0200
committerMarek Mahut <marek.mahut@gmail.com>2019-08-25 18:33:12 +0200
commitc0cd8e33c80b788f016b603756d43632f4e84eae (patch)
treee3ed3b9cb96aa4424bd631ac80f834e39d0402a4 /pkgs/applications
parentd9cf3ee80f73bf54cc1c227c7eb9383dffd1ba08 (diff)
downloadnixlib-c0cd8e33c80b788f016b603756d43632f4e84eae.tar
nixlib-c0cd8e33c80b788f016b603756d43632f4e84eae.tar.gz
nixlib-c0cd8e33c80b788f016b603756d43632f4e84eae.tar.bz2
nixlib-c0cd8e33c80b788f016b603756d43632f4e84eae.tar.lz
nixlib-c0cd8e33c80b788f016b603756d43632f4e84eae.tar.xz
nixlib-c0cd8e33c80b788f016b603756d43632f4e84eae.tar.zst
nixlib-c0cd8e33c80b788f016b603756d43632f4e84eae.zip
jormungandr: installing the bootstrap scripts
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/altcoins/jormungandr/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/applications/altcoins/jormungandr/default.nix b/pkgs/applications/altcoins/jormungandr/default.nix
index abfd3fa51718..8c276d6bb805 100644
--- a/pkgs/applications/altcoins/jormungandr/default.nix
+++ b/pkgs/applications/altcoins/jormungandr/default.nix
@@ -24,6 +24,22 @@ rustPlatform.buildRustPackage rec {
   nativeBuildInputs = [ pkgconfig protobuf ];
   buildInputs = [ openssl ] ++ lib.optionals stdenv.isDarwin [ darwin.apple_sdk.frameworks.Security ];
 
+  patchPhase = ''
+    sed -i "s~SCRIPTPATH=.*~SCRIPTPATH=$out/templates/~g" scripts/bootstrap
+  '';
+
+  installPhase = ''
+    install -d $out/bin $out/templates
+    install -m755 target/*/release/jormungandr $out/bin/
+    install -m755 target/*/release/jcli $out/bin/
+    install -m755 scripts/send-transaction $out/templates
+    install -m755 scripts/jcli-helpers $out/bin/
+    install -m755 scripts/bootstrap $out/bin/jormungandr-bootstrap
+    install -m644 scripts/faucet-send-money.shtempl $out/templates/
+    install -m644 scripts/create-account-and-delegate.shtempl $out/templates/
+    install -m644 scripts/faucet-send-certificate.shtempl $out/templates/
+  '';
+
   PROTOC = "${protobuf}/bin/protoc";
 
   # Disabling integration tests