about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2020-04-12 03:39:54 -0500
committerGitHub <noreply@github.com>2020-04-12 03:39:54 -0500
commitbba28099b26807a57783d94ba12bf2463b7355c6 (patch)
tree30b85cd8211bbe813833ff2c651bbc57e9ec600e /pkgs/applications
parente7ca19f7cb075fd1c4d15d76157fa41c2080b430 (diff)
parenta37e2f2f1db5fb6f65f0f37209241dafef553ef9 (diff)
downloadnixlib-bba28099b26807a57783d94ba12bf2463b7355c6.tar
nixlib-bba28099b26807a57783d94ba12bf2463b7355c6.tar.gz
nixlib-bba28099b26807a57783d94ba12bf2463b7355c6.tar.bz2
nixlib-bba28099b26807a57783d94ba12bf2463b7355c6.tar.lz
nixlib-bba28099b26807a57783d94ba12bf2463b7355c6.tar.xz
nixlib-bba28099b26807a57783d94ba12bf2463b7355c6.tar.zst
nixlib-bba28099b26807a57783d94ba12bf2463b7355c6.zip
Merge pull request #84942 from marsam/update-zeek
zeek: 3.0.3 -> 3.1.1
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/ids/zeek/default.nix20
1 files changed, 15 insertions, 5 deletions
diff --git a/pkgs/applications/networking/ids/zeek/default.nix b/pkgs/applications/networking/ids/zeek/default.nix
index 9d1df501369f..6faacf2e67e6 100644
--- a/pkgs/applications/networking/ids/zeek/default.nix
+++ b/pkgs/applications/networking/ids/zeek/default.nix
@@ -1,25 +1,35 @@
 {stdenv, fetchurl, cmake, flex, bison, openssl, libpcap, zlib, file, curl
-, libmaxminddb, gperftools, python, swig, rocksdb }:
+, libmaxminddb, gperftools, python, swig, fetchpatch }:
 let
   preConfigure = (import ./script.nix);
 in
 stdenv.mkDerivation rec {
   pname = "zeek";
-  version = "3.0.3";
+  version = "3.1.1";
 
   src = fetchurl {
     url = "https://old.zeek.org/downloads/zeek-${version}.tar.gz";
-    sha256 = "0xlw5v83qbgy23wdcddmvan2pid28mw745g4fc1z5r18kp67i8a2";
+    sha256 = "0siybzdp8w62jqk5vdi5fxwvj6cn4r6c2d4z2axd4rj5vhv5zvx2";
   };
 
   nativeBuildInputs = [ cmake flex bison file ];
-  buildInputs = [ openssl libpcap zlib curl libmaxminddb gperftools python swig rocksdb ];
+  buildInputs = [ openssl libpcap zlib curl libmaxminddb gperftools python swig ];
 
   #see issue https://github.com/zeek/zeek/issues/804 to modify hardlinking duplicate files.
   inherit preConfigure;
-  
+
   enableParallelBuilding = true;
 
+  patches = stdenv.lib.optionals stdenv.cc.isClang [
+    # Fix pybind c++17 build with Clang. See: https://github.com/pybind/pybind11/issues/1604
+    (fetchpatch {
+      url = "https://github.com/pybind/pybind11/commit/759221f5c56939f59d8f342a41f8e2d2cacbc8cf.patch";
+      sha256 = "0l8z7d7chq1awd8dnfarj4c40wx36hkhcan0702p5l89x73wqk54";
+      extraPrefix = "aux/broker/bindings/python/3rdparty/pybind11/";
+      stripLen = 1;
+    })
+  ];
+
   cmakeFlags = [
     "-DPY_MOD_INSTALL_DIR=${placeholder "out"}/${python.sitePackages}"
     "-DENABLE_PERFTOOLS=true"