about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-07-05 18:05:57 -0400
committerGitHub <noreply@github.com>2018-07-05 18:05:57 -0400
commitbb0febf575bb847e632a507e2c3b75eb0ec63b01 (patch)
treedc8a3b53df11785addab6ae283af7fac6a402ad8 /pkgs/applications
parentcdebd1c61f9dc713406ced66923bf9dd678d813c (diff)
parentad20a4a1c328967c7e4abe211f3dd63bb68bf966 (diff)
downloadnixlib-bb0febf575bb847e632a507e2c3b75eb0ec63b01.tar
nixlib-bb0febf575bb847e632a507e2c3b75eb0ec63b01.tar.gz
nixlib-bb0febf575bb847e632a507e2c3b75eb0ec63b01.tar.bz2
nixlib-bb0febf575bb847e632a507e2c3b75eb0ec63b01.tar.lz
nixlib-bb0febf575bb847e632a507e2c3b75eb0ec63b01.tar.xz
nixlib-bb0febf575bb847e632a507e2c3b75eb0ec63b01.tar.zst
nixlib-bb0febf575bb847e632a507e2c3b75eb0ec63b01.zip
Merge pull request #43079 from matthewbauer/rework-extra-pkgs
Rework stage.nix's extraPkgs
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/programming/scyther/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/applications/science/programming/scyther/default.nix b/pkgs/applications/science/programming/scyther/default.nix
index beef26c6032a..e0993a580193 100644
--- a/pkgs/applications/science/programming/scyther/default.nix
+++ b/pkgs/applications/science/programming/scyther/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, buildEnv, callPackage_i686, fetchFromGitHub, python27Packages, graphviz
+{ stdenv, lib, buildEnv, pkgsi686Linux, fetchFromGitHub, python27Packages, graphviz
 , includeGUI ? true
 , includeProtocols ? true
 }:
@@ -20,7 +20,7 @@ let
     platforms = platforms.linux;
   };
 
-  cli = callPackage_i686 ./cli.nix {
+  cli = pkgsi686Linux.callPackage ./cli.nix {
     inherit version src meta;
   };
 
@@ -47,7 +47,7 @@ let
       python27Packages.wxPython
       graphviz
     ];
- 
+
     installPhase = ''
       mkdir -p "$out"/gui "$out"/bin
       cp -r gui/* "$out"/gui