about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2017-09-02 18:47:46 +0200
committerGitHub <noreply@github.com>2017-09-02 18:47:46 +0200
commitb6730e7684810bfad65265b4df5e4e80044d99e3 (patch)
treead0b30c466e1fadcf88899b334fae173e286d9bc /pkgs/applications
parent491f5be49b9b802962f698fe77835f4647b34b38 (diff)
parentf9c2cb80a6176df9b9f06938eaab9a356626ded2 (diff)
downloadnixlib-b6730e7684810bfad65265b4df5e4e80044d99e3.tar
nixlib-b6730e7684810bfad65265b4df5e4e80044d99e3.tar.gz
nixlib-b6730e7684810bfad65265b4df5e4e80044d99e3.tar.bz2
nixlib-b6730e7684810bfad65265b4df5e4e80044d99e3.tar.lz
nixlib-b6730e7684810bfad65265b4df5e4e80044d99e3.tar.xz
nixlib-b6730e7684810bfad65265b4df5e4e80044d99e3.tar.zst
nixlib-b6730e7684810bfad65265b4df5e4e80044d99e3.zip
Merge pull request #28887 from womfoo/fix/ekiga-build
ekiga: fix build and cleanup patches
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/instant-messengers/ekiga/autofoo.patch11
-rw-r--r--pkgs/applications/networking/instant-messengers/ekiga/boost.patch31
-rw-r--r--pkgs/applications/networking/instant-messengers/ekiga/default.nix15
3 files changed, 12 insertions, 45 deletions
diff --git a/pkgs/applications/networking/instant-messengers/ekiga/autofoo.patch b/pkgs/applications/networking/instant-messengers/ekiga/autofoo.patch
deleted file mode 100644
index d15e8b6ccfd4..000000000000
--- a/pkgs/applications/networking/instant-messengers/ekiga/autofoo.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -4,7 +4,7 @@
- AC_PREREQ([2.53])
- AC_CONFIG_MACRO_DIR([m4])
- AC_CONFIG_SRCDIR(src/ekiga.cpp)
--AM_INIT_AUTOMAKE([1.11 no-dist-gzip dist-xz tar-ustar])
-+AM_INIT_AUTOMAKE([1.11 no-dist-gzip dist-xz tar-ustar subdir-objects])
- 
- AM_MAINTAINER_MODE([enable])
- AC_CONFIG_HEADERS([config.h])
diff --git a/pkgs/applications/networking/instant-messengers/ekiga/boost.patch b/pkgs/applications/networking/instant-messengers/ekiga/boost.patch
deleted file mode 100644
index 9dad3d94f04b..000000000000
--- a/pkgs/applications/networking/instant-messengers/ekiga/boost.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/m4/ax_boost_base.m4
-+++ b/m4/ax_boost_base.m4
-@@ -33,7 +33,7 @@
- #   and this notice are preserved. This file is offered as-is, without any
- #   warranty.
- 
--#serial 20
-+#serial 22
- 
- AC_DEFUN([AX_BOOST_BASE],
- [
-@@ -91,9 +91,17 @@ if test "x$want_boost" = "xyes"; then
-     dnl are found, e.g. when only header-only libraries are installed!
-     libsubdirs="lib"
-     ax_arch=`uname -m`
--    if test $ax_arch = x86_64 -o $ax_arch = ppc64 -o $ax_arch = s390x -o $ax_arch = sparc64; then
-+    case $ax_arch in
-+      x86_64|ppc64|s390x|sparc64|aarch64)
-         libsubdirs="lib64 lib lib64"
--    fi
-+        ;;
-+    esac
-+
-+    dnl allow for real multi-arch paths e.g. /usr/lib/x86_64-linux-gnu. Give
-+    dnl them priority over the other paths since, if libs are found there, they
-+    dnl are almost assuredly the ones desired.
-+    AC_REQUIRE([AC_CANONICAL_HOST])
-+    libsubdirs="lib/${host_cpu}-${host_os} $libsubdirs"
- 
-     dnl first we check the system location for boost libraries
-     dnl this location ist chosen if boost libraries are installed with the --layout=system option
diff --git a/pkgs/applications/networking/instant-messengers/ekiga/default.nix b/pkgs/applications/networking/instant-messengers/ekiga/default.nix
index 575759ad4372..283d38ef5c74 100644
--- a/pkgs/applications/networking/instant-messengers/ekiga/default.nix
+++ b/pkgs/applications/networking/instant-messengers/ekiga/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, glib, fetchurl, cyrus_sasl, gettext, openldap, ptlib, opal, libXv, rarian, intltool
+{ stdenv, glib, fetchurl, fetchpatch, cyrus_sasl, gettext, openldap, ptlib, opal, libXv, rarian, intltool
 , perl, perlXMLParser, evolution_data_server, gnome_doc_utils, avahi, autoreconfHook
 , libsigcxx, gtk, dbus_glib, libnotify, libXext, xextproto, gnome3, boost, libsecret
 , pkgconfig, libxml2, videoproto, unixODBC, db, nspr, nss, zlib, hicolor_icon_theme
@@ -34,7 +34,17 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
-  patches = [ ./autofoo.patch ./boost.patch ];
+  patches = [
+    (fetchpatch { url = https://sources.debian.net/data/main/e/ekiga/4.0.1-7/debian/patches/autofoo.patch;
+      sha256 = "1vyagslws4mm9yfz1m5p1kv9sxmk5lls9vxpm6j72q2ahsgydzx4";
+    })
+    (fetchpatch { url = https://sources.debian.net/data/main/e/ekiga/4.0.1-7/debian/patches/boost.patch;
+      sha256 = "01k0rw8ibrrf9zn9lx6dzbrgy58w089hqxqxqdv9whb65cldlj5s";
+    })
+    (fetchpatch { url = https://src.fedoraproject.org/rpms/ekiga/raw/dbf5f5ba449d22bd79f0394cddb7d4d8a88ec6ac/f/ekiga-4.0.1-libresolv.patch;
+      sha256 = "18wc68im8422ibpa0gkrkgjq41m7hikaha3xqmjs2km45i1cwcaz";
+    })
+  ];
 
   postInstall = ''
     wrapProgram "$out"/bin/ekiga \
@@ -45,7 +55,6 @@ stdenv.mkDerivation rec {
     description = "VOIP/Videoconferencing app with full SIP and H.323 support";
     maintainers = [ maintainers.raskin ];
     platforms = platforms.linux;
-    broken = true; # because of glibc-2.25
   };
 
   passthru = {