about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorzowoq <59103226+zowoq@users.noreply.github.com>2020-05-13 21:37:48 +1000
committerzowoq <59103226+zowoq@users.noreply.github.com>2020-05-14 23:08:01 +1000
commitb57ae988643eed4d05e5b2671e42abb054edee0a (patch)
treefa0bdb5e9dc2afb3bf9cfcd6c086a77dd776b035 /pkgs/applications
parente142fbb3f7545863268b82440cb16bf1266add86 (diff)
downloadnixlib-b57ae988643eed4d05e5b2671e42abb054edee0a.tar
nixlib-b57ae988643eed4d05e5b2671e42abb054edee0a.tar.gz
nixlib-b57ae988643eed4d05e5b2671e42abb054edee0a.tar.bz2
nixlib-b57ae988643eed4d05e5b2671e42abb054edee0a.tar.lz
nixlib-b57ae988643eed4d05e5b2671e42abb054edee0a.tar.xz
nixlib-b57ae988643eed4d05e5b2671e42abb054edee0a.tar.zst
nixlib-b57ae988643eed4d05e5b2671e42abb054edee0a.zip
runc: add libselinux, update buildtags
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/virtualization/runc/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/applications/virtualization/runc/default.nix b/pkgs/applications/virtualization/runc/default.nix
index 95db2a1d9e9a..1bf6b3d574a9 100644
--- a/pkgs/applications/virtualization/runc/default.nix
+++ b/pkgs/applications/virtualization/runc/default.nix
@@ -8,6 +8,7 @@
 , libapparmor
 , apparmor-parser
 , libseccomp
+, libselinux
 }:
 
 buildGoPackage rec {
@@ -25,9 +26,11 @@ buildGoPackage rec {
   outputs = [ "out" "man" ];
 
   nativeBuildInputs = [ go-md2man installShellFiles pkg-config which ];
-  buildInputs = [ libseccomp libapparmor apparmor-parser ];
 
-  makeFlags = [ "BUILDTAGS+=seccomp" "BUILDTAGS+=apparmor" ];
+  buildInputs = [ libselinux libseccomp libapparmor apparmor-parser ];
+
+  # these will be the default in the next release
+  makeFlags = [ "BUILDTAGS+=seccomp" "BUILDTAGS+=apparmor" "BUILDTAGS+=selinux" ];
 
   buildPhase = ''
     cd go/src/${goPackagePath}