about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2017-12-27 17:20:32 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-12-27 17:20:32 -0500
commitb3df1562d86638ef052e6c9d0f21498f11a3e15e (patch)
tree7a70f4558cd34853abdf967397ac998280830b2c /pkgs/applications
parente16f887ec50ef0060de6d0ef8a59462541a28665 (diff)
parent558c96fe13a692b5023d959933c89df4e0c49a34 (diff)
downloadnixlib-b3df1562d86638ef052e6c9d0f21498f11a3e15e.tar
nixlib-b3df1562d86638ef052e6c9d0f21498f11a3e15e.tar.gz
nixlib-b3df1562d86638ef052e6c9d0f21498f11a3e15e.tar.bz2
nixlib-b3df1562d86638ef052e6c9d0f21498f11a3e15e.tar.lz
nixlib-b3df1562d86638ef052e6c9d0f21498f11a3e15e.tar.xz
nixlib-b3df1562d86638ef052e6c9d0f21498f11a3e15e.tar.zst
nixlib-b3df1562d86638ef052e6c9d0f21498f11a3e15e.zip
Merge branch 'alt-stdenv' into staging
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/airwave/default.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/pkgs/applications/audio/airwave/default.nix b/pkgs/applications/audio/airwave/default.nix
index 4f010213b653..c37963c77f3e 100644
--- a/pkgs/applications/audio/airwave/default.nix
+++ b/pkgs/applications/audio/airwave/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, cmake, fetchFromGitHub, file, gcc_multi, libX11, makeWrapper
+{ stdenv, multiStdenv, cmake, fetchFromGitHub, file, libX11, makeWrapper
 , overrideCC, qt5, requireFile, unzip, wine
 }:
 
@@ -13,8 +13,6 @@ let
     sha256 = "1ban59skw422mak3cp57lj27hgq5d3a4f6y79ysjnamf8rpz9x4s";
   };
 
-  stdenv_multi = overrideCC stdenv gcc_multi;
-
   vst-sdk = stdenv.mkDerivation rec {
     name = "vstsdk368_08_11_2017_build_121";
     src = requireFile {
@@ -38,7 +36,7 @@ let
 
 in
 
-stdenv_multi.mkDerivation {
+multiStdenv.mkDerivation {
   name = "airwave-${version}";
 
   src = airwave-src;
@@ -54,7 +52,7 @@ stdenv_multi.mkDerivation {
     # For airwave-host-32.exe.so, point wineg++ to 32-bit versions of
     # these libraries, as $NIX_LDFLAGS contains only 64-bit ones.
     substituteInPlace src/host/CMakeLists.txt --replace '-m32' \
-      '-m32 -L${wine-xembed}/lib -L${wine-xembed}/lib/wine -L${stdenv_multi.cc.libc.out}/lib/32'
+      '-m32 -L${wine-xembed}/lib -L${wine-xembed}/lib/wine -L${multiStdenv.cc.libc.out}/lib/32'
   '';
 
   # libstdc++.so link gets lost in 64-bit executables during