about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAndrew Cann <shum@canndrew.org>2017-04-13 11:53:35 +0800
committerAndrew Cann <shum@canndrew.org>2017-04-13 11:56:06 +0800
commitb306e672a18aa3fccc58eebf6e329df851db0ae8 (patch)
tree8261c4cf1113a0656957f0cd94ef4cb642375a53 /pkgs/applications
parentefe12d665812e2c5f7c20513a829edff5b8b1977 (diff)
downloadnixlib-b306e672a18aa3fccc58eebf6e329df851db0ae8.tar
nixlib-b306e672a18aa3fccc58eebf6e329df851db0ae8.tar.gz
nixlib-b306e672a18aa3fccc58eebf6e329df851db0ae8.tar.bz2
nixlib-b306e672a18aa3fccc58eebf6e329df851db0ae8.tar.lz
nixlib-b306e672a18aa3fccc58eebf6e329df851db0ae8.tar.xz
nixlib-b306e672a18aa3fccc58eebf6e329df851db0ae8.tar.zst
nixlib-b306e672a18aa3fccc58eebf6e329df851db0ae8.zip
hivemind: init at git-2017-04-13
Hivemind is a peer-to-peer oracle protocol which absorbs accurate data
into a blockchain so that bitcoin-users can speculate in prediction
markets.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/altcoins/default.nix3
-rw-r--r--pkgs/applications/altcoins/hivemind.nix39
2 files changed, 42 insertions, 0 deletions
diff --git a/pkgs/applications/altcoins/default.nix b/pkgs/applications/altcoins/default.nix
index fbc3d1c36f91..b51acea061f1 100644
--- a/pkgs/applications/altcoins/default.nix
+++ b/pkgs/applications/altcoins/default.nix
@@ -22,6 +22,9 @@ rec {
   freicoin = callPackage ./freicoin.nix { boost = pkgs.boost155; };
   go-ethereum = callPackage ./go-ethereum.nix { };
 
+  hivemind = callPackage ./hivemind.nix { withGui = true; };
+  hivemindd = callPackage ./hivemind.nix { withGui = false; };
+
   litecoin  = callPackage ./litecoin.nix { withGui = true; };
   litecoind = callPackage ./litecoin.nix { withGui = false; };
 
diff --git a/pkgs/applications/altcoins/hivemind.nix b/pkgs/applications/altcoins/hivemind.nix
new file mode 100644
index 000000000000..179a96c04499
--- /dev/null
+++ b/pkgs/applications/altcoins/hivemind.nix
@@ -0,0 +1,39 @@
+{ stdenv, fetchFromGitHub, pkgconfig, autoreconfHook, openssl, db48, boost
+, zlib, miniupnpc, qt4, utillinux, protobuf, qrencode, libevent
+, withGui }:
+
+with stdenv.lib;
+stdenv.mkDerivation rec {
+  name = "hivemind" + (toString (optional (!withGui) "d")) + "-" + version;
+  version = "git-2017-04-13";
+
+  src = fetchFromGitHub {
+    owner = "bitcoin-hivemind";
+    repo = "hivemind";
+    rev = "147973cfe76867410578d91d6f0a8df105cab4e0";
+    sha256 = "1ndqqma1b0sh2gn7cl8d9fg44q0g2g42jr2y0nifkjgfjn3c7l5h";
+  };
+
+  nativeBuildInputs = [ pkgconfig autoreconfHook ];
+  buildInputs = [ openssl db48 boost zlib
+                  miniupnpc protobuf libevent]
+                  ++ optionals stdenv.isLinux [ utillinux ]
+                  ++ optionals withGui [ qt4 qrencode ];
+
+  configureFlags = [ "--with-boost-libdir=${boost.out}/lib" 
+                     "--with-incompatible-bdb"
+                   ] ++ optionals withGui [ "--with-gui=qt4" ];
+
+  meta = {
+    description = "Peer-to-Peer oracle protocol";
+    longDescription= ''
+      Hivemind is a Peer-to-Peer Oracle Protocol which absorbs accurate data
+      into a blockchain so that Bitcoin-users can speculate in Prediction
+      Markets.
+    '';
+    homepage = "https://bitcoinhivemind.com";
+    maintainers = with maintainers; [ canndrew ];
+    license = licenses.mit;
+    platforms = platforms.unix;
+  };
+}