about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-05-27 21:56:04 +0200
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-05-27 22:00:06 +0200
commitb2d7f4b1ba937951fefdd026314512ab0be91508 (patch)
treed1f7fc189bac34f376069294d67abfa3c8551693 /pkgs/applications
parent87fd373aac3a1aaa84ddb328d43074aeebc1b133 (diff)
downloadnixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.gz
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.bz2
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.lz
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.xz
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.zst
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.zip
Use common licence attributes from lib/licenses.nix
Many (less easily automatically converted) old-style strings
remain.

Where there was any possible ambiguity about the exact version or
variant intended, nothing was changed. IANAL, nor a search robot.

Use `with stdenv.lib` wherever it makes sense.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/beast/default.nix4
-rw-r--r--pkgs/applications/editors/emacs-modes/jabber/default.nix8
-rw-r--r--pkgs/applications/editors/emacs-modes/nyan-mode/default.nix6
-rw-r--r--pkgs/applications/graphics/gimp/plugins/default.nix4
-rw-r--r--pkgs/applications/misc/eaglemode/default.nix8
-rw-r--r--pkgs/applications/networking/browsers/conkeror/default.nix8
-rw-r--r--pkgs/applications/networking/browsers/mozilla-plugins/fribid/default.nix8
-rw-r--r--pkgs/applications/networking/browsers/mozilla-plugins/mplayerplug-in/default.nix4
-rw-r--r--pkgs/applications/networking/browsers/netsurf/netsurf.nix11
-rw-r--r--pkgs/applications/science/electronics/ngspice/default.nix8
-rw-r--r--pkgs/applications/science/math/pari/default.nix8
-rw-r--r--pkgs/applications/science/math/speedcrunch/default.nix4
-rw-r--r--pkgs/applications/science/molecular-dynamics/gromacs/default.nix4
-rw-r--r--pkgs/applications/video/dvdauthor/default.nix4
-rw-r--r--pkgs/applications/window-managers/awesome/default.nix2
-rw-r--r--pkgs/applications/window-managers/tabbed/default.nix8
-rw-r--r--pkgs/applications/window-managers/vwm/default.nix8
-rw-r--r--pkgs/applications/window-managers/wmii/default.nix2
-rw-r--r--pkgs/applications/window-managers/wmii31/default.nix2
19 files changed, 57 insertions, 54 deletions
diff --git a/pkgs/applications/audio/beast/default.nix b/pkgs/applications/audio/beast/default.nix
index 340a83e7963f..3997855a75b6 100644
--- a/pkgs/applications/audio/beast/default.nix
+++ b/pkgs/applications/audio/beast/default.nix
@@ -29,9 +29,9 @@ stdenv.mkDerivation {
       ./patch.patch # patches taken from gentoo
     ];
 
-  meta = { 
+  meta = with stdenv.lib; {
     description = "A music composition and modular synthesis application";
     homepage = http://beast.gtk.org;
-    license = ["GPL-2" "LGPL-2.1"];
+    license = with licenses; [ gpl2 lgpl21 ];
   };
 }
diff --git a/pkgs/applications/editors/emacs-modes/jabber/default.nix b/pkgs/applications/editors/emacs-modes/jabber/default.nix
index 82028722f54c..cb8a22a3c06f 100644
--- a/pkgs/applications/editors/emacs-modes/jabber/default.nix
+++ b/pkgs/applications/editors/emacs-modes/jabber/default.nix
@@ -8,7 +8,7 @@ stdenv.mkDerivation rec {
     sha256 = "75e3b7853de4783b8ab8270dcbe6a1e4f576224f77f7463116532e11c6498c26";
   };
   buildInputs = [ emacs ];
-  meta = {
+  meta = with stdenv.lib; {
     description = "A Jabber client for Emacs";
     longDescription = ''
       jabber.el is a Jabber client for Emacs. It may seem strange to have a
@@ -16,8 +16,8 @@ stdenv.mkDerivation rec {
       a special case of text editing.
     '';
     homepage = http://emacs-jabber.sourceforge.net/;
-    license = [ "GPLv2+" ];
-    maintainers = with stdenv.lib.maintainers; [ astsmtl ];
-    platforms = with stdenv.lib.platforms; linux;
+    license = with licenses; gpl2Plus;
+    maintainers = with maintainers; [ astsmtl ];
+    platforms = with platforms; linux;
   };
 }
diff --git a/pkgs/applications/editors/emacs-modes/nyan-mode/default.nix b/pkgs/applications/editors/emacs-modes/nyan-mode/default.nix
index ab94dbae9501..a21c73b7e8b0 100644
--- a/pkgs/applications/editors/emacs-modes/nyan-mode/default.nix
+++ b/pkgs/applications/editors/emacs-modes/nyan-mode/default.nix
@@ -1,4 +1,4 @@
-{trivialBuild, fetchFromGitHub}:
+{trivialBuild, lib, fetchFromGitHub}:
 
 trivialBuild rec {
   pname    = "nyan-mode";
@@ -23,9 +23,9 @@ trivialBuild rec {
     cp -r mus $out
   '';
 
-  meta = {
+  meta = with lib; {
     description = "An analog indicator of the position in the buffer";
     homepage = https://github.com/TeMPOraL/nyan-mode/;
-    license = "GPLv3+";
+    license = with licenses; gpl3Plus;
   };
 }
diff --git a/pkgs/applications/graphics/gimp/plugins/default.nix b/pkgs/applications/graphics/gimp/plugins/default.nix
index 5f43abfcfc1e..8ece9ba2453c 100644
--- a/pkgs/applications/graphics/gimp/plugins/default.nix
+++ b/pkgs/applications/graphics/gimp/plugins/default.nix
@@ -59,12 +59,12 @@ rec {
       sed -e 's,^\(GIMP_PLUGIN_DIR=\).*,\1'"$out/${gimp.name}-plugins", \
        -e 's,^\(GIMP_DATA_DIR=\).*,\1'"$out/share/${gimp.name}", -i configure
     '';
-    meta = {
+    meta = with stdenv.lib; {
       description = "The GIMP Animation Package";
       homepage = http://www.gimp.org;
       # The main code is given in GPLv3, but it has ffmpeg in it, and I think ffmpeg license
       # falls inside "free".
-      license = [ "GPLv3" "free" ];
+      license = with licenses; [ gpl3 free ];
     };
   };
 
diff --git a/pkgs/applications/misc/eaglemode/default.nix b/pkgs/applications/misc/eaglemode/default.nix
index db613cd49222..47535ab6b903 100644
--- a/pkgs/applications/misc/eaglemode/default.nix
+++ b/pkgs/applications/misc/eaglemode/default.nix
@@ -31,11 +31,11 @@ stdenv.mkDerivation rec {
     ln -s $out/eaglemode.sh $out/bin/eaglemode.sh
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = "http://eaglemode.sourceforge.net";
     description = "Zoomable User Interface";
-    license="GPLv3";
-    maintainers = with stdenv.lib.maintainers; [viric];
-    platforms = with stdenv.lib.platforms; linux;
+    license = with licenses; gpl3;
+    maintainers = with maintainers; [ viric ];
+    platforms = with platforms; linux;
   };
 }
diff --git a/pkgs/applications/networking/browsers/conkeror/default.nix b/pkgs/applications/networking/browsers/conkeror/default.nix
index f6e3cd3cf8d1..9715b46ed507 100644
--- a/pkgs/applications/networking/browsers/conkeror/default.nix
+++ b/pkgs/applications/networking/browsers/conkeror/default.nix
@@ -19,7 +19,7 @@ stdenv.mkDerivation {
       --add-flags "-app $out/libexec/conkeror/application.ini"
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "A keyboard-oriented, customizable, extensible web browser";
     longDescription = ''
       Conkeror is a keyboard-oriented, highly-customizable, highly-extensible
@@ -30,8 +30,8 @@ stdenv.mkDerivation {
       self-documenting, featuring a powerful interactive help system.
     '';
     homepage = http://conkeror.org/;
-    license = [ "MPLv1.1" "GPLv2" "LGPLv2.1" ];
-    maintainers = with stdenv.lib.maintainers; [ astsmtl chaoflow ];
-    platforms = with stdenv.lib.platforms; linux;
+    license = with licenses; [ mpl11 gpl2 lgpl21 ];
+    maintainers = with maintainers; [ astsmtl chaoflow ];
+    platforms = with platforms; linux;
   };
 }
diff --git a/pkgs/applications/networking/browsers/mozilla-plugins/fribid/default.nix b/pkgs/applications/networking/browsers/mozilla-plugins/fribid/default.nix
index 3b473019600f..b8aa17803e9f 100644
--- a/pkgs/applications/networking/browsers/mozilla-plugins/fribid/default.nix
+++ b/pkgs/applications/networking/browsers/mozilla-plugins/fribid/default.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation rec {
 
   passthru.mozillaPlugin = "/lib/mozilla/plugins";
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "A browser plugin to manage Swedish BankID:s";
     longDescription = ''
       FriBID is an open source software for the Swedish e-id system
@@ -30,8 +30,8 @@ stdenv.mkDerivation rec {
       support.
     '';
     homepage = http://fribid.se;
-    license = [ "GPLv2" "MPLv1" ];
-    maintainers = [ stdenv.lib.maintainers.edwtjo ];
-    platforms = with stdenv.lib.platforms; linux;
+    license = with licenses; [ gpl2 mpl10 ];
+    maintainers = [ maintainers.edwtjo ];
+    platforms = with platforms; linux;
   };
 }
diff --git a/pkgs/applications/networking/browsers/mozilla-plugins/mplayerplug-in/default.nix b/pkgs/applications/networking/browsers/mozilla-plugins/mplayerplug-in/default.nix
index 105e5904715c..07e152e91dbc 100644
--- a/pkgs/applications/networking/browsers/mozilla-plugins/mplayerplug-in/default.nix
+++ b/pkgs/applications/networking/browsers/mozilla-plugins/mplayerplug-in/default.nix
@@ -28,9 +28,9 @@ stdenv.mkDerivation rec {
     mozillaPlugin = "/lib/mozilla/plugins";
   };
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "A browser plugin that uses mplayer to play digital media from websites";
     homepage = http://mplayerplug-in.sourceforge.net/;
-    license = [ "GPLv2+" "LGPLv2+" "MPLv1+" ];
+    license = with licenses; [ gpl2Plus lgpl2Plus "MPLv1+" ];
   };
 }
diff --git a/pkgs/applications/networking/browsers/netsurf/netsurf.nix b/pkgs/applications/networking/browsers/netsurf/netsurf.nix
index 2d2253f43ef1..f7e90b61a941 100644
--- a/pkgs/applications/networking/browsers/netsurf/netsurf.nix
+++ b/pkgs/applications/networking/browsers/netsurf/netsurf.nix
@@ -23,12 +23,15 @@ stdenv.mkDerivation {
   buildPhase = "make PREFIX=$out";
   installPhase = "make PREFIX=$out install";
 
-  meta = { 
+  meta = with args.lib; {
     description = "free, open source web browser";
     homepage = http://www.netsurf-browser.org;
-    license = ["GPLv2" /* visual worrk : */ "MIT" ];
-    maintainers = [args.lib.maintainers.marcweber];
-    platforms = args.lib.platforms.linux;
+    license = with licenses; [
+      gpl2
+      mit /* visual work */
+    ];
+    maintainers = with maintainers; [ marcweber ];
+    platforms = platforms.linux;
   };
 
 }
diff --git a/pkgs/applications/science/electronics/ngspice/default.nix b/pkgs/applications/science/electronics/ngspice/default.nix
index 493af97d1567..e64ea909cbb9 100644
--- a/pkgs/applications/science/electronics/ngspice/default.nix
+++ b/pkgs/applications/science/electronics/ngspice/default.nix
@@ -12,11 +12,11 @@ stdenv.mkDerivation {
 
   configureFlags = [ "--enable-x" "--with-x" "--with-readline" ];
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "The Next Generation Spice (Electronic Circuit Simulator)";
     homepage = "http://ngspice.sourceforge.net";
-    license = ["BSD" "GPLv2"];
-    maintainers = with stdenv.lib.maintainers; [viric];
-    platforms = with stdenv.lib.platforms; linux;
+    license = with licenses; [ "BSD" gpl2 ];
+    maintainers = with maintainers; [ viric ];
+    platforms = with platforms; linux;
   };
 }
diff --git a/pkgs/applications/science/math/pari/default.nix b/pkgs/applications/science/math/pari/default.nix
index 0dbab841a81b..b97314f02d1d 100644
--- a/pkgs/applications/science/math/pari/default.nix
+++ b/pkgs/applications/science/math/pari/default.nix
@@ -16,12 +16,12 @@ stdenv.mkDerivation rec {
     "--with-gmp=${gmp} " +
     "--with-readline=${readline}";
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Computer algebra system for high-performance number theory computations";
     homepage    = "http://pari.math.u-bordeaux.fr/";
-    license     = "GPLv2+";
-    maintainers = with stdenv.lib.maintainers; [ertes raskin];
-    platforms   = stdenv.lib.platforms.linux;
+    license     = with licenses; gpl2Plus;
+    maintainers = with maintainers; [ ertes raskin ];
+    platforms   = platforms.linux;
 
     inherit version;
     downloadPage = "http://pari.math.u-bordeaux.fr/download.html";
diff --git a/pkgs/applications/science/math/speedcrunch/default.nix b/pkgs/applications/science/math/speedcrunch/default.nix
index dee33a04be22..e2f34d48de27 100644
--- a/pkgs/applications/science/math/speedcrunch/default.nix
+++ b/pkgs/applications/science/math/speedcrunch/default.nix
@@ -23,9 +23,9 @@ stdenv.mkDerivation rec {
 
   buildFlags = "VERBOSE=1";
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage    = "http://speedcrunch.digitalfanatics.org";
-    license     = "GPLv2+";
+    license     = with licenses; gpl2Plus;
     description = "A fast power user calculator";
     longDescription = ''
       SpeedCrunch is a fast, high precision and powerful desktop calculator.
diff --git a/pkgs/applications/science/molecular-dynamics/gromacs/default.nix b/pkgs/applications/science/molecular-dynamics/gromacs/default.nix
index 879690bc91ed..bb851140b45d 100644
--- a/pkgs/applications/science/molecular-dynamics/gromacs/default.nix
+++ b/pkgs/applications/science/molecular-dynamics/gromacs/default.nix
@@ -19,9 +19,9 @@ stdenv.mkDerivation {
     ${if singlePrec then "-DGMX_DOUBLE=OFF" else "-DGMX_DOUBLE=ON -DGMX_DEFAULT_SUFFIX=OFF"}
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage    = "http://www.gromacs.org";
-    license     = "GPLv2";
+    license     = with licenses; gpl2;
     description = "Molecular dynamics software package";
     longDescription = ''
       GROMACS is a versatile package to perform molecular dynamics,
diff --git a/pkgs/applications/video/dvdauthor/default.nix b/pkgs/applications/video/dvdauthor/default.nix
index cab7b4112d03..03ccb2664fce 100644
--- a/pkgs/applications/video/dvdauthor/default.nix
+++ b/pkgs/applications/video/dvdauthor/default.nix
@@ -18,9 +18,9 @@ stdenv.mkDerivation rec{
     ./dvdauthor-imagemagick-0.7.0.patch
   ];
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Tools for generating DVD files to be played on standalone DVD players";
     homepage = http://dvdauthor.sourceforge.net/;
-    license = ["GPLv2"];
+    license = with licenses; gpl2;
   };
 }
diff --git a/pkgs/applications/window-managers/awesome/default.nix b/pkgs/applications/window-managers/awesome/default.nix
index 3541743057cc..a158dd8dcf45 100644
--- a/pkgs/applications/window-managers/awesome/default.nix
+++ b/pkgs/applications/window-managers/awesome/default.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "Highly configurable, dynamic window manager for X";
     homepage    = http://awesome.naquadah.org/;
-    license     = "GPLv2+";
+    license     = with licenses; gpl2Plus;
     maintainers = with maintainers; [ lovek323 ];
     platforms   = platforms.linux;
   };
diff --git a/pkgs/applications/window-managers/tabbed/default.nix b/pkgs/applications/window-managers/tabbed/default.nix
index 2dec3b2241f2..82539b940b8c 100644
--- a/pkgs/applications/window-managers/tabbed/default.nix
+++ b/pkgs/applications/window-managers/tabbed/default.nix
@@ -18,11 +18,11 @@ stdenv.mkDerivation rec {
     export makeFlags="PREFIX=$out"
   '';
  
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://tools.suckless.org/tabbed;
     description = "Simple generic tabbed fronted to xembed aware applications";
-    license="MIT";
-    maintainers = with stdenv.lib.maintainers; [viric];
-    platforms = with stdenv.lib.platforms; linux;
+    license = with licenses; mit;
+    maintainers = with maintainers; [ viric ];
+    platforms = with platforms; linux;
   };
 }
diff --git a/pkgs/applications/window-managers/vwm/default.nix b/pkgs/applications/window-managers/vwm/default.nix
index 3613bb21ff62..be0a946064b6 100644
--- a/pkgs/applications/window-managers/vwm/default.nix
+++ b/pkgs/applications/window-managers/vwm/default.nix
@@ -22,11 +22,11 @@ stdenv.mkDerivation rec {
  
   buildInputs = [ ncurses pkgconfig glib libviper libpseudo gpm libvterm ];
  
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://vwm.sourceforge.net/;
     description = "Dynamic window manager for the console";
-    license="GPLv2+";
-    maintainers = with stdenv.lib.maintainers; [viric];
-    platforms = with stdenv.lib.platforms; linux;
+    license = with licenses; gpl2Plus;
+    maintainers = with maintainers; [ viric ];
+    platforms = with platforms; linux;
   };
 }
diff --git a/pkgs/applications/window-managers/wmii/default.nix b/pkgs/applications/window-managers/wmii/default.nix
index a44c54f7b575..e8ecc72a6d30 100644
--- a/pkgs/applications/window-managers/wmii/default.nix
+++ b/pkgs/applications/window-managers/wmii/default.nix
@@ -30,6 +30,6 @@ args: with args; stdenv.mkDerivation {
   ";
   meta = { homepage = "www.suckless.org";
            description = "a really cool window manager which can by driven by keyboard only";
-           license="MIT";
+           license = stdenv.lib.licenses.mit;
          };
 }
diff --git a/pkgs/applications/window-managers/wmii31/default.nix b/pkgs/applications/window-managers/wmii31/default.nix
index dd49cf5ec43e..568be30f1c52 100644
--- a/pkgs/applications/window-managers/wmii31/default.nix
+++ b/pkgs/applications/window-managers/wmii31/default.nix
@@ -30,6 +30,6 @@ args: with args; stdenv.mkDerivation {
   ";
   meta = { homepage = "www.suckless.org";
            description = "One small tool of the wmii window manger to let the user select an item from a list by filtering";
-           license="MIT";
+           license = stdenv.lib.licenses.mit;
          };
 }