about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJason Heard <jasonpheard@gmail.com>2020-01-15 17:06:59 -0700
committerJason Heard <jasonpheard@gmail.com>2020-01-16 10:16:58 -0700
commitb2a7d4739e7be3c553c5bc7c9b51b6b974a8918b (patch)
tree59d0deba9c0ce9253a646a300e9d6f558df14534 /pkgs/applications
parent67373ae389842d543c66b38a51f45252850b9f28 (diff)
downloadnixlib-b2a7d4739e7be3c553c5bc7c9b51b6b974a8918b.tar
nixlib-b2a7d4739e7be3c553c5bc7c9b51b6b974a8918b.tar.gz
nixlib-b2a7d4739e7be3c553c5bc7c9b51b6b974a8918b.tar.bz2
nixlib-b2a7d4739e7be3c553c5bc7c9b51b6b974a8918b.tar.lz
nixlib-b2a7d4739e7be3c553c5bc7c9b51b6b974a8918b.tar.xz
nixlib-b2a7d4739e7be3c553c5bc7c9b51b6b974a8918b.tar.zst
nixlib-b2a7d4739e7be3c553c5bc7c9b51b6b974a8918b.zip
quodlibet: fix tests
- Add XDG_ICONS_DIRS to XDG_DATA_DIRS so tests can see icons.
- Skip quality tests and remove their dependencies.
- Add gdk-pixbuf to checkInputs to fix a test that uses SVGs.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/quodlibet/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/pkgs/applications/audio/quodlibet/default.nix b/pkgs/applications/audio/quodlibet/default.nix
index 573dca518e3a..4dfa3c0e6546 100644
--- a/pkgs/applications/audio/quodlibet/default.nix
+++ b/pkgs/applications/audio/quodlibet/default.nix
@@ -18,7 +18,7 @@ python3.pkgs.buildPythonApplication rec {
 
   nativeBuildInputs = [ wrapGAppsHook gettext ];
 
-  checkInputs = with python3.pkgs; [ pytest pytest_xdist pyflakes pycodestyle polib xvfb_run dbus.daemon glibcLocales ];
+  checkInputs = [ gdk-pixbuf ] ++ (with python3.pkgs; [ pytest pytest_xdist polib xvfb_run dbus.daemon glibcLocales ]);
 
   buildInputs = [ gnome3.adwaita-icon-theme libsoup glib glib-networking gtk3 webkitgtk gdk-pixbuf keybinder3 gtksourceview libmodplug libappindicator-gtk3 kakasi gobject-introspection ]
     ++ (if xineBackend then [ xineLib ] else with gst_all_1;
@@ -35,11 +35,11 @@ python3.pkgs.buildPythonApplication rec {
 
   checkPhase = ''
     runHook preCheck
-    env XDG_DATA_DIRS="$out/share:${gtk3}/share/gsettings-schemas/${gtk3.name}:$XDG_DATA_DIRS" \
+    env XDG_DATA_DIRS="$out/share:${gtk3}/share/gsettings-schemas/${gtk3.name}:$XDG_ICON_DIRS:$XDG_DATA_DIRS" \
       HOME=$(mktemp -d) \
       xvfb-run -s '-screen 0 800x600x24' dbus-run-session \
         --config-file=${dbus.daemon}/share/dbus-1/session.conf \
-        py.test${stdenv.lib.optionalString (xineBackend || !withGstPlugins) " --ignore=tests/plugin/test_replaygain.py"}
+        py.test ${stdenv.lib.optionalString (xineBackend || !withGstPlugins) " --ignore=tests/plugin/test_replaygain.py"} --ignore=tests/quality
     runHook postCheck
   '';
 
@@ -65,6 +65,5 @@ python3.pkgs.buildPythonApplication rec {
 
     maintainers = with maintainers; [ coroa sauyon ];
     homepage = https://quodlibet.readthedocs.io/en/latest/;
-    broken = true;
   };
 }