about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-08-10 10:41:23 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-08-10 10:41:23 +0200
commitb0c30f436e12a82b789876d11846644bbd1c82bc (patch)
tree25abdfe9c71730579250b555486eb734b219f030 /pkgs/applications
parent60418e9196e7b8941cc2234db00194d614d38aae (diff)
parentc2ef89aac97b6eb8e3efe53173ec8eea7d2ebf17 (diff)
downloadnixlib-b0c30f436e12a82b789876d11846644bbd1c82bc.tar
nixlib-b0c30f436e12a82b789876d11846644bbd1c82bc.tar.gz
nixlib-b0c30f436e12a82b789876d11846644bbd1c82bc.tar.bz2
nixlib-b0c30f436e12a82b789876d11846644bbd1c82bc.tar.lz
nixlib-b0c30f436e12a82b789876d11846644bbd1c82bc.tar.xz
nixlib-b0c30f436e12a82b789876d11846644bbd1c82bc.tar.zst
nixlib-b0c30f436e12a82b789876d11846644bbd1c82bc.zip
Merge remote-tracking branch 'upstream/master' into HEAD
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/android-studio/packages.nix6
-rw-r--r--pkgs/applications/networking/seafile-client/default.nix41
-rw-r--r--pkgs/applications/virtualization/lkl/default.nix6
3 files changed, 21 insertions, 32 deletions
diff --git a/pkgs/applications/editors/android-studio/packages.nix b/pkgs/applications/editors/android-studio/packages.nix
index 17f795ad68db..1a324b544dc3 100644
--- a/pkgs/applications/editors/android-studio/packages.nix
+++ b/pkgs/applications/editors/android-studio/packages.nix
@@ -27,9 +27,9 @@ in rec {
 
   preview = mkStudio rec {
     pname = "android-studio-preview";
-    version = "3.0.0.8"; # This is actually "Android Studio 3.0 Canary 9"
-    build = "171.4220116";
-    sha256Hash = "02aw1m65wb5cgjq1dxm86c5m6p8b41kgjcgsl5d0h93fb4clf64b";
+    version = "3.0.0.9"; # This is actually "Android Studio 3.0 Beta 1"
+    build = "171.4243858";
+    sha256Hash = "137jd4146srjigyzcfds8pf7b185q1qdkb0zp2yqc8g6bv4ccb22";
 
     meta = stable.meta // {
       description = "The Official IDE for Android (preview version)";
diff --git a/pkgs/applications/networking/seafile-client/default.nix b/pkgs/applications/networking/seafile-client/default.nix
index 9c6aefd8ced4..d930e24883ea 100644
--- a/pkgs/applications/networking/seafile-client/default.nix
+++ b/pkgs/applications/networking/seafile-client/default.nix
@@ -1,39 +1,28 @@
-{stdenv, fetchurl, writeScript, pkgconfig, cmake, qt4, seafile-shared, ccnet, makeWrapper}:
+{ stdenv, fetchurl, writeScript, pkgconfig, cmake, qtbase, qttools
+, seafile-shared, ccnet, makeWrapper }:
 
-stdenv.mkDerivation rec
-{
-  version = "5.0.7";
+stdenv.mkDerivation rec {
+  version = "6.1.0";
   name = "seafile-client-${version}";
 
-  src = fetchurl
-  {
+  src = fetchurl {
     url = "https://github.com/haiwen/seafile-client/archive/v${version}.tar.gz";
-    sha256 = "ae6975bc1adf45d09cf9f6332ceac7cf285f8191f6cf50c6291ed45f8cf4ffa5";
+    sha256 = "16rn6b9ayaccgwx8hs3yh1wb395pp8ffh8may8a8bpcc4gdry7bd";
   };
 
-  buildInputs = [ pkgconfig cmake qt4 seafile-shared makeWrapper ];
-
-  builder = writeScript "${name}-builder.sh" ''
-    source $stdenv/setup
-
-    tar xvfz $src
-    cd seafile-client-*
-
-    cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_SKIP_BUILD_RPATH=ON -DCMAKE_INSTALL_PREFIX="$out" .
-    make -j1
-
-    make install
+  nativeBuildInputs = [ pkgconfig cmake makeWrapper ];
+  buildInputs = [ qtbase qttools seafile-shared ];
 
+  postInstall = ''
     wrapProgram $out/bin/seafile-applet \
       --suffix PATH : ${stdenv.lib.makeBinPath [ ccnet seafile-shared ]}
-    '';
+  '';
 
-  meta =
-  {
-    homepage = https://github.com/haiwen/seafile-clients;
+  meta = with stdenv.lib; {
+    homepage = https://github.com/haiwen/seafile-client;
     description = "Desktop client for Seafile, the Next-generation Open Source Cloud Storage";
-    license = stdenv.lib.licenses.asl20;
-    platforms = stdenv.lib.platforms.linux;
-    maintainers = [ stdenv.lib.maintainers.calrama ];
+    license = licenses.asl20;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.calrama ];
   };
 }
diff --git a/pkgs/applications/virtualization/lkl/default.nix b/pkgs/applications/virtualization/lkl/default.nix
index d1bf5792a1b4..b790a15e607f 100644
--- a/pkgs/applications/virtualization/lkl/default.nix
+++ b/pkgs/applications/virtualization/lkl/default.nix
@@ -1,8 +1,8 @@
 { stdenv, fetchFromGitHub, bc, python, fuse, libarchive }:
 
 stdenv.mkDerivation rec {
-  name = "lkl-2017-06-27";
-  rev  = "0d91d102b046eec535a6d67df9829b80b24e9ce9";
+  name = "lkl-2017-08-09";
+  rev  = "083cdeece0577635d523244dcf0da86074e23e4e";
 
   outputs = [ "dev" "lib" "out" ];
 
@@ -14,7 +14,7 @@ stdenv.mkDerivation rec {
     inherit rev;
     owner  = "lkl";
     repo   = "linux";
-    sha256 = "1sc18fik2dm0hnsb5q4srvwbf6wgv27zlf3qa7x39g4vbj1jqgas";
+    sha256 = "1fyh0p54jgsqywswj40zbw64jbqx2w10wax1k3j2szzlhjrv9x1a";
   };
 
   # Fix a /usr/bin/env reference in here that breaks sandboxed builds