about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2013-05-21 22:48:50 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2013-05-21 22:48:50 +0200
commitaf6503b2af316fc00125de5e15a35996ed3eeb83 (patch)
tree52e16c06adbc0729ef4581799fe6bdff5095d286 /pkgs/applications
parentdc28cdf721d6b3c6a5be1b730745ec86f7b64de6 (diff)
downloadnixlib-af6503b2af316fc00125de5e15a35996ed3eeb83.tar
nixlib-af6503b2af316fc00125de5e15a35996ed3eeb83.tar.gz
nixlib-af6503b2af316fc00125de5e15a35996ed3eeb83.tar.bz2
nixlib-af6503b2af316fc00125de5e15a35996ed3eeb83.tar.lz
nixlib-af6503b2af316fc00125de5e15a35996ed3eeb83.tar.xz
nixlib-af6503b2af316fc00125de5e15a35996ed3eeb83.tar.zst
nixlib-af6503b2af316fc00125de5e15a35996ed3eeb83.zip
wireshark: add desktop item
And fix a small "ethereal" typo.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/sniffers/wireshark/default.nix20
1 files changed, 19 insertions, 1 deletions
diff --git a/pkgs/applications/networking/sniffers/wireshark/default.nix b/pkgs/applications/networking/sniffers/wireshark/default.nix
index 31ec394b2dcc..21a21a1d7acb 100644
--- a/pkgs/applications/networking/sniffers/wireshark/default.nix
+++ b/pkgs/applications/networking/sniffers/wireshark/default.nix
@@ -1,6 +1,7 @@
 { stdenv, fetchurl, perl, pkgconfig, gtk, libpcap, flex, bison
 , gnutls, libgcrypt, glib, zlib, libxml2, libxslt, adns, geoip
 , heimdal, python, lynx, lua5
+, makeDesktopItem
 }:
 
 let version = "1.8.6"; in
@@ -20,13 +21,30 @@ stdenv.mkDerivation {
 
   configureFlags = "--disable-usr-local --with-ssl --enable-threads --enable-packet-editor";
 
+  desktopItem = makeDesktopItem {
+    name = "Wireshark";
+    exec = "wireshark";
+    icon = "wireshark";
+    comment = "Powerful network protocol analysis suite";
+    desktopName = "Wireshark";
+    genericName = "Network packet analyzer";
+    categories = "Network;System";
+  };
+
+  postInstall = ''
+    mkdir -p "$out"/share/applications/
+    mkdir -p "$out"/share/icons/
+    cp "$desktopItem"/share/applications/* "$out"/share/applications/
+    cp image/wsicon.svg "$out"/share/icons/wireshark.svg
+  '';
+
   meta = {
     homepage = http://www.wireshark.org/;
     description = "a powerful network protocol analyzer";
     license = stdenv.lib.licenses.gpl2;
 
     longDescription = ''
-      Wireshark (formerly known as "Etherreal") is a powerful network
+      Wireshark (formerly known as "Ethereal") is a powerful network
       protocol analyzer developed by an international team of networking
       experts. It runs on UNIX, OS X and Windows.
     '';