about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-10 12:03:24 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-10 12:03:24 -0400
commitad838f6f91fcc89a2c9b1a6b85e7551181c30f95 (patch)
tree886e434f1fc652b9c9afdcef725174dce0ef7aaa /pkgs/applications
parentc248aa40b1102e1d450c1730424d9048648ffc19 (diff)
parent79adb993fbafeb89062e9b948e916d89311f7ca6 (diff)
downloadnixlib-ad838f6f91fcc89a2c9b1a6b85e7551181c30f95.tar
nixlib-ad838f6f91fcc89a2c9b1a6b85e7551181c30f95.tar.gz
nixlib-ad838f6f91fcc89a2c9b1a6b85e7551181c30f95.tar.bz2
nixlib-ad838f6f91fcc89a2c9b1a6b85e7551181c30f95.tar.lz
nixlib-ad838f6f91fcc89a2c9b1a6b85e7551181c30f95.tar.xz
nixlib-ad838f6f91fcc89a2c9b1a6b85e7551181c30f95.tar.zst
nixlib-ad838f6f91fcc89a2c9b1a6b85e7551181c30f95.zip
Merge branch 'fewer-crossAttrs' into staging
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/math/yacas/default.nix59
-rw-r--r--pkgs/applications/science/math/yacas/gcc43.patch17
-rw-r--r--pkgs/applications/version-management/fossil/default.nix15
3 files changed, 33 insertions, 58 deletions
diff --git a/pkgs/applications/science/math/yacas/default.nix b/pkgs/applications/science/math/yacas/default.nix
index 0f6dc35fe0cb..c02ef73df119 100644
--- a/pkgs/applications/science/math/yacas/default.nix
+++ b/pkgs/applications/science/math/yacas/default.nix
@@ -1,44 +1,39 @@
-{stdenv, fetchurl, perl}: 
+{ stdenv, fetchFromGitHub, cmake, perl
+, enableGui ? false, qt5
+, enableJupyter ? false, boost, jsoncpp, openssl, zmqpp
+}:
 
 stdenv.mkDerivation rec {
-  name = "yacas-1.2.2";
+  name = "yacas-${version}";
+  version = "1.6.1";
 
-  src = fetchurl {
-    url = "http://yacas.sourceforge.net/backups/${name}.tar.gz";
-    sha256 = "1dmafm3w0lm5w211nwkfzaid1rvvmgskz7k4500pjhgdczi5sd78";
+  src = fetchFromGitHub {
+    owner = "grzegorzmazur";
+    repo = "yacas";
+    rev = "v${version}";
+    sha256 = "0awvlvf607r4hwl1vkhs6jq2s6ig46c66pmr4vspj2cdnypx99cc";
   };
 
   hardeningDisable = [ "format" ];
 
-  # Perl is only for the documentation
-  nativeBuildInputs = [ perl ];
-
-  patches = [ ./gcc43.patch ];
+  cmakeFlags = [
+    "-DENABLE_CYACAS_GUI=${if enableGui then "ON" else "OFF"}"
+    "-DENABLE_CYACAS_KERNEL=${if enableJupyter then "ON" else "OFF"}"
+  ];
 
-  crossAttrs = {
-    # Trick to get host-built programs needed for the cross-build.
-    # If yacas had proper makefiles, this would not be needed.
-    preConfigure = ''
-      ./configure
-      pushd src
-      make mkfastprimes 
-      cp mkfastprimes ../..
-      popd
-      pushd manmake
-      make manripper removeduplicates
-      cp manripper removeduplicates ../..
-      popd
-    '';
-    preBuild = ''
-      cp ../mkfastprimes ../manripper ../removeduplicates src
-    '';
-  };
+  # Perl is only for the documentation
+  nativeBuildInputs = [ cmake perl ];
+  buildInputs = [
+  ] ++ stdenv.lib.optionals enableGui (with qt5; [ qtbase qtwebkit ])
+    ++ stdenv.lib.optionals enableJupyter [ boost jsoncpp openssl zmqpp ]
+    ;
 
   meta = {
-      description = "Easy to use, general purpose Computer Algebra System";
-      homepage = http://yacas.sourceforge.net/;
-      license = stdenv.lib.licenses.gpl2Plus;
-      maintainers = with stdenv.lib.maintainers; [viric];
-      platforms = with stdenv.lib.platforms; linux;
+    description = "Easy to use, general purpose Computer Algebra System";
+    homepage = http://www.yacas.org/;
+    license = stdenv.lib.licenses.gpl2Plus;
+    maintainers = with stdenv.lib.maintainers; [viric];
+    platforms = with stdenv.lib.platforms; linux;
+    broken = enableGui || enableJupyter;
   };
 }
diff --git a/pkgs/applications/science/math/yacas/gcc43.patch b/pkgs/applications/science/math/yacas/gcc43.patch
deleted file mode 100644
index 054f80cff927..000000000000
--- a/pkgs/applications/science/math/yacas/gcc43.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Taken from gentoo:
-http://sources.gentoo.org/viewcvs.py/gentoo-x86/sci-mathematics/yacas/files/yacas-1.2.2-gcc43.patch?rev=1.1&view=markup
-Index: yacas-1.2.2-gcc43.patch
-===================================================================
---- a/manmake/manripper.cpp
-+++ b/manmake/manripper.cpp
-@@ -1,7 +1,8 @@
- 
--#include <stdio.h>
--#include <ctype.h>
-+#include <cstdio>
-+#include <cctype>
- #include <string>
-+#include <cstring>
- #include <map>
- 
- using namespace std;
diff --git a/pkgs/applications/version-management/fossil/default.nix b/pkgs/applications/version-management/fossil/default.nix
index f46a704ea9ca..1373e13c4147 100644
--- a/pkgs/applications/version-management/fossil/default.nix
+++ b/pkgs/applications/version-management/fossil/default.nix
@@ -1,5 +1,7 @@
-{stdenv, libiconv, fetchurl, zlib, openssl, tcl, readline, sqlite, ed, which
-, tcllib, withJson ? true}:
+{ stdenv
+, libiconv, fetchurl, zlib, openssl, tcl, readline, sqlite, ed, which
+, tcllib, withJson ? true
+}:
 
 stdenv.mkDerivation rec {
   name = "fossil-${version}";
@@ -18,11 +20,11 @@ stdenv.mkDerivation rec {
              ++ stdenv.lib.optional stdenv.isDarwin libiconv;
   nativeBuildInputs = [ tcl ];
 
-  doCheck = true;
+  doCheck = stdenv.hostPlatform == stdenv.buildPlatform;
 
   checkTarget = "test";
 
-  preCheck = ''
+  preCheck = stdenv.lib.optional doCheck ''
     export TCLLIBPATH="${tcllib}/lib/tcllib${tcllib.version}"
   '';
   configureFlags = if withJson then  "--json" else  "";
@@ -36,11 +38,6 @@ stdenv.mkDerivation rec {
     INSTALLDIR=$out/bin make install
   '';
 
-  crossAttrs = {
-    doCheck = false;
-    makeFlags = [ "TCC=$CC" ];
-  };
-
   meta = {
     description = "Simple, high-reliability, distributed software configuration management";
     longDescription = ''