about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMathijs Kwik <mathijs@bluescreen303.nl>2014-06-05 15:42:39 +0200
committerMathijs Kwik <mathijs@bluescreen303.nl>2014-06-16 22:43:10 +0200
commitab8337e4fcd14ce70c27a0ae98e7241f41b8e71d (patch)
treefbabb7c1c5ebe73b31d929c59b711082447eb070 /pkgs/applications
parentc585786c1fccaac001ef7e20227219e0aabef696 (diff)
downloadnixlib-ab8337e4fcd14ce70c27a0ae98e7241f41b8e71d.tar
nixlib-ab8337e4fcd14ce70c27a0ae98e7241f41b8e71d.tar.gz
nixlib-ab8337e4fcd14ce70c27a0ae98e7241f41b8e71d.tar.bz2
nixlib-ab8337e4fcd14ce70c27a0ae98e7241f41b8e71d.tar.lz
nixlib-ab8337e4fcd14ce70c27a0ae98e7241f41b8e71d.tar.xz
nixlib-ab8337e4fcd14ce70c27a0ae98e7241f41b8e71d.tar.zst
nixlib-ab8337e4fcd14ce70c27a0ae98e7241f41b8e71d.zip
add emacs-metaweblog
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-modes/metaweblog/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/applications/editors/emacs-modes/metaweblog/default.nix b/pkgs/applications/editors/emacs-modes/metaweblog/default.nix
new file mode 100644
index 000000000000..2a35c6ef6950
--- /dev/null
+++ b/pkgs/applications/editors/emacs-modes/metaweblog/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchgit, emacs, xmlRpc }:
+
+stdenv.mkDerivation rec {
+  name = "metaweblog-0.1";
+
+  src = fetchgit {
+    url = https://github.com/punchagan/metaweblog.git;
+    rev = "ceda65048afaa4c7596c7f50ced998c59ef41167";
+    sha256 = "a4c10bb1b4be574e560f87d5f07da4e24e5fffe9ecc83e6d4f9325f3a7eb1e2f";
+  };
+
+  buildInputs = [ emacs ];
+  propagatedUserEnvPkgs = [ xmlRpc ];
+
+  buildPhase = ''
+    emacs -L . -L ${xmlRpc}/share/emacs/site-lisp --batch -f batch-byte-compile *.el
+  '';
+
+  installPhase = ''
+    install -d $out/share/emacs/site-lisp
+    install *.el* $out/share/emacs/site-lisp
+  '';
+
+  meta = {
+    description = "an emacs library to access metaweblog based weblogs";
+    homepage = https://github.com/punchagan/metaweblog;
+    license = "GPLv3+";
+
+    platforms = stdenv.lib.platforms.all;
+  };
+}