about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorNaïm Favier <n@monade.li>2021-09-03 13:58:51 +0200
committerNaïm Favier <n@monade.li>2021-09-03 17:36:36 +0200
commita75326417df32c0354e3244a9461700d214eab82 (patch)
treeb41964ed4f25f7c4c79dcb1979220693bc5e3809 /pkgs/applications
parentd14e9188d1cd88f1b530bf860638c2de27486a6d (diff)
downloadnixlib-a75326417df32c0354e3244a9461700d214eab82.tar
nixlib-a75326417df32c0354e3244a9461700d214eab82.tar.gz
nixlib-a75326417df32c0354e3244a9461700d214eab82.tar.bz2
nixlib-a75326417df32c0354e3244a9461700d214eab82.tar.lz
nixlib-a75326417df32c0354e3244a9461700d214eab82.tar.xz
nixlib-a75326417df32c0354e3244a9461700d214eab82.tar.zst
nixlib-a75326417df32c0354e3244a9461700d214eab82.zip
vscode,vscodium: fix moving files to the trash
Put gio in PATH so that VSCode is able to move files to the trash.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/vscode/generic.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/applications/editors/vscode/generic.nix b/pkgs/applications/editors/vscode/generic.nix
index 7279d6bf60b5..4363f83ba037 100644
--- a/pkgs/applications/editors/vscode/generic.nix
+++ b/pkgs/applications/editors/vscode/generic.nix
@@ -1,7 +1,7 @@
 { stdenv, lib, makeDesktopItem
 , unzip, libsecret, libXScrnSaver, libxshmfence, wrapGAppsHook
 , gtk2, atomEnv, at-spi2-atk, autoPatchelfHook
-, systemd, fontconfig, libdbusmenu, buildFHSUserEnvBubblewrap
+, systemd, fontconfig, libdbusmenu, glib, buildFHSUserEnvBubblewrap
 , writeShellScriptBin
 
 # Populate passthru.tests
@@ -101,6 +101,13 @@ let
       runHook postInstall
     '';
 
+    preFixup = ''
+      gappsWrapperArgs+=(
+        # Add gio to PATH so that moving files to the trash works when not using a desktop environment
+        --prefix PATH : ${glib.bin}/bin
+      )
+    '';
+
     inherit meta;
   };