about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTimo Kaufmann <timokau@zoho.com>2018-11-24 20:47:03 +0100
committerTimo Kaufmann <timokau@zoho.com>2018-11-24 23:14:38 +0100
commita0723f1285a07f28171720a6742777625e3628fa (patch)
tree65e592020dafa0fe9368a5abc4d87ba7adf8724b /pkgs/applications
parente28a8ed2878633c7f4e343a6dff6d6a6a4ce2d4d (diff)
downloadnixlib-a0723f1285a07f28171720a6742777625e3628fa.tar
nixlib-a0723f1285a07f28171720a6742777625e3628fa.tar.gz
nixlib-a0723f1285a07f28171720a6742777625e3628fa.tar.bz2
nixlib-a0723f1285a07f28171720a6742777625e3628fa.tar.lz
nixlib-a0723f1285a07f28171720a6742777625e3628fa.tar.xz
nixlib-a0723f1285a07f28171720a6742777625e3628fa.tar.zst
nixlib-a0723f1285a07f28171720a6742777625e3628fa.zip
sage: don't fix node version
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/math/sage/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/pkgs/applications/science/math/sage/default.nix b/pkgs/applications/science/math/sage/default.nix
index ce64f5522244..fda827696d3d 100644
--- a/pkgs/applications/science/math/sage/default.nix
+++ b/pkgs/applications/science/math/sage/default.nix
@@ -7,7 +7,7 @@
 # is always preferred, see `sage-src.nix` for that.
 
 let
-  inherit (pkgs) fetchurl symlinkJoin callPackage nodePackages_8_x;
+  inherit (pkgs) fetchurl symlinkJoin callPackage nodePackages;
 
   # https://trac.sagemath.org/ticket/15980 for tracking of python3 support
   python = pkgs.python2.override {
@@ -24,7 +24,7 @@ let
       flask-openid = self.callPackage ./flask-openid.nix {};
       python-openid = self.callPackage ./python-openid.nix {};
       sagenb = self.callPackage ./sagenb.nix {
-        mathjax = nodePackages_8_x.mathjax;
+        mathjax = nodePackages.mathjax;
       };
 
       # Package with a cyclic dependency with sage
@@ -45,8 +45,8 @@ let
     inherit pari_data ecl;
     inherit singular;
     cysignals = python.pkgs.cysignals;
-    three = nodePackages_8_x.three;
-    mathjax = nodePackages_8_x.mathjax;
+    three = nodePackages.three;
+    mathjax = nodePackages.mathjax;
   };
 
   # The shell file that gets sourced on every sage start. Will also source
@@ -70,7 +70,7 @@ let
     inherit sage-env;
     inherit pynac singular;
     pkg-config = pkgs.pkgconfig; # not to confuse with pythonPackages.pkgconfig
-    three = nodePackages_8_x.three;
+    three = nodePackages.three;
   };
 
   # Doesn't actually build anything, just runs sages testsuite. This is a