about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2019-10-24 04:20:00 -0500
committerJon <jonringer@users.noreply.github.com>2019-10-24 18:50:34 -0700
commit9e5a30b43e2c5c99801f3748db65efff58f665d6 (patch)
tree1a95e4317d1120cbb94ba01cbb3f14b426ee229e /pkgs/applications
parentb4658834aa34d20a86e29b03436c0751ba042ee5 (diff)
downloadnixlib-9e5a30b43e2c5c99801f3748db65efff58f665d6.tar
nixlib-9e5a30b43e2c5c99801f3748db65efff58f665d6.tar.gz
nixlib-9e5a30b43e2c5c99801f3748db65efff58f665d6.tar.bz2
nixlib-9e5a30b43e2c5c99801f3748db65efff58f665d6.tar.lz
nixlib-9e5a30b43e2c5c99801f3748db65efff58f665d6.tar.xz
nixlib-9e5a30b43e2c5c99801f3748db65efff58f665d6.tar.zst
nixlib-9e5a30b43e2c5c99801f3748db65efff58f665d6.zip
git-backup: init at 0.2.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/git-backup/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/applications/version-management/git-backup/default.nix b/pkgs/applications/version-management/git-backup/default.nix
new file mode 100644
index 000000000000..9d05fb830313
--- /dev/null
+++ b/pkgs/applications/version-management/git-backup/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, fetchFromGitHub, rustPlatform, pkg-config, openssl, Security }:
+
+rustPlatform.buildRustPackage rec {
+  pname = "git-backup";
+  version = "0.2.0";
+
+  src = fetchFromGitHub {
+    owner = "jsdw";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "0h31j8clvk4gkw4mgva9p0ypf26zhf7f0y564fdmzyw6rsz9wzcj";
+  };
+
+  cargoSha256 = "1vfyhfdy5ks9zs9sy61ck9459w86hn9v6jqcar7rib82bclzr1mx";
+
+  nativeBuildInputs = [ pkg-config ];
+
+  buildInputs = [ openssl ] ++ stdenv.lib.optionals stdenv.isDarwin [ Security ];
+
+  meta = with stdenv.lib; {
+    homepage = "https://github.com/jsdw/git-backup";
+    description = "A tool to help you backup your git repositories from services like GitHub";
+    license = licenses.mit;
+    maintainers = [ maintainers.marsam ];
+  };
+}