about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2021-10-06 23:57:04 +0200
committerGitHub <noreply@github.com>2021-10-06 23:57:04 +0200
commit9e016672b17fb167f8cb8c6e854bfa6109b3c6ba (patch)
treeb339113eeb2a4c9038c6d036f485c5568d3afaaf /pkgs/applications
parent68f25d5a86282be8fac90116db3ac676988ef04b (diff)
parent7ad2a73cb286223c2f5116f2a728f42aa0467c98 (diff)
downloadnixlib-9e016672b17fb167f8cb8c6e854bfa6109b3c6ba.tar
nixlib-9e016672b17fb167f8cb8c6e854bfa6109b3c6ba.tar.gz
nixlib-9e016672b17fb167f8cb8c6e854bfa6109b3c6ba.tar.bz2
nixlib-9e016672b17fb167f8cb8c6e854bfa6109b3c6ba.tar.lz
nixlib-9e016672b17fb167f8cb8c6e854bfa6109b3c6ba.tar.xz
nixlib-9e016672b17fb167f8cb8c6e854bfa6109b3c6ba.tar.zst
nixlib-9e016672b17fb167f8cb8c6e854bfa6109b3c6ba.zip
Merge pull request #140523 from hjones2199/gpsd-fixes
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/kde/marble.nix11
-rw-r--r--pkgs/applications/misc/foxtrotgps/default.nix20
2 files changed, 24 insertions, 7 deletions
diff --git a/pkgs/applications/kde/marble.nix b/pkgs/applications/kde/marble.nix
index 7fe3aa529fa2..637ae3bc977e 100644
--- a/pkgs/applications/kde/marble.nix
+++ b/pkgs/applications/kde/marble.nix
@@ -2,7 +2,7 @@
 , extra-cmake-modules, kdoctools
 , qtscript, qtsvg, qtquickcontrols, qtwebengine
 , krunner, shared-mime-info, kparts, knewstuff
-, gpsd, perl
+, gpsd, perl, fetchpatch
 }:
 
 mkDerivation {
@@ -18,6 +18,15 @@ mkDerivation {
     qtscript qtsvg qtquickcontrols qtwebengine shared-mime-info krunner kparts
     knewstuff gpsd
   ];
+  patches = [
+    (fetchpatch {
+      # Backport fix to allow compilation with gpsd 3.23.1
+      # Remove when marble compiles without the patch.
+      # See: https://invent.kde.org/education/marble/-/merge_requests/57
+      url = "https://invent.kde.org/education/marble/-/commit/8aadc3eb8f9484a65d497d442cd8c61fe1462bef.diff";
+      sha256 = "sha256-ZkPXyunVItSRctv6SLGIonvyZwLDhCz+wfJrIXeHcDo=";
+    })
+  ];
   preConfigure = ''
     cmakeFlags+=" -DINCLUDE_INSTALL_DIR=''${!outputDev}/include"
   '';
diff --git a/pkgs/applications/misc/foxtrotgps/default.nix b/pkgs/applications/misc/foxtrotgps/default.nix
index 8692ac98933b..745a2357e236 100644
--- a/pkgs/applications/misc/foxtrotgps/default.nix
+++ b/pkgs/applications/misc/foxtrotgps/default.nix
@@ -6,8 +6,8 @@ let
   srcs = {
     foxtrot = fetchbzr {
       url = "lp:foxtrotgps";
-      rev = "329";
-      sha256 = "0fwgnsrah63h1xdgm5xdi5ancrz89shdp5sdzw1qc1m7i9a03rid";
+      rev = "331";
+      sha256 = "sha256-/kJv6a3MzAzzwIl98Mqi7jrUJC1kDvouigf9kGtv868=";
     };
     screenshots = fetchbzr {
       url = "lp:foxtrotgps/screenshots";
@@ -17,7 +17,7 @@ let
   };
 in stdenv.mkDerivation rec {
   pname = "foxtrotgps";
-  version = "1.2.2+329";
+  version = "1.2.2+331";
 
   # Pull directly from bzr because gpsd API version 9 is not supported on latest release
   src = srcs.foxtrot;
@@ -39,12 +39,20 @@ in stdenv.mkDerivation rec {
   ];
 
   postUnpack = ''
-  cp -R ${srcs.screenshots} $sourceRoot/doc/screenshots
-  chmod -R u+w $sourceRoot/doc/screenshots
+    cp -R ${srcs.screenshots} $sourceRoot/doc/screenshots
+    chmod -R u+w $sourceRoot/doc/screenshots
+  '';
+
+  # Remove when foxtrotgps supports gpsd 3.23.1
+  # Patch for compatibility with gpsd 3.23.1. This was added for foxtrotgps
+  # 1.2.2+331. The command can be removed if the build of a newer version
+  # succeeds without it.
+  postPatch = ''
+    substituteInPlace src/gps_functions.c --replace "STATUS_NO_FIX" "STATUS_UNK"
   '';
 
   preConfigure = ''
-  intltoolize --automake --copy --force
+    intltoolize --automake --copy --force
   '';
 
   meta = with lib; {