about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2020-05-06 21:08:51 -0500
committerGitHub <noreply@github.com>2020-05-06 21:08:51 -0500
commit9d959ff8d550eb8b09735fa8d3483b581818b03d (patch)
tree4dad9f6d3653fabaf66360b91eaf57d0306714bf /pkgs/applications
parent90888c3cab5358f5f799346085120564ca0876ea (diff)
parentf8d9d72f0eb9b327e7bffeb3bcab90e5f58917a3 (diff)
downloadnixlib-9d959ff8d550eb8b09735fa8d3483b581818b03d.tar
nixlib-9d959ff8d550eb8b09735fa8d3483b581818b03d.tar.gz
nixlib-9d959ff8d550eb8b09735fa8d3483b581818b03d.tar.bz2
nixlib-9d959ff8d550eb8b09735fa8d3483b581818b03d.tar.lz
nixlib-9d959ff8d550eb8b09735fa8d3483b581818b03d.tar.xz
nixlib-9d959ff8d550eb8b09735fa8d3483b581818b03d.tar.zst
nixlib-9d959ff8d550eb8b09735fa8d3483b581818b03d.zip
Merge pull request #86638 from zowoq/cri-shell
cri-o, cri-tools: install completion, manpages
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/virtualization/cri-o/default.nix46
1 files changed, 33 insertions, 13 deletions
diff --git a/pkgs/applications/virtualization/cri-o/default.nix b/pkgs/applications/virtualization/cri-o/default.nix
index 2fd3a0b39dd6..4c3d9ffc937c 100644
--- a/pkgs/applications/virtualization/cri-o/default.nix
+++ b/pkgs/applications/virtualization/cri-o/default.nix
@@ -3,25 +3,24 @@
 , btrfs-progs
 , buildGoPackage
 , fetchFromGitHub
-, git
 , glibc
 , gpgme
+, installShellFiles
 , libapparmor
 , libassuan
 , libgpgerror
 , libseccomp
 , libselinux
 , lvm2
-, pkgconfig
-, which
+, pkg-config
 }:
 
 buildGoPackage rec {
-  project = "cri-o";
+  pname = "cri-o";
   version = "1.18.0";
-  name = "${project}-${version}${flavor}";
+  name = "${pname}-${version}${flavor}";
 
-  goPackagePath = "github.com/${project}/${project}";
+  goPackagePath = "github.com/cri-o/cri-o";
 
   src = fetchFromGitHub {
     owner = "cri-o";
@@ -30,27 +29,48 @@ buildGoPackage rec {
     sha256 = "142flmv54pj48rjqkd26fbxrcbx2cv6pdmrc33jgyvn6r99zliah";
   };
 
-  nativeBuildInputs = [ git pkgconfig which ];
-  buildInputs = [ btrfs-progs gpgme libapparmor libassuan libgpgerror
-                 libseccomp libselinux lvm2 ]
-                ++ stdenv.lib.optionals (glibc != null) [ glibc glibc.static ];
+  outputs = [ "out" "man" ];
+
+  nativeBuildInputs = [ installShellFiles pkg-config ];
+
+  buildInputs = [
+    btrfs-progs
+    gpgme
+    libapparmor
+    libassuan
+    libgpgerror
+    libseccomp
+    libselinux
+    lvm2
+  ] ++ stdenv.lib.optionals (glibc != null) [ glibc glibc.static ];
 
   BUILDTAGS = "apparmor seccomp selinux containers_image_ostree_stub";
   buildPhase = ''
     pushd go/src/${goPackagePath}
 
-    make binaries BUILDTAGS="$BUILDTAGS"
+    sed -i '/version.buildDate/d' Makefile
+
+    make binaries docs BUILDTAGS="$BUILDTAGS"
   '';
+
   installPhase = ''
     install -Dm755 bin/crio $out/bin/crio${flavor}
     install -Dm755 bin/crio-status $out/bin/crio-status${flavor}
     install -Dm755 bin/pinns $out/bin/pinns${flavor}
+
+    for shell in bash fish zsh; do
+      installShellCompletion --$shell completions/$shell/*
+    done
+
+    installManPage docs/*.[1-9]
   '';
 
   meta = with stdenv.lib; {
     homepage = "https://cri-o.io";
-    description = ''Open Container Initiative-based implementation of the
-                    Kubernetes Container Runtime Interface'';
+    description = ''
+      Open Container Initiative-based implementation of the
+      Kubernetes Container Runtime Interface
+    '';
     license = licenses.asl20;
     maintainers = with maintainers; [ ] ++ teams.podman.members;
     platforms = platforms.linux;