about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorArtjom Vejsel <akawolf0@gmail.com>2015-07-26 10:29:56 +0300
committerVladimír Čunát <vcunat@gmail.com>2015-07-26 12:08:07 +0200
commit9ca034f277209aad437e169ae3a555f6372328a4 (patch)
tree75d9c02bbdf4547b80341e3c0337fee755f3061c /pkgs/applications
parent1a4bb0ef9b4abc14325541ce2f145c364838de12 (diff)
downloadnixlib-9ca034f277209aad437e169ae3a555f6372328a4.tar
nixlib-9ca034f277209aad437e169ae3a555f6372328a4.tar.gz
nixlib-9ca034f277209aad437e169ae3a555f6372328a4.tar.bz2
nixlib-9ca034f277209aad437e169ae3a555f6372328a4.tar.lz
nixlib-9ca034f277209aad437e169ae3a555f6372328a4.tar.xz
nixlib-9ca034f277209aad437e169ae3a555f6372328a4.tar.zst
nixlib-9ca034f277209aad437e169ae3a555f6372328a4.zip
purple-vk-plugin: init at 40ddb6d (close #8996)
@vcunat simplified preConfigure.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/instant-messengers/pidgin-plugins/purple-vk-plugin/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/applications/networking/instant-messengers/pidgin-plugins/purple-vk-plugin/default.nix b/pkgs/applications/networking/instant-messengers/pidgin-plugins/purple-vk-plugin/default.nix
new file mode 100644
index 000000000000..0a96d8749aef
--- /dev/null
+++ b/pkgs/applications/networking/instant-messengers/pidgin-plugins/purple-vk-plugin/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchhg, pidgin, cmake, libxml2 } :
+
+let
+  version = "40ddb6d";
+in
+stdenv.mkDerivation rec {
+  name = "purple-vk-plugin-${version}";
+
+  src = fetchhg {
+    url = "https://bitbucket.org/olegoandreev/purple-vk-plugin";
+    rev = "${version}";
+    sha256 = "02p57fgx8ml00cbrb4f280ak2802svz80836dzk9f1zwm1bcr2qc";
+  };
+
+  buildInputs = [ pidgin cmake libxml2 ];
+
+  preConfigure = ''
+    sed -i -e 's|DESTINATION.*PURPLE_PLUGIN_DIR}|DESTINATION lib/purple-2|' CMakeLists.txt
+  '';
+
+  cmakeFlags = "-DCMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT=1";
+
+  meta = {
+    homepage = https://bitbucket.org/olegoandreev/purple-vk-plugin;
+    description = "Vk (russian social network) plugin for Pidgin / libpurple";
+    license = stdenv.lib.licenses.gpl3;
+  };
+}