about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTim Steinbach <NeQuissimus@users.noreply.github.com>2017-04-01 13:49:22 -0400
committerGitHub <noreply@github.com>2017-04-01 13:49:21 -0400
commit9bf115c46a2435d95fe285a5b05b69ef5af86851 (patch)
tree00ce89ee83dee814a844767bdbfe95008de52412 /pkgs/applications
parent9e1537cd2130ab929e94bfccaff7d8808d468919 (diff)
parentc9d02b7c573774d2ffd2add2192ec92d60a12396 (diff)
downloadnixlib-9bf115c46a2435d95fe285a5b05b69ef5af86851.tar
nixlib-9bf115c46a2435d95fe285a5b05b69ef5af86851.tar.gz
nixlib-9bf115c46a2435d95fe285a5b05b69ef5af86851.tar.bz2
nixlib-9bf115c46a2435d95fe285a5b05b69ef5af86851.tar.lz
nixlib-9bf115c46a2435d95fe285a5b05b69ef5af86851.tar.xz
nixlib-9bf115c46a2435d95fe285a5b05b69ef5af86851.tar.zst
nixlib-9bf115c46a2435d95fe285a5b05b69ef5af86851.zip
Merge pull request #24509 from tilpner/master
vscode: Fix relocation errors
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/vscode/default.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/pkgs/applications/editors/vscode/default.nix b/pkgs/applications/editors/vscode/default.nix
index 3031fa1cb0c1..c46640602141 100644
--- a/pkgs/applications/editors/vscode/default.nix
+++ b/pkgs/applications/editors/vscode/default.nix
@@ -55,7 +55,7 @@ in
       '' else ''
         mkdir -p $out/lib/vscode $out/bin
         cp -r ./* $out/lib/vscode
-        ln -s $out/lib/vscode/code $out/bin
+        ln -s $out/lib/vscode/bin/code $out/bin
 
         mkdir -p $out/share/applications
         cp $desktopItem/share/applications/* $out/share/applications
@@ -67,11 +67,8 @@ in
     postFixup = lib.optionalString (stdenv.system == "i686-linux" || stdenv.system == "x86_64-linux") ''
       patchelf \
         --set-interpreter "$(cat $NIX_CC/nix-support/dynamic-linker)" \
-        --set-rpath "${atomEnv.libPath}:$out/lib/vscode" \
+        --set-rpath "${atomEnv.libPath}:${stdenv.lib.makeLibraryPath [libXScrnSaver]}/libXss.so.1:$out/lib/vscode" \
         $out/lib/vscode/code
-
-      wrapProgram $out/bin/code \
-        --prefix LD_PRELOAD : ${stdenv.lib.makeLibraryPath [ libXScrnSaver ]}/libXss.so.1
     '';
 
     meta = with stdenv.lib; {